Skocz do zawartości

artbe

Użytkownicy
  • Zawartość

    3
  • Rejestracja

  • Ostatnio

Reputacja

0 Neutralna

O artbe

  • Ranga
    1/10

Informacje

  • Płeć
    Mężczyzna
  1. Hej Mam pewien problem i już nie rozumiem co robię źle. W moim projekcie z jednej strony potrzebuję 5V do taśm ledów, z drugiej strony chcę zasilać arduino poprzez tę wtyczkę na zasilanie DC, więc potrzebuję min. 7V. Mój plan polega na tym, że biorę zasilacz DC 12V 2A (taki akurat mam), wciskam go w wejście DC z kabelkiem (właściwie dwoma ). Te kabelki rozdzielają się na dwie pary +/-. Jedna para kabelków idzie do wtyczki DC, która wejdzie w Arduino. Druga para idzie do przetwornicy impulsowej, żeby obniżyć napięcie do 5V. Przetwornica to ta z kursu Elektronika poziom 2 https://botland.com.pl/pl/przetwornice-step-up-step-down/941-pololu-s7v7f5-przetwornica-step-upstep-down-5v-1a.html Wyjściowe napięcie 5V "idzie" jako zasilanie LED-ów. Gdy złożyłem cały projekt na płytkach stykowych (a także póżniej już z częścią polutowaną, ale bez tej części zasilającej) to wszystko było ok. Z dokładnością do tego, że Arduino było jeszcze zasilane z USB. Wszystko działało elegancko. Następnie już na płytce uniwersalnej zlutowałem przetwornicę, kabelek z wejściem DC i jakieś piny do masy i wyjścia 5V z przetwornicy. Tylko tyle. Napięciem 5V zasiliłem jedną diodę z rezystorem 1k. Żadnego Arduino ani nic innego nie podłączałem. Podpiąłem woltomierz, i podłączyłem zasilanie. Przez chwilę miałem nieco ponad 5V, dioda się świeciła. I po krótkiej chwili napięcie mocno spadło, dioda zgasła i kaplica. Sprawdziłem, że po tej awarii, przetwornica dalej "wypuszcza" jakieś napięcie, ale sporo niższe, Prąd jaki płynął przez diodę był rzędu 0.10-0.15 mA. Dodam jeszcze, że zanim to zlutowałem, to dokładnie to samo (zasilanie DC 12V, przetwornica, dioda, rezystor) zamontowałem na płytce stykowej i było ok. Gdzieś popełniłem błąd, ale już nie wiem gdzie. Zwłaszcza, że na płytce stykowej wszystko działało. Może ktoś będzie umiał mi pomoć. Pozdrawiam
  2. Dzięki za mega szybką odpowiedź Prąd w danym oczku jest taki sam (w każdym jego punkcie) - stąd taki wynik. Z tego samego powodu nie ma różnicy, czy rezystor znajdzie się za diodą, czy przed nią. Sprawdź ten artykuł, powinien być pomocny: Czy kolejność w połączeniu szeregowym ma znaczenie? Tak mówi prawo Kirchoffa i doświadczalnie mi tak wyszło, ale właśnie myślenie zdroworozsądkowe (moje) się tutaj wysypuje. Zabieram się za artykuł i mam nadzieję wszystko mi wyjaśni Zerknij na poniższy artykuł. Jest tam więcej informacji o połączeniu diody z rezystorem Jak dobrać rezystor do diody? Różne metody zasilania LED! Już zdążyłem odwrócić kolejność i chyba domyślam się co będzie w tym artykule Ale dla pewności zabieram się też i za niego. Dzięki!
  3. Cześć Zrobiłem sobie następujący obwód szeregowy w poniższej kolejności: 1. bateria 2. opornik 1000 Ohm 3. dioda prostownicza 4. zielony LED Mierzyłem sobie napięcie na każdym elemencie i rzeczywiście suma napięć daje w przybliżeniu napięcie baterii. Mierzyłem też natężenie prądu pomiędzy poszczególnymi elementami, tj. między baterią i opornikiem, między opornikiem i diodą, między diodą a LED-em oraz między LED-em a masą. I wszędzie prąd był podobny (ok. 5,7 mA). Czyli Kirchhoff się zgadza. Ale naszły mnie takie pytania (być może nie rozumiem jakichś podstaw): 1. dlaczego natężenie mierzone na samym początku między baterią, a opornikiem jest też 5,7 mA? Na zdrowy rozsądek wydaje się, że przepływający prąd powinien "natrafić na opór" dopiero przy oporniku. I że dopiero za opornikiem prąd powinien być mniejszy. 2. Zauważyłem, że na diodzie i LED-ie odkłada się jakby "dedykowane" napięcie, tj. ok. 0.7V i 2V odpowiednio. Jak zmieniałem LED-y na inne, to na diodzie dalej było ok 0.7V, na innym LED-ie odkładało się też "dedykowane" napięcie, ale odpowiednio pomniejszone/powiększone odłożyło się na oporniku. Z czego to wynika? Dlaczego na oporniku nie odkłada się stałe napięcie i np. LED nie ma zbyt małego napięcia? Będę wdzięczny za każdą pomoc w zrozumieniu
×
×
  • Utwórz nowe...