Skocz do zawartości

xy

Użytkownicy
  • Zawartość

    18
  • Rejestracja

  • Ostatnio

Reputacja

0 Neutralna

O xy

  • Ranga
    2/10

Informacje

  • Płeć
    Mężczyzna
  • Zainteresowania
    inne
  1. Panowie Dziękuję, Dziękuję ,Dziękuję bardzo .Jeszcze wrócę i odniosę się do poprzednich postów Ale dopiero w niedzielę . Ja dałem plamę . I tu chcę coś naświetlić . W lutym br. na forum elektroda popełniłem jako nez wpis dość prowokacyjny przyznam pt. Polskie Perpetuum Mobile pomoże ktoś ? Obecnie w Hyde Parku . Chodzi o to że sprawa dotyczy tego właśnie . Ktoś pytał o Wielkość silnika - sam jestem zaskakiwany kiedyś były to 15kW jak na filmikach YT . Wczoraj gdy byłem u Pana Jana silniczek był mały 0,7 kW. Proszę zwrócić uwagę że zasilanie tego silnika nie jest konwencjonalne . ---------- Wracając do rzeczy owej mojej plamy Pojechałem do tego Pana z kodem i żadne moje Arduino nie przyjęło linii kodu : DelayMicroseconds(5555); Wywalało błędem Następnie jakoś sobie w biłem w głowę że jak zapala się diodę stanem wysokim to zchwilą gdy ma zgasnąć należy dać kod digitalWrite(6,LOW); delay( 1000 ); a wyszło tak digitalWrite(3,HIGH); delay(1000); digitalWrite(3,LOW); digitalWrite(5,HIGH); delay(1000); digitalWrite(5,LOW); digitalWrite(6,HIGH); delay(1000); digitalWrite(6,LOW); są 3 diody i mają się zapalać naprzemiennie Co chciałem osiągnąć ? to że pierwsza zapala się i świeci 1 sekundę , i tylko ona ma świecić gaśnie pierwsza ale w tym momencie zapala się druga dioda i tylko ona ma świecić druga gaśnie ale bezpośrednio zapala się trzecia dioda i tylko ona ma świecić natomiast taki kod jak niżej powodował przerwy czyli żadna nie świeciła digitalWrite(3,HIGH); delay(1000); digitalWrite(3,LOW); delay(2000); digitalWrite(5,HIGH); delay(1000); digitalWrite(5,LOW); delay(2000); digitalWrite(6,HIGH); delay(1000); digitalWrite(6,LOW); delay(2000); Możliwe że przedobrzyłem ------------------------ Mam jeszcze cholerny problem z płytkami NANO Poszperałem na forum ktoś był uprzejmy podać linka na film gdzie po angielsku wyjaśnione jest źe jeśli literka "G" to sterowniki na porty CH341SER .Mnie to nie pomagało dopiero znalazłem opcję NANO OLD ale już tam na miejscu nic mi nie wychodziło żadne kombinacje (UNO też) musiałem załatwić to przez LEONARDO --------------------------- na koniec dodam to że dzisiejsze eksperymenty zakończyły się spaleniem jednego przekaźnika półprzewodnikowego Pozdrawiam xy
  2. Panowie Jeszcze nie wszystko ogarniam rzeczywiście dwie maszyny synchronizować "prądowo " jest trochę kłopotliwe . Tu silnik kołem pasowym przenosi napęd na prądnicę . We wszystkich pośrednich elementach jak przekaźniki liczę na to że stałe opóźnienie nie jest takie groźne. Na razie jest to w fazie koncepcyjnej i poszukiwania najlepszego rozwiązania. . Dziękuję bardzo za każdy wpis zwłaszcza krytyczny bo to zwraca uwagę na potencjalne niebezpieczeństwa i przeszkody które trzeba będzie ominąć . Najmocniej przepraszam muszę opuścić śledzenie tego tematu .ale za kilka dni wrócę bogatszy o nową wiedzę w tej sprawie i na pewno te życzliwe Wasze uwagi wykorzystam . Pozdrawiam xy
  3. Deshipu Ta część już samego napięcia wchodzącego na silnik będzie "załatwiona" przekaźnikami elektronicznymi . Ale najpierw trzeba tylko zobaczyć jak to zadziała i na ile jest elastyczne poza tym jest jeszcze tak wysterować impulsami by były one najbardziej efektywne (długość impulsu ,przerwa) Ethanak jeszcze nie wiem i myślę że to przede mną następne zadanie Dziękuję Panom za zwrócenie uwagi na możliwe do wystąpienia problemy . To b.ważne Pozdrawiam xy
  4. Ethanak Tak przyjmuję do wiadomości i godzę się na razie na to to że Arduino nie zareaguje na żaden sygnał zewnętrzny . Potrzebne było by coś w rodzaju sprzężenia zwrotnego ale to w dalszej kolejności Pozdrawiam xy
  5. Ethanak Chcę impulsami prądu stałego zasilać silnik prądu zmiennego Te impulsy powinny być bardzo dokładne Silnik napędza prądnicę Pierwotnie trzeba silnik rozpędzić do określonej prędkości znamionowej tak by prądnica też miała prędkość znamionową Stąd w pierwszej fazie rozruchowej podaje się coraz krótsze impulsy a już gdy osiągnie się prędkość obrotową zgodną z oczekiwaniami to już jest praca stabilna owe 5,55 ms impuls i przerwa o podobnej wartości lub dłuższa zależy jaki to jest silnik Czy dość dokładnie to opisałem ? Pewnie sam jeszcze nie ogarniam niespodzianek w takim układzie bo być może obciążając prądnicę obroty silnika będę spadać ale tym będę martwił sie później . Najpierw jest bieg jałowy Jeśli dochodzenie do obrotów faza rozruchu jest zbyt droga w realizacji to tę fazę można wykonać ręcznie A skupmy się na stabilnym podawaniu impulsów i przerwach natomiast innym czynnikiem utrudniającym mogą być silniki 3 fazowe gdzie impulsy podawane przesunięte są względem siebie o 120 stopni ale idzie to przeliczyć na czas podania takiego impulsu lub 3 timery . Pozdrawiam xy Chcę mieć wpływ na moment podania impulsu , jego długość trwania i długość trwania przerwy
  6. Deshipu Teraz dopiero wyjdzie moja zupełna ignorancja w tych sprawach .Sorry zupełnie nie znam się . na tym Przypuszczam że timer to taki programator który da się jakoś zaprogramować ustawić . Czy przykład jakiegoś taniego timera mógłbyś podać ? A może jest to jakiś układ elektroniczny ? Może są takie niedrogie zestawy tak sterujące ? Zupełna Amba Przepraszam ale się nie znam na tym wszystkim . Pozdrawiam xy
  7. Dziękuję Bardzo Panowie za odpowiedzi . Jeszcze ich nie przetrawiłem (tzn jeszcze nie rozumiem) co oznacza co . Chodzi o wysyłanie impulsów sterujących do silnika Przykładowe wartości to w milisekundach 5,5555 5,6497 5,7471 5,8479 Oczywiście chciałbym posługiwać się wartościami jeśli to możliwe do drugiego miejsca po przecinku w milisekundach. Tu pokazałem fazę ostatnich kilku kroków rozruchu (długości impulsu ) Oprócz tego jest jeszcze przerwa Impuls / Przerwa /Impuls / Przerwa itd długość impulsów tej stabilnej pracy przyjmijmy 5,55 milisekund Edit Skoro opóźnienia są stałe to chyba nie przeszkadza w stabilnej pracy Pozdrawiam xy
  8. Witam Arduino NANO Cy można sterować impulsami krótszymi niż 1 ms ? Czy byłby dopuszczalny np taki zapis delay(0,100); lub delay(0,010); może zamiast przecinka kropka tak by przejść na mikrosekundy . Lub też są inne sposoby? . Pozdrawiam xy
  9. Jamik Dziękuję za linki . Pomiędzy szyną minusową a dodatnią jest 0,00 Czyli rezystory powinny " okrakiem wejść w np kolumnę F lub tej lewek połówki i kolumn z cokolwiek z A lub B lub C lub D lub E ? Dopiero zaskoczyłem .... Nie dość że mnie za uszy wyciągasz to jeszcze ratujesz moje Arduino . DZIĘKUJĘ Pozdrawiam xy
  10. Przepraszam skończony baran jestem Pomierzyłem i te co nie świecą mają 3,37V a te świecące 4,8V i 4,9V Teraz zajarzyłem z tą przerwą w połowie . Po prostu w pamięci miałem z YT schemat i złe wyobrażenie myślałem że "szyna" jest jednolita w kolumnie od góry do dołu .Teraz już musi działać . Aż mi wstyd ! Ale jeszcze raz dziękuję za pomoc i cierpliwość tylko mnie dziwi skąd tam napięcie w tej drugiej połówce?.... Dodatkowa zmyłka Mea culpa ,Mea culpa ,Mea bardzo wielka culpa WSZYSTKIE Diody świecą idealnie . Wielkie dzięki Pozdrawiam xy
  11. Jamik Na UNO jest taki komunikat Tak ale to moja wina ponieważ Uno było wgrywane na innym kompie i przeniosłem zły port teraz skopiowałem kod i utworzyłem nowy plik .Komunikatu tego już nie ma . Na UNO są używane inne piny (wybieram raczej te zaznaczone " ~ " ponoć są właściwsze Na uno są to 3,5,6,9, 10, 11 Napięcia na tych nie świecących są o ok 1 V wyższe 3,3V a te które świecą mają 2,15 mierzone na nóżkach diody kombinowałem z opornikiem większym niż 1` kOm . Zamieniałem ledy te świecące z nieświecącymi bez zmian czyli cały czas 4 tylko świecą.. Zdjęcie mam niestety po spakowaniu zipem ponad 1,2 MB Ściągnę zaraz 7z i spróbuję zejść poniżej 1M. Pozdrawiam xy
  12. Jeszcze raz dziękuję Zmienię Oporniki Pozdrawiam xy [ Dodano: 13-03-2018, 17:36 ] Dopiero zauważyłem pytanie O ten znaczek (chyba chodzi o ten " + " na rysunku w Paincie jednej gałęzi Nie żadnych innych zasilań poza USB nie stosuję Coś jednak jest na rzeczy Przeszedłem na UNO i pozmieniałem oporniki oraz powtykałem w te same dziurki na płytce po dwie nóżki Układ taki PIN 3 na płytce do Dziurki w Kolumnie B do tej samej opornik 1kOm druga nóżka opornika do kolumny A i do tej dłuższa noga Diody druga noga diody na minusową "szynę" Przy wgrywaniu na płytkę pokazuje mi błąd dla UNO Uno mam z tej strony z rozszerzeniem arduino.cc napisane na płytce Made in Italy Próbowałem Arduino/Genuino UNO i Duemilanowe / Decymila Śmieszne jest to że nie dość że nie wszystkie zapala to zupełnie w innej kolejności Chyba to wszystko za trudne dla mnie Pozdrawiam xy
  13. Jamik rysowałem z pamięci powinna być jeszcze pionowa w diodzie -zapomniałem i przepraszam Okazuje się że mam napięcia na tych dwóch nieświecących (na czas pomiaru DELAY dałem na 2500) Mam pytanie gdybym dał zamiast tych 175 Omów dwóch oporników jeden (1 k) 1 kOm czy będzie działało? Wnioskuję że coś zdążyłem spalić ;((( Pozdrawiam xy edit Ethanak źle zrozumiałem przepraszam Już powinienem sobie poradzić (tylko nie wiem co z tą podmianą oporników na 1 k) Dziękuję wszystkim Panom Za udzieloną mi lekcję
  14. Panowie serdecznie dziękuję za Waszą cierpliwość i pomoc Od Jamika dowiedziałem się o programach do rysowania Ale wytłumaczcie proszę mi dlaczego 3 od góry mojego kolorowego widoku działają Jeden czwarty przy zamienionym układzie (choć to nie powinno mieć znaczenia działa A dwa identycznie złożone jak ten czwarty nie ? Ethanak Jak nie może działać jeśli migają 4 Deshipu niech to będzie tymczasowe rozwiązanie z tym paintem postarma się zastosować do rad Jamika Pozdrawiam
×
×
  • Utwórz nowe...