Skocz do zawartości

DraveS

Użytkownicy
  • Zawartość

    25
  • Rejestracja

  • Ostatnio

Reputacja

5 Neutralna

O DraveS

  • Ranga
    3/10
  • Urodziny 11.04.1989

Informacje

  • Płeć
    Mężczyzna
  • Lokalizacja
    Śrem
  • Języki programowania
    C++/JS/PHP
  • Zainteresowania
    Lotnictwo, Drony, Modele RC, Sport, Programowanie
  • Zawód
    Programista/Web Developer

Ostatnio na profilu byli

Blok z ostatnio odwiedzającymi jest wyłączony i nie jest wyświetlany innym użytkownikom.

  1. DraveS

    Wspólna masa bezpieczna dla arduino?

    @SOYER Ale o co Ci chodzi w ogóle? Zrobiłem - miałem na myśli że zleciłem elektrykowi. A nawet jeśli bym sam ją wykonał to już została skończona, a nie "robisz instalację elektryczną w domu nie mając pojęcia co robię". Dodatkowo pytam czy mogę łączyć gnd arduino z zasilaczem na 5v do sterowania logiką przekaźników a ty wylatujesz z jakąś nieodpowiedzialnością. Instalacja w sumie już działa na wyłącznikach bistabilnych bez użycia żadnego układu czy komputera. Teraz ją chcę przerobić na monostabilną sterowaną przez arduino a później dodać wymianą informacji z RPi z domoticzem. Miło by było jednak odpowiadać na temat i coś wnieść do dyskusji a nie zgrywać wszechfachowca z elektrody. Więc uściślając pytanie. Czy arduino może posiadać wspólny gnd z dodatkowym zasilaczem? Czy może coś się stać niebezpiecznego (czytaj: czy arduino za 80zł sięnie spali). A jeśli tak to w jakich warunkach może to zajść. Np jeśli układ wykorzysta całą wydajność z zasilacza oraz arduino?
  2. DraveS

    Wspólna masa bezpieczna dla arduino?

    Ok. Czyli coś dzwoniło ale nie w tym kościele. A czy zasilanie z wyjścia 5v jeśli Arduino jest podłączone przez USB jest jakoś ograniczona samym Arduino czy wtedy zależy od wyjścia USB? Czy takie połączenie gnd innego zasilacza i arduino może w jakichś sytuacjach być niebezpieczne?
  3. Hej mam taki problem. Zrobiłem instalację w domu tak, że w skrzynce elektrycznej mam wszystkie lampy a w puszkach wyłączników mam tylko skrętkę UTP. Na razie chcę sterować wyłącznikami mono stabilnymi za pomocą arduino. Mam przekaźniki SSR 2 sztuki po 8 przekaźników sterowanych stanem wysokim. I teraz: Arduno ma wydajność prądową 25mA. Jeden moduł bierze 8mA zasilania i 0,4 mA na każdy stan wysoki. Boję się, że jestem blisko maxa. Mam taki pomysł, by zasilić moduły z innego źródła, ale żeby odczytać stan wysoki z wyjścia arduino muszę połączyć GND arduino z minusem zasilacza. Czy to bezpieczne dla Arduino?
  4. Hej. Chciałbym sterować przekaźnikami bezpośrednio przez arduino, ale żeby wszystko było podłączone do domoticza na RPi. Niestety nie mogę znaleźć żadnego konkretnego poradnika jak to zrobić. Wszystkie poradniki są najczęściej z użyciem ESP. A mi chodzi, żeby były nawet obok siebie. Jedyny sensowny poradnik jaki znalazłem to połączenie przez ethernet i wymienianie się informacjami za pomocą http. Często przewija się też MySensors. Może jakoś źle o tym wszystkim myślę? Czego w ogóle szukać bo jakoś czuję, że źle się w ogóle za to zabrałem.
  5. DraveS

    Wyświetlacz ze starego tabletu

    Dzięki wielkie Tak myślałem że jakiś konwerter będzie potrzebny. Nie będę się w to bawił
  6. Jest możliwość podłączenia tabletu jako wyświetlacza do RPi? Chodzi mi raczej o rozbiórkę tabletu i podłączenie go np taśmą. Mam starego acer a200 ale jego prędkość działania jest już tragiczna. Zastanawiałem się czy mógłbym użyć jakoś wyświetlacza.
  7. Hej napisałem sobie w lua taki kodzik. On oczywiście działa, ale mi się nie podoba za bardzo. commandArray = {} if (devicechanged['Przycisk'] == 'Open' and otherdevices['Dioda'] == 'Off') then commandArray['Dioda']='On' end if (devicechanged['Przycisk'] == 'Open' and otherdevices['Dioda'] == 'On') then commandArray['Dioda']='Off' end return commandArray Jak to napisać jakoś mnie topornie? Np żeby stosować wartości boolienwoskie zamiast 'Open', 'Off'. Użyć negacji i przyporządkować do zmiennych żeby kod wyglądał np tak?: dioda = otherdevices['Dioda'] przycisk = otherdevices['Przycisk'] if(przycisk.value == 1){dioda.value = !dioda.value}
  8. @Treker Masz rację, ja użyłem sobie 17 i jakoś kompletnie przeoczyłem informację o dodaniu tych linii do pliku. Moja wina przepraszam bardzo (teraz przynajmniej lepiej zapamiętam ;)) Drugi zadziałało bardzo dobrze. Dziękuję bardzo i w sumie przepraszam za lenistwo następnym razem zajrzę do dokumentacji.
  9. Hej mam dwa pytanka: W kursie jest, że żeby np zrobić z IO17 wyjście to tam robimy /usr/bin/gpio export 17 out. Potem coś tam coś tam i restartujemy malinkę itp. Ale przecież po restarcie wszystko się zeruje. To u mnie jest coś nie tak? Dopisałem sobie tą linię do pliku domoticza na początku i wtedy faktycznie jest ok, ale nie wynika to z kursu. Ogarnąłem sobie taki kod do obsługi DHT11: # Domoticz server SERVER="192.168.0.53:8181" # DHT IDX DHTIDX="2" # DHTPIN DHTPIN="4" sleep 5 sudo nice -20 python /home/pi/Adafruit_Python_DHT/examples/AdafruitDHT.py 11 $DHTPIN > /var/tmp/temp.txt #TEMP=$(cat /var/tmp/temp.txt | grep "Temp" | awk '{ print $3 }') #TEMP=$(cat /var/tmp/temp.txt | grep "Temp") TEMP=$(awk ' /Temp/ {print substr ($0,6,4)}' /var/tmp/temp.txt) #HUM=$(awk ' /Hudmidity/ {print substr ($0,0)}' /var/tmp/temp.txt) #HUM=$(awk ' /Humidity/ {print 1$}' /var/tmp/temp.txt) HUM=$(awk ' /Humidity/ {print substr ($0,22,4)}' /var/tmp/temp.txt) echo $TEMP echo $HUM # Send data curl -s -i -H "Accept: application/json" "http://$SERVER/json.htm?type=command&c=getauth&param=udevice&idx=$DHTIDX&nvalue=0&svalue=$TEMP;$HUM;2" TEMP="" HUM="" Ale gdy ustawię w domoticzu hasło to wtedy kod nie może się dostać. Jak jeszcze przekazać dane do logowania?
  10. DraveS

    Raspberry Pi się nie uruchamia

    @Treker To będzie wina czytnika. Obie karty po poprawnym już flashowaniu są praktycznie niewidoczne dla huaweia. Gdy flashowałem kartę od samego początku huaweiem to było jakby poprawnie, czyli tworzyły się 2 dyski, windows chciał je formatować był dysk boot z plikami itd. Ale RPi tego nie widział. Gdy zrobiłem flasha nowym czytnikiem na pierwszy rzut oka wszystko było tak samo. Z tą różnicą, że działały w RPi. Ale karty z powrotem włożone do huaweia są już dla niego nieczytelne. Widać tylko ~80 MB miejsca w połowie zajętego, niby jako boot, ale drugiego dysku już nie ma. Nie ma możliwości zrobienia flasha w Etcherze. Po włożeniu do nowego czytnika wszystko wraca do normy (2 dyski flash itd bezproblemowo)
  11. DraveS

    Raspberry Pi się nie uruchamia

    @Treker Specjalnie dla Ciebie sflashowałem starą kartę i.. też poszło. Widać wina czytnika który jest modemem (huawei E3372). Jeszcze bym się pokusił o flashowanie nowej karty tym czytnikiem i sprawdzenie czy nie zadziała ale mi się już nie chce kasować wszystkiego. Przynajmniej dobrze wiedzieć, że mam 2 sprawne karty. No i okazuje się, że czasem może i czytnik zawinić albo jakaś bardzo niekorzystna konfiguracja akurat 2 sztuk sprzętu które się nie polubiły
  12. DraveS

    Raspberry Pi się nie uruchamia

    Dzięki wszystkim za odpowiedzi. Kupiłem nową kartę i nowy reader i poszło elegancko. Chociaż nie wiem czemu bo poprzedni działa normalnie, karta identyczna jak poprzednia 16GB class10 jedna i druga. No ale one potrafią mieć swoje fochy. Tak czy inaczej kryzys zażegnany. Jeszcze raz dzięki
  13. DraveS

    Raspberry Pi się nie uruchamia

    Jak napisałem wcześniej uruchomienie zwykle z podłączonym monitorem skutkuje czarnym ekranem. Sprawdzę kartę jeszcze
  14. DraveS

    Raspberry Pi się nie uruchamia

    Tak oczywiście. Tym programem z kursu wgrałem, dodałem linie uart_enable=1. Próbowałem również ustawić na zero, ale dodatkowo jakaś komendę wyłączająca chyba bt i usunięcie z tego drugiego pliku prędkości transmisji ale też nie pomogło (takie coś w sieci znalazłem) potem jeszcze raz flashowalem kartę. Z kartą jest wszystko ok, ale dla pewności dzisiaj po pracy jeszcze przetestuje inną.
  15. DraveS

    Raspberry Pi się nie uruchamia

    Witam. Dzisiaj przyszła do mnie malinka, ale chyba jest coś z nią nie tak. Moje wszystkie czynności ograniczały się do włożenia malinki w obudowę, włożenia karty i podłączenia do zasilacza (oryginalny z zestawu z Botlandu) i niestety nic się nie dzieje. Podłączeniu do monitora jest czarny ekran i nic, po podłączeniu przez UART też głucho. Na RPi świeci się tylko czerwona dioda. Powinno się świecić coś jeszcze? Co zrobić by ewentualnie zareklamować wadliwy egzemplarz?
×