Skocz do zawartości

shoter09

Użytkownicy
  • Zawartość

    47
  • Rejestracja

  • Ostatnio

Reputacja

0 Neutralna

O shoter09

  • Ranga
    3/10

Informacje

  • Płeć
    Mężczyzna
  • Lokalizacja
    -_-
  1. nic nie pomogło. Myślicie, że to może być spowodowane przez podłączenie 7 pinu L293 z 4 pinem (XTAL2) Attiny2313 ? tutaj jest schemat jak mam połączone wszystko
  2. Witam Mam problem z ustawieniem PWM na attiny2313 + L293D dla silników. Czy ustawie pwm1a = 255 czy pwm1a = 100 to silnik i tak kręci się z maksymalną prędkością. Pin 1 z L293D podłączyłem pod 16 pin attiny2313, a pin 9 z L293D podłączyłem pod pin 15 w attiny2313. $regfile = "attiny2313.dat" $crystal = 1000000 Config Timer1 = Pwm , Pwm = 8 , Prescale = 1 , Compare A Pwm = Clear Down , Compare B Pwm = Clear Down Config Portd.0 = Output Config Portd.1 = Output Config Portb.2 = Output Config Porta.1 = Output Config Portd.6 = Input Config Portb.0 = Input Silnik_lewy_a Alias Portb.2 Silnik_lewy_b Alias Porta.1 Silnik_prawy_b Alias Portd.0 Silnik_prawy_a Alias Portd.1 Czujnik1 Alias Pind.6 Czujnik2 Alias Pinb.0 Set Silnik_lewy_a Reset Silnik_lewy_b Set Silnik_prawy_a Reset Silnik_prawy_b Do Pwm1b = 100 Pwm1a = 255 Loop End
  3. bartek1333, tak, to są koła z lego piotreks-89, mi się zdawało, że jak dioda ir w CNY70 wyśle światło, to one rozchodzi się na całą obudowę tak jak na tym zdjęciu (zaznaczone na czerwono)
  4. Witam Zrobiłem kilka dni temu mojego pierwszego robota - line follower. Do budowy wykorzystałem 3 czujniki CNY70, atmega8, L293D, diodę LED, kilka rezystorów i 2 micro serwa (przerobione). Całość zasilana jest napięciem 4,5V. Program napisałem sam, jednak muszę podziękować Decado za wytłumaczenie mi jak działa CNY70 dzięki Decado jeszcze trochę wzorowałem się na programie Nawyka w artykule Przepis na robota - w pełni programowalny Line Follower Zdjęcia: Filmik z przejazdu:
  5. Mam pytanie, a mianowicie czy da się zrobić line followera na attiny13 (z 3 czujnikami CNY70) schemat i program w załączniku (w programie jest mały błąd jak by ktoś mógł powiedzieć dla czego to bym był wdzięczny jeszcze nigdy nie programowałem attiny13 a tam trzeba ustawiać coś na początku) lf13.rar
  6. Jak mogę to sprawdzić ? sorry za takie głupie pytania ale naprawdę ciemny jestem
  7. Sprawdzałem tak: M8 - L293DNE 2 - 15 3 - 10 4 - 7 5 - 2 i masy i VCC wszędzie jest dobre połączenie
  8. sorry ale ciemny jestem i nie wiem które to piny możesz mi powiedzieć ich numery ?
  9. Już wiem czemu tak było. Bo zapomniałem podłączyć masy do L293DNE. Ale teraz jest następny problem bez różnicy czy czujniki wykrywają linie czy nie ciągle jest +5V na obu silnikach
×
×
  • Utwórz nowe...