Skocz do zawartości

dam234

Użytkownicy
  • Zawartość

    8
  • Rejestracja

  • Ostatnio

Wszystko napisane przez dam234

  1. W załącznikach przesyłam Ci kod do Arduino Uno, dokumentacje oraz zdjęcia pinów oraz ze wszystko działa. 1. GND 2. VCC ( +5V) 3. Kontrast Vo (potencjometr lub podepnij pod GND 4. Register Select (RS). Podejpnij pod 6 PIN Arduino 5. Read/Write (R/W). Podepnij pod GND 6. Clock (Enable). Podepnij pod 7 PIN Arduino 11.Bit 4 (DS4) Podepnij pod 9 PIN Arduino 12.Bit 5 (DS5) Podepnij pod 10 PIN Arduino 13.Bit 6 (DS6) Podepnij pod 11 PIN Arduino 14.Bit 7 (DS7) Podepnij pod 12 PIN Arduino #include <LiquidCrystal.h> #define RSPin 6 #define EnablePin 7 #define DS4 9 #define DS5 10 #define DS6 11 #define DS7 12 #define LCDColumns 16 #define LCDRows 2 LiquidCrystal lcd(RSPin, EnablePin,DS4,DS5,DS6,DS7); void setup() { lcd.begin(LCDColumns, LCDRows); //Configure the LCD lcd.setCursor(0,0); lcd.print("Hello, World!"); } void loop() { } Jeżeli wszystko masz zrobione tak samo tzn. ze uszkodzony masz wyświetlacz. WM-C2002M.pdf
  2. Wszystkie możliwe kombinacje próbowałem a błąd cały czas ten sam , chyba jest problem z programatorem skoro ISP normalnie działa, nie wiem jeszcze czy działa TPI bo nie sprawdzałem tego. Wybrałem ATXMEGE ze względu na to ze potrzebuje 2x DAC i 2xADC w małej obudowie a ten mikrokontroler akurat ma i ma tylko 32 piny i jest w normalnej cenie. Chyba ze masz jakiś lepszy mikrokontroler, który by miał min. 2xDAC i min 2xADC i mało pinów najlelpiej 32 i przestępna cena a nie 20zł.
  3. To jest ATXMEGA a nie ATMEGA i nie posiada chyba ISP tylko PDI
  4. Płytka programatora wygląda tak: A programator tak: Tutaj odczytana Atmega8 przez ISP ale z PDI problem przy ATXMEGA32E5 ATXMEGA32E5 Moja wersja mikrokontrolera
  5. A które piny ISP odpowiadają za PDI. Fusebitów nie mogę zmienić, ponieważ nawet nie mogę odczytać sygnatury mikrokontrolera
  6. Mikerokontroler jest świeży. Jeszcze ani razu nie programowany. Chyba że podpinam się w złe piny programatora. Powiesz mi którę piny to które na złączu ISP 10
  7. Programator na ISP działa. Mam zwykła ATXMEGE SMD przylutowaną do adaptera DIP i włożoną w płytkę stykową. Podłączam zasilanie 3,3V (1, 17, 18)i masę oraz piny PDI oraz PID/Reset (7,8). Wydaje mi się ze nie da się inaczej podłączyć, programuje w Atmel studio 7 i Atmel studio 6. Posiadam taką podstawkę
  8. Posiadam programator AVRISP MkII i chciałbym nim zaprogramować procesorek ATXMEGA32E5. W jaki sposób mam połączyć złącze ISP z procesorkiem, ponieważ w ogóle nie działa mi żadne połączenie
×
×
  • Utwórz nowe...