Skocz do zawartości

quando

Użytkownicy
  • Zawartość

    4
  • Rejestracja

  • Ostatnio

Reputacja

1 Neutralna

O quando

  • Ranga
    1/10
  • Urodziny 28.12.1973

Informacje

  • Płeć
    Mężczyzna
  1. Witam i dziękuje za odpowiedz. Może źle się określiłem. gdy Pierwszy kod jest wgrany do son-offa to son-off działa prawidłowo bez podłączenie go z serwerem Blynk drugi kod ma dodane biblioteki do komunikacji z serwerem Blynk. i gdy go wgram do son-off to problem jest taki że son-off nie zadziała do puki nie będzie połączenia z serwerem blynk. Ręczne wciśniecie przycisku gpio -0 (przekaźnik nie odpowiada.) tak jak by program czekał na połączenie z serwerem BLYNK. W momencie kiedy to połączenie nastąpi z serwerem wciśniecie przycisku wirtualnego a aplikacji Blynk powoduje pracę programu.
  2. Witam. Jestem początkującym i proszę o wyrozumiałość. Napisałem krótki kod który o dziwo działa oczywiście z poradników:)) int odbiornik = 12; int wlacznik = 0; bool running = false; void setup() { pinMode(odbiornik, OUTPUT); pinMode(wlacznik, INPUT); digitalWrite(wlacznik, HIGH); } void loop() { if (digitalRead(wlacznik) == LOW) { delay(50); running = !running; digitalWrite(odbiornik, running); while(digitalRead(wlacznik) == LOW); delay(50); } } wgrany do son-off i działa prawidłowo czyli wciśniecie przełącznika w son-off załącza przekaźnik, ponowne wciśniecie wyłącza. Mój problem zaczyna się jak dodaję bibliotekę Blynk #define BLYNK_PRINT Serial #include <ESP8266WiFi.h> #include <BlynkSimpleEsp8266.h> char auth[] = "***************************"; char ssid[] = "*******"; char pass[] = "*******"; int odbiornik = 12; int wlacznik = 0; bool running = false; void setup() { pinMode(odbiornik, OUTPUT); pinMode(wlacznik, INPUT); digitalWrite(wlacznik, HIGH); Blynk.begin(auth, ssid, pass, "8.8.8.8", 80); } void loop() { if (digitalRead(wlacznik) == LOW) { delay(50); running = !running; digitalWrite(odbiornik, running); while(digitalRead(wlacznik) == LOW); delay(50); } Blynk.run(); } Son-Off komunikuje się z serwerem Blynk czyli wszystko OK ,ale przy pierwszym uruchomieniu przycisk analogowy w son-off nie działa !!!!! dopiero wciśniecie wirtualnego włącznika w aplikacji Blynk powoduje że program zaczyna działać. Czy musi być wstawiona jakaś procedura aby program działał tak jak należy. Bardzo proszę o pomoc?
×
×
  • Utwórz nowe...