Skocz do zawartości

Arek-

Użytkownicy
  • Zawartość

    11
  • Rejestracja

  • Ostatnio

Reputacja

2 Neutralna

O Arek-

  • Ranga
    2/10
  1. @Elvis dokładnie tak jak mówisz, chodziło mi o szybkie przetestowanie układu czy jest komunikacja z tym scalakiem. @RFM polutowałem układ, zobaczymy czy dioda zacznie świecić. Dziękuje wam wszystkim za pomoc, nie wiecie jak bardzo się ucieszyłem jak zobaczyłem, że dioda zaczęła mrugać, czas najwyższy wywalić stykówkę do kosza, zacznę lutować normalnie na płytkach jak to @RFM robi z tym PCFem już dobre kilka miesięcy męczyłem się i nie tak dawno wróciłem do tego tematu i w końcu zatrybiło jeszcze raz dziękuję serdecznie wszystkim za pomoc!!
  2. @atMegaTona już wiem czemu się grzał,s tyki w płytce nie dobrze kontaktowały i masa PCFa wisiała w powietrzu i jakiś prąd przepływał od Vcc przez piny adresowe do masy zasilania. Ten problem rozwiązany. Z tym, że teraz dioda nie chce mrugać, miernikiem sprawdzałem czy jakieś napięcie pojawia się na tym pinie i nic. Dołączam sketcha w razie czego. #include <Wire.h> #include <PCF8574.h> PCF8574 expander; void setup() { expander.begin(0x20); expander.pinMode(4, OUTPUT); } void loop() { expander.digitalWrite(4, LOW); delay(100); expander.digitalWrite(4, HIGH); delay(100); }
  3. Jest dobrze zrobione? Dałem wszędzie rezystory 1kΩ bo najwygodniej mi było ich użyć. Na linie SDA i SCL po dwa rezystory 10kΩ połączone równolegle. Układ nie grzeje się ale i dioda nie mruga.
  4. @atMegaTona podpiąłem do masy piny A0-A2 przez rezystory 1kΩ i linie SDA i SCL do Vcc przez rezystory 5kΩ i układ nie grzeje się.
  5. @Gieneq podłączenie na pająka nic nie pomogło, ani nie grzeje się, a ni nie działa ten scalak(doda nie miga) @atMegaTona jak duże dać rezystory do interfejsu i jakie rezystory do pinów adresowych?
  6. @RFM aj, przepraszam, faktycznie nie pisałeś, coś mi się pomieszało. @Gieneq mam właśnie ściągniętą tą taśmę, ja nie widzę nic co mogło by powodować zwarcia, mogę wstawić zdjęcie jej. Spróbuje polutować na pająka, zobaczymy czy będzie działać normalnie.
  7. @Gieneq zrobiłem coś takiego i nie grzeje się
  8. @RFM Tak jak pisałeś, 10kΩ. Na zdjęciu, po prawej stronie jest czarny kabelek, nie zmieścił się w kadrze.
  9. @Gieneq Sprawdziłem i nigdzie nie ma zwarć, niby wszystko jest dobrze. @RFM Dodałem te rezystory podciągające. Jaki dodać kondensator?
  10. Witam, ma problem z tytułowym scalakiem, a mianowicie podczas montowania układu testowego(mruganie diody LED) na płytce stykowej, przy podłączaniu pinów adresowych do masy następuje zwarcie i układ bardzo grzeje się. Myślałem że to wina konkretnego scalaka po czym kupiłem 3 kolejne scalaki i dalej ten sam problem występuje. Próbowałem później pierwsze podłączyć te piny adresowe lecz przy podłączaniu zasilania następowało zwarcie i scalak grzał się. Sprawdzałem po kilkanaście razy, czy aby na pewno dobrze wszystko podłączyłem, czy nie ma gdzieś zwarć na stykówce, wszystko dobrze było, więc gdzie jest problem?
×
×
  • Utwórz nowe...