Skocz do zawartości

voltedor

Użytkownicy
  • Zawartość

    3
  • Rejestracja

  • Ostatnio

Reputacja

0 Neutralna

O voltedor

  • Ranga
    1/10
  1. Udało mi się odpalić wtyczkę do cubeMX korzystając z innego łącza sieciowego, ale wygenerowany kod w 1 projekcie różni się trochę od tego w artykule. zamiast "stm32F4xx..." i brak jakiejkolwiek funkcji HAL_GPIO - wszystkie funkcje HAL_. _ ss z Project explorer. Przeoczyłem coś czy funkcje w programie się zaktualizowały?
  2. Tak, pracuje na koncie jako administratora a co do programu antywirusowego to były problemy przy pobieraniu eclipse (antywirus uznawał jako niebezpieczny).I takie pytanie jeszcze zanim zacznę próbować na innym pcie pobierać czy eclipse jest wymagane jako od dzielny program jeżeli, zdecydowałem się na CubeIDE?
  3. Cześ jestem tu nowy mam problemy z konfiguracją środowiska dla stm32.Dodam tylko, że nie używałem wcześniej żadnych środowisk programistycznych (poza arduino) . STM32CubeMX - wcześniej mi działało ale, jak chciałem wygenerować kod pojawiał się komunikat z zapytanie o pobranie dodatkowych elementów po akceptacji program kręcił się w kółko, zainstalowałem ponowie teraz program nie uruchamia się. CubeMX jako wtyczka do eclipse - Program się nie uruchamia, albo tylko szczątkowy interfejs programu. eclipse - Program chyba działa ale, przy każdym włączeniu programu jestem witany przez 4 komunikaty 2 razy : STM32CubeiDE - po wybraniu file > new > STM32 project pojawia się na kilka sekund : "initalizing stm32 target selection" program nie uruchamia się, albo wyskakuje komunikat System workbench stm32 - nie ma do tego zestawu ale, chciałem sprawdzić czy działa po wybraniu biblioteki HAL: Czy miał ktoś podobne problemy?
×
×
  • Utwórz nowe...