Skocz do zawartości

koso22

Użytkownicy
  • Zawartość

    4
  • Rejestracja

  • Ostatnio

Reputacja

1 Neutralna

O koso22

  • Ranga
    1/10
  1. Hehe faktycznie siedział tam potencjometr 100k. Dzisiaj założyłem 1K i wszystko chodzi jak należy. Dziękuje za odpowiedzi i wskazanie drogi bo siedziałbym nad tym chyba następny tydzień żeby wpaść, że problemem może tu być potencjometr.
  2. Hmmm. No faktycznie. Sprawdzę to bo faktycznie nie pamiętam co tam siedzi. Robiąc prototyp wykorzystałem to co było pod ręką, działało więc pod tym kątem później faktycznie nie myślałem.
  3. Mowa o jednostkach w skali ADC. Jeden stopień to około 2-3 jednostek ADC przez co dosyć poważnie fałszuje to odczyt. Zwiększenie ilości jednostek ADC przypadających na 1 stopień kąta raczej nie wchodzi w grę bo musiałbym zmienić przełożenie kół zębatych czego wolałbym uniknąć. Przeszukiwanie internetu kieruje mnie ku problemie tętnienia napięcia. Niestety nie mam oscyloskopu żeby to sprawdzić. Czy jest jakiś sprawdzony sposób na wyeliminowanie tego zjawiska w przypadku Arduino?
  4. Jest to mój pierwszy post więc witam wszystkich forumowiczów i proszę o pomoc bo jestem już mocno zdesperowany. Przeszukałem forum i internet ale nie natknąłem się na rozwiązanie mojego problemu. Zbudowałem w oparciu o podróbę Arduino Uno czujnik kąta obrotu zaginarki. Sprawa ma się następująco potencjometr wieloobrotowy, na ekranowanym przewodzie o długości 50cm, w roli dzielnika napięcia za pomocą kół zębatych odczytuje aktualną pozycję i na wyświetlaczu 7segmentowym wyświetla przyporządkowaną wartość kąta. Program się zgadza wszystko działa tak jak zaplanowałem. Problem polega na wartościach przetwornika ADC. Przy podpiętym zasilaniu po USB z laptopa czy komputera wartości przetwornika są w miarę stałe. Natomiast gdy podpinam zasilanie zewnętrzne z zasilacza impulsowego wartości wachają się +/- 4 co sprawia olbrzymi problem. Wykluczam ułożenie kabli ponieważ: przewód USB podpięty pod laptop - wszystko OK, ten sam przewód USB tak samo ułożony podpięty pod zasilacz 5v/power bank daje już spore zakłócenia. Objawy są te same przy wykorzystywaniu regulatora napięcia z płytki czyli podając zasilanie +9v na Arduino. Czy ktoś jest mnie wstanie naprowadzić jak rozwiązać problem a raczej jak stworzyć te same warunki zasilania zewnętrznego co przy zasilaniu z laptopa? Czyżby napięcie zasilania zasilaczy impulsowych +/-5% w ten sposób by się objawiało? Płytka nie jest oryginalna to fakt ale czy oryginalne Arduino w czymś by tu pomogło jeśli po zasilaniu z laptopa wszystko jest OK? W sumie to jestem trochę zdesperowany i jestem wstanie zasilać urządzenie przy pomocy uśpionego laptopa co raczej mija się z celem. A może po prostu zamiast zasilacza impulsowego zastosować trafo i wyprostować napięcie? Dziękuje za zainteresowanie i proszę o jakieś podpowiedzi rozwiązania problemu.
×
×
  • Utwórz nowe...