Skocz do zawartości

tofurman

Użytkownicy
  • Zawartość

    7
  • Rejestracja

  • Ostatnio

  • Wygrane dni

    1

tofurman wygrał w ostatnim dniu 22 stycznia

tofurman ma najbardziej lubianą zawartość!

Reputacja

6 Neutralna

O tofurman

  • Ranga
    2/10

Ostatnio na profilu byli

Blok z ostatnio odwiedzającymi jest wyłączony i nie jest wyświetlany innym użytkownikom.

  1. Okazuje się, że MONIT czasem ma problem z nazwą procesu kontrolowanego. Metodą prób i błędów doszedłem, że w pliku konfiguracyjnym w linijce: check process domoticz with pidfile /var/run/domoticz.pid wystarczy zmienić nazwę procesu z domoticz na np. domoticz1 i wszystko zaczyna działać jak należy.
  2. Jeśli to tylko zimny lut by był, to może warto przejechać grotem lutownicy. Jeśli rezystor to na znanym portalu możesz takie znaleźć po 2 zł za 100 szt. (tylko, czy o takiej samej tolerancji???). Jeśli to coś więcej to chyba taniej wyjdzie kupić nowy miernik.
  3. Lut też na RJ11 jest jakiś taki matowy, więc może coś być na rzeczy. Może tam po prostu zimny lut się ujawnił... Zwiększyło to rezystancję o parę dziesiątych Ω albo 1 czy 2 Ω więc na zakresie 1000 mA (rezystancja bocznika 1Ω) czy 100 mA (rezystancja bocznika 10Ω) jest znaczne przekłamanie, bo w przypadku dodatkowych 2 Ω na zakresie 1000 mA będzie błąd rzędu 200%. Dla zakresu 100 mA będzie to już tylko ok 20%, Na zakresie 10 mA błąd będzie rzędu 2%, a więc w granicach dopuszczalnego błędu miernika.
  4. Rezystory wyglądają na dobre, chociaż nie wiem dlaczego ten RJ10 nie ma oznaczenia (Może chińczyk przy lutowaniu położył oznaczeniem do dołu). Po obejrzeniu zdjęć mogę powiedzieć, że rezystory RX1 (w tym konkretnym egzemplarzu go nie ma) oraz RX2 to rezystory, które mają poprawić dokładność rezystancji bocznika (a nie dzielnika, jak napisałem w poprzednim poście) Według oznaczeń rezystory powinny mieć: RX2 - 200Ω, RJ11 - 1Ω, RJ10 - Nie ma oznaczenia, ale wg logiki powinien mieć 9Ω, RJ13 - 90Ω zaś RJ12 - 900Ω Oczywiście R, jak to zostało opisane na płytce drukowanej ma 0,01Ω (dlatego równolegle z RJ11 jest połączony RX2, aby uzyskać 0,99Ω). W takiej sytuacji wystarczy, że jeden z tych rezystorów zwiększy trochę rezystancję i miernik będzie zawyżał wskazanie. To samo, jeśli styki w przełączniku zakresów są przypalone (zwiększona rezystancja połączenia wewnątrz przełącznika), ale przy nadpalonych stykach w przełączniku zakresów albo nie będzie żadnej różnicy, albo będzie wskazanie trochę zaniżone. Jeśli zawyża wskazania na wszystkich zakresach, to stawiam na ten potencjometr montażowy, który znajduje się po drugiej stronie płytki drukowanej i z tej strony jest widoczny tylko przez otwór do jego regulacji. Jeśli to nie jeden z wyżej wymienionych elementów, to nie wierzę, że błędne wskazania są tylko na amperomierzu. Muszą być i na woltomierzu, i na omomierzu i na pomiarze baterii. W takiej sytuacji padł układ scalony. Ponieważ to jest raczej prostszy miernik, to podejrzewam, że jest to ICL7107 lub jeden z jego klonów.
  5. Trzeba sprawdzić dzielnik napięcia. Amperomierz, to rezystor o małej rezystancji i odpowiednio wyskalowany woltomierz, który mierzy na nim napięcie. Jeśli nie padł układ scalony miernika (a skoro inne rzeczy mierzy normalnie, to raczej nie padł), to najwyraźniej coś jest nie tak z dzielnikiem. No... chyba, że się przypaliły blaszki łączące pola przełącznika, co też się mogło zdarzyć, ale raczej nie na zakresie 10A, tylko mniejszym, bo na tym zakresie cały prąd idzie po z zacisku COM po rezystorze 0,01 Ω (to ten drut obok bezpiecznika) przez bezpiecznik i do zacisku 10A. Pozostałe zakresy idą z zacisku COM na rezystor, na przełącznik i dopiero później do zacisku ma/A/Ω/V. Oczywiście to jest tylko uproszczony schemat. Podejrzewam, że dzielnikiem mogą być rezystory RX1, RX2, RJ10, RJ11, RJ12 (leżą nad bezpiecznikiem) - ze szczególną uwagą na RJ10, który mi się nawet na zdjęciu z wyglądu nie podoba
  6. Tomasz, 44 lata wykształcenie elektryczne, z zamiłowania elektronika i muzyka. Obecnie próbuję opanować Raspberry Pi.
  7. Moja konfiguracja to Raspberry Pi 4 oraz Raspbian Buster z września 2019 r. Chciałem uruchomić program monit, aby pilnował i w razie czego restartował domoticza, ale niestety nie udało mi się go zmusić do działania. Kilka razy zmieniałem zawartość pliku konfiguracyjnego - bez skutku, odinstalowanie programu i zainstalowanie na nowo - bez skutku, reinstalacja systemu i próba instalacji na czystym systemie - bez skutku. Przy instalacji wyświetla takie informacje: Przygotowywanie do rozpakowania pakietu .../monit_1%3a5.25.2-3_armhf.deb ... Rozpakowywanie pakietu monit (1:5.25.2-3) ... Konfigurowanie pakietu monit (1:5.25.2-3) ... Job for monit.service failed because the control process exited with error code. See "systemctl status monit.service" and "journalctl -xe" for details. invoke-rc.d: initscript monit, action "restart" failed. ● monit.service - LSB: service and resource monitoring daemon Loaded: loaded (/etc/init.d/monit; generated) Drop-In: /etc/systemd/system/monit.service.d └─override.conf Active: activating (auto-restart) (Result: exit-code) since Wed 2020-01-22 03:48:02 CET; 19ms ago Docs: man:systemd-sysv-generator(8) Process: 11542 ExecStart=/etc/init.d/monit start (code=exited, status=1/FAILURE) dpkg: błąd przetwarzania pakietu monit (--configure): podproces zainstalowany pakiet monit skrypt post-installation zwrócił kod błędu 1 Przetwarzanie wyzwalaczy pakietu man-db (2.8.5-2)... Przetwarzanie wyzwalaczy pakietu systemd (241-7~deb10u2+rpi1)... Wystąpiły błędy podczas przetwarzania: monit E: Sub-process /usr/bin/dpkg returned an error code (1) Czy jest jakiś sposób, żeby to zaczęło działać??? Przeszukałem wiele stron i forów, ale nikt jeszcze się nie spotkał chyba z tym problemem,
×
×
  • Utwórz nowe...