Skocz do zawartości

TenWernyhor

Użytkownicy
  • Zawartość

    4
  • Rejestracja

  • Ostatnio

Reputacja

0 Neutralna

O TenWernyhor

  • Ranga
    1/10
  1. Tak, masz rację 1,5W to za dużo na SOT223, pracowałem nad tym po nocy i źle przeczytałem dokumentację - (125°C-40°C)/1,5W < 136 więc "heatsink is required." Zamieniłem obudowę na TO252 i uwzględnię duże pole masy na płytce. Wydaje mi się, że ten przełącznik da radę 0,5A/12V odpowiadałoby, jeśli się nie mylę 0,75A przy 8V w pełni naładowanego akumulatora, zakładając 0,3A prądu przez stabilizator, na silniki zostaje 0,45A na silniki, bez obciążenia pobierają łącznie 0,14A myślę, że stosunkowo lekki robot nie spowoduje przy zwykłej jeździe jakiegoś wielkiego obciążenia. Mam w domu te silniki i postaram się to zmierzyć w wolnej chwili. Większe obciążenia nie powinny też trwać jakoś długo. Mogę się mylić... Na złączu na masę mam przeznaczone 2 piny, mogę dać IDC 16 i wtedy 4, ale myślę że to wystarczy. Jeśli dobrze rozumiem taśmę IDC można potraktować tu jako rezystor, na którym wystąpi spadek napięcia, a zwiększając ilość żył na masie zmniejszę rezystancję, a tym samym spadek napięcia. Dodam jeszcze po 100nF na każde źródło zasilania na płytce. Nie jestem pewny, czy dobrze zrozumiałem ten problem.
  2. Myślę, że całkowity prąd pobierany ze stabilizatora nie powinien przekraczać 300mA, więc radiator nie jest wymagany. Tak, planuje zasilanie akumulatorem LiPol 2S. Planuje wykorzystanie enkoderów magnetycznych od Pololu, dlatego potrzebuje tam 3,3V. Usunąłem kondensatory C5 i C6, płytka od enkoderów ma kondensator 3,3nF podłączony do pinów silnika. Prawdopodobnie dolutuje jeszcze po 100nF do każdej płytki wykorzystując przelotki. W takim razie z DACa zrezygnuje. Zamieniłem rezystory na bazach na 2,2k. Dam przełącznik suwakowy 0,5A/12V, powinien wystarczyć widziałem go na kilku robotach z forum, ciężko znaleźć coś około 2A, co nie jest krową.
  3. Dzięki za poświęcony czas. Poprawiłem tranzystory, jestem prawie pewny, że jest już okej. Emitery podłączyłem bezpośrednio do 3,3V, bazy prze rezystory 4,7k co powinno umożliwić sterowanie prądem do 140mA przy minimalnym β : (3,3V-0,7V)/4,7kΩ*250 ≈ 140mA, jeśli dobrze rozumiem. TSOPa zasiliłem 3,3V i podłączyłem według dokumentacji, bezpośrednio do mikrokontrolera. Istnieją dwie wersje czujników TSOP48xx - starsza może pracować tylko z 5V i różni się nieco od nowszej, poprawionej wersji. Popatrzyłem na złą dokumentacje, stąd te kombinacje z dzielnikiem W XMegach każdy pin ma przerwania. Diody pogrupowałem po dwie i zasiliłem 3,3V, żeby uprościć płytkę zrezygnowałem z 5V. Tak, to czujnik przeszkód. Teraz, przy 3,3V będzie mniejsze natężenie. Pierwotnie dałem tyle, bo już kiedyś używałem jej w parze w z fototranzystorem jako czujnik odległości i zasilałem podobnym natężeniem, grzała się mocno, ale zasięg czujnika był bardzo satysfakcjonujący, zwłaszcza przy kiepsko dobranym fototranzystorze. Poza tym jest podłączona do DAC, więc mógłbym regulować natężenie. Nie wiem, na ile założenie, że większe natężenie na diodzie to lepszy zasięg jest poprawne. Obecnie może być na niej maksymalnie około 40mA. Myślę że to wystarczy, zwłaszcza że teraz będę miał lepszy fototranzystor. Zamierzam przylutować kabel z odpowiednią wtyczką, powinno wystarczyć. Jeśli chodzi o zasilanie to zaczynam się zastanawiać, czy dip switch to na pewno dobry przełącznik do takiego zastosowania. Chyba poszukam czegoś innego, bo oczami wyobraźni widzę stopiony plastik. Mam wyprowadzone I2C i piny z SPI/UART, dodałem też jeden przycisk - będę mógł sobie chociaż ustawić na nich +/- do jakiejś nastawy. Nie wiem czy ten robot kiedykolwiek wystartuje na jakichś zawodach, na razie chcę tylko zdać laboratoria z podstaw techniki mikroprocesorowej na ładną ocenę Aktualny schemat:
  4. Hej, jeśli komuś chciałoby się rzucić okiem na schemat mojego LF'a i sprawdzić czy wszystko jest jak należy, to bardzo proszę: Będę wdzięczny za wszelkie uwagi. Przede wszystkim chciałbym się upewnić, czy sterownie diodami IR jest na pewno ok. Pozdrawiam!
×
×
  • Utwórz nowe...