Skocz do zawartości

danio8522

Użytkownicy
  • Zawartość

    6
  • Rejestracja

  • Ostatnio

Reputacja

1 Neutralna

O danio8522

  • Ranga
    2/10

Ostatnio na profilu byli

Blok z ostatnio odwiedzającymi jest wyłączony i nie jest wyświetlany innym użytkownikom.

  1. Postępując logicznie, w zakładce Board muszę oprócz procesora wybrać nazwę płytki, nazwy mojej płytki tam nie ma więc wybrałem zakładkę MCU i odpowiednie dane zgodne z tymi podanymi dla płytki którą posiadam: Na stronie ST znalazłem bibliotekę dla F1 której zawartość jest bardzo podobna to tej dla Nucleo: https://www.st.com/content/st_com/en/products/embedded-software/mcu-mpu-embedded-software/stm32-embedded-software/stm32-standard-peripheral-libraries/stsw-stm32054.html Jak widać na zdjęciu poniżej wkleiłem dwa zaznaczone pliki do katalogu C:\Users\\AppData\Roaming\Ac6\SW4STM32\f
  2. Na podstawie kursu STM32 chcę uruchomić płytkę STM32F103C8T6, zdjęcie płytki poniżej. Oczywiście nie mogę podczas tworzenia projektu wybrać NUCLEO-F103RB więc poniżej przesyłam zdjęcia z konfiguracji, czy jest ona prawidłowa ? Czy może powinienem wejść w zakładkę MCU a nie Board i tam wybrać procesor ? Przechodząc do biblioteki, zgodnie z opisaną aktualizacją: https://forbot.pl/forum/topic/8387-kurs-stm32-3-plytka-nucleo-konfiguracja-srodowiska/page/10/#comments Dla NUCLEO-F103RB: https://www.st.com/en/embedded-software/stsw-stm32143.html#overview Dla STM32F103C8T
  3. Dzień dobry, Jestem studentem, pisanie programów do mikrokontrolerów to dla mnie nowość, mam troszkę większe doświadczenie w podłączaniu układów i elektronice. Przy budowie jakiegokolwiek urządzenia zawsze sam wykonywałem mechanikę i stronę tzw. hardware natomiast korzystałem z gotowego programu udostępnionego na opensource i schematów na podstawie których budowałem układ. Teraz, posiadam pompę 12V sterowaną PWM 2Hz i będę chciał stworzyć układ i program który wraz ze wzrostem oporu termistora będzie zwiększał wypełnienie PWM. Wybrałem ST ponieważ tylko z takimi procesorami miałem
  4. Z informatykami nie udało nam się ustalić co się stało, komputer został uruchomiony po zainstalowaniu Windowsa na czystym dysku. Obecnie zainstalowałem System Workbench for STM32 w zaproponowanym przez program katalogu a przed instalacją zainstalowałem Java. Program działa. Osoby które miały taki sam, podobny lub inne problemy podczas instalacji zachęcam do kontynuowania tematu.
  5. Windows 7 Professional SP1 64bit, może to akurat zbieg okoliczności, ale chciałbym poznać przyczynę natomiast nie mam na tyle wiedzy aby w tej chwili ustalić powód usterki
  6. Zgodnie z kursem: https://forbot.pl/blog/kurs-stm32-3-plytka-nucleo-konfiguracja-srodowiska-id4875 Pobrałem oprogramowanie https://www.openstm32.org/HomePage Niestety po zainstalowaniu komputer uległ awarii, kilka skrótów na pulpicie do programów straciło swoją grafikę a po ponownym uruchomieniu komputera wpisywane hasło nie odblokowywuje komputera, oczywiście nie zmieniałem hasła. Otworzyłem temat również na elektrodzie: https://www.elektroda.pl/rtvforum/viewtopic.php?t=3673947&highlight= Jak myślicie co się stało ? Czy brak javy mógł być powodem ? Czy program dokonał jakiś zmian
×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.