Skocz do zawartości

deikare

Użytkownicy
  • Zawartość

    1
  • Rejestracja

  • Ostatnio

Reputacja

0 Neutralna

O deikare

  • Ranga
    1/10
  1. Witam Mam problem z debuggowaniem programów z kursu (używam kursowej płytki NUCLEO-F103RB). Po poprawnym zbuildowaniu projektu po ustawieniu konfiguracji uruchamiania nie mogę ani wejść w run, ani w debug - pojawia się ten sam błąd: Open On-Chip Debugger 0.10.0+dev-00021-g524e8c8 (2019-04-12-08:48) Licensed under GNU GPL v2 For bug reports, read http://openocd.org/doc/doxygen/bugs.html srst_only separate srst_nogate srst_open_drain connect_assert_srst Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD adapter speed: 8000 kHz adapter_nsrst_delay: 100 Info : clock speed 8000 kHz Info : STLINK v2.1 JTAG v36 API v2 M26 VID 0x0483 PID 0x374B Info : using stlink api v2 Info : Target voltage: 3.244649 Info : Unable to match requested speed 8000 kHz, using 4000 kHz Info : Stlink adapter speed set to 4000 kHz Info : STM32F103RBTx.cpu: hardware has 6 breakpoints, 4 watchpoints Info : Listening on port 3333 for gdb connections target halted due to debug-request, current mode: Thread xPSR: 0x01000000 pc: 0x080007e8 msp: 0x20005000 Info : Unable to match requested speed 8000 kHz, using 4000 kHz Info : Stlink adapter speed set to 4000 kHz Info : Unable to match requested speed 8000 kHz, using 4000 kHz adapter speed: 4000 kHz ** Programming Started ** auto erase enabled Info : device id = 0x20036410 Info : flash size = 128kbytes target halted due to breakpoint, current mode: Thread xPSR: 0x61000000 pc: 0x2000003a msp: 0x20005000 wrote 4096 bytes from file Debug/zxczxc.elf in 0.306180s (13.064 KiB/s) ** Programming Finished ** ** Verify Started ** target halted due to breakpoint, current mode: Thread xPSR: 0x61000000 pc: 0x2000002e msp: 0x20005000 target halted due to breakpoint, current mode: Thread xPSR: 0x61000000 pc: 0x2000002e msp: 0x20005000 verified 3580 bytes in 0.078790s (44.372 KiB/s) ** Verified OK ** ** Resetting Target ** shutdown command invoked Dodam, że kabel działa w porządku, mikro było testowane ST-Linkiem. Jestem w stanie nawet uruchomić przykładowy kod (np blinkowanie diodą) pomimo błędu przy uruchamianiu\debugu. Przeszukałem fora, lecz nicz nie znalazłem. Co zrobić w takiej sytuacji?
×
×
  • Utwórz nowe...