Skocz do zawartości

emiemi8

Użytkownicy
  • Zawartość

    10
  • Rejestracja

  • Ostatnio

  • Wygrane dni

    1

emiemi8 zajął 1. miejsce w rankingu.
Data osiągnięcia: 29 sierpnia 2021.

Treści użytkownika emiemi8 zdobyły tego dnia najwięcej polubień!

Reputacja

5 Neutralna

O emiemi8

  • Ranga
    2/10

Informacje

  • Płeć
    Kobieta

Ostatnio na profilu byli

Blok z ostatnio odwiedzającymi jest wyłączony i nie jest wyświetlany innym użytkownikom.

  1. Cześć Mam problem pojawiający się podczas podłączania zewnętrznego źródła zasilania poprzez złącze jack na płytce. Kiedy podłączam baterię 9V to na pinie vin jest tylko ok. 3V. Dodam, że płytka jest oryginalna ale od początku miała wadliwe to wejście gdyż działało poprawnie tylko przy lekkim nagięciu złącza, które było podłączone (tak jakby coś było krzywe i manualnie trzeba to było wyprostować, żeby wszystko stykało). Czy da się to jakoś naprawić? Pozdrawiam
  2. @Gieneq testowałam na kilku różnych bateriach i było to samo. Ostatecznie baterii nie podłączałam bezpośrednio do Arduino ale przez płytkę stykową a potem do pinu Vin. Jednak obecnie mam problem, że w momencie obciążenia silników cały program się zawiesza (kiedy silniki kręcą się swobodnie wszystko jest ok) - czy to przez zbyt małą wydajność prądową takiej baterii i czy w takim razie muszę zmienić ją na jakieś akumulatory?
  3. Cześć. Mam problem z podłączeniem silników do mostka H. Otóż kiedy mam podłączone Arduino przez USB do komputera wszystko działa. Kiedy Arduino jest podłączone przez USB oraz dodatkowo ma wpiętą baterię 9V też wszystko działa (silniki kręcą się szybciej). Kiedy jednak odepnę USB zostawiając podpiętą baterię to program nie chce działać choć Arduino jest włączone (na płytce świeci się dioda on oraz miga dioda L). Będę wdzięczna za odpowiedź co robię nie tak. Poniżej przedstawiam schemat połączeń. Pozdrawiam
  4. @SOYER oczywiście! To mój pierwszy większy projekt, który od zera stworzyłam samodzielnie więc tym większa radość
  5. Cześć Tak prezentuje się moja stacja pogody: Kod: //biblioteki #include <DHT.h> //wilgotnosc #include <OneWire.h> //temperatura #include <DallasTemperature.h> #include <LiquidCrystal.h> //wyswietlacz #define DHT11_PIN 10 #define termometr A4 #define zachmurzenie A5 #define czuwanie 11 DHT dht; //wilgotnosc OneWire oneWire(termometr); //temperatura i oneWire DallasTemperature sensors(&oneWire); LiquidCrystal lcd(4,5,6,7,8,9); //wyswietlacz volatile int tryb = 1; int wilgotnosc=0; int wilgotnosc2=0; int temperatura=0; int zachm
  6. Cześć #include <Adafruit_NeoPixel.h> //biblioteka do linijki LED #include <Keypad.h> //biblioteka do klawiatury #define pir 1 #define reset 2 #define kontaktron 11 #define buzzer 12 const byte ROWS = 4; //ile wierszy const byte COLS = 4; //ile kolumn byte rowPins[ROWS] = {6, 5, 4, 3}; //piny wierszy byte colPins[COLS] = {7, 8, 9, 10}; //piny kolumn int pinAlarmuPozycja = 1; //zmienne do wpisywania pinu char pinCyfra1 = '1'; char pinCyfra2 = '2'; char pinCyfra3 = '3'; char pinCyfra4 = '4'; int ileCzasuMinelo = 0; //odliczanie czasu na wpisanie pinu char keys[ROWS][COLS] =
  7. @Gieneq Zrobiłam tak i słychać bez problemu. Wstawiam kod jakby miało to coś pomóc. void setup() { pinMode(A5, OUTPUT); //Konfiguracja A5 jako wyjście } void loop() { int czestotliwosc = 0,ile=0; /* for (czestotliwosc = 31; czestotliwosc < 65535; czestotliwosc++) { tone(A5, czestotliwosc); } */ for(ile=1;ile>0;ile++) { tone(A5,1500); delay(300); tone(A5,10000); delay(300); } }
  8. Cześć Mam problem dotyczący przykładu, w którym w pętli for generujemy różne częstotliwości dźwięku. Wszystko jest podłączone zgodnie ze schematem a po kilku nieudanych próbach kod przekopiowałam prosto ze strony (inne programy/przykłady działają poprawnie). I cały czas to samo - słychać tylko jeden obieg pętli (tzn. nie słychać po pewnym czasie kolejnego charakterystycznego świstu jak w nagraniu na stronie). Gdzie może tkwić błąd? Pozdrawiam
  9. Plan był taki żeby dane dało się wpisywać za pomocą UART. Zresztą nie ma to specjalnego znaczenia bo teraz program działa - dzięki @szymon812! Natomiast ciekawi mnie, czy istnieją sposoby, żeby zrobić to tak aby program nie zatrzymywał się w nieskończonej pustej pętli (zastanawiałam się nad przypadkiem programu, który z racji powiedzmy swojego przeznaczenia nie mógłby być wstrzymywany w takiej pustej pętli)? Pozdrawiam
  10. Cześć, Piszę z następującym problemem: otóż chciałam trochę rozbudować zadanie domowe 9.1 (to o obliczaniu pola figur) tak aby po wpisaniu do UART dało się wybrać figurę, której pole chcemy obliczyć a następnie również przez UART wpisać dane (np. długości boków). Niestety program działa poprawnie tylko do pewnego momentu (co jest zaznaczone w kodzie). Podejrzewam, że problem tkwi w wielokrotnym odczytywaniu wysyłanych danych. Jeśli się mylę proszę o poprawienie mnie. Oczywiście program nie jest jeszcze skończony ale wolałabym najpierw rozwiązać trapiący mnie problem. String odebraneDa
×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.