Skocz do zawartości

Marcinas

Użytkownicy
  • Zawartość

    125
  • Rejestracja

  • Ostatnio

Posty napisane przez Marcinas


  1. Marcinas, spróbuj z tym ST-Link Utility. Pamiętam, że też miałem podobny błąd, tylko nie pamiętam czym był spowodowany... Ewentualnie możesz jeszcze włączyć AC6 z uprawnieniami administratora (PPM -> uruchom jako administrator).

    Gdy uruchomię program System Workbench for stm32 jako administrator nic to nie zmienia.

    Po uruchomieniu STM32 ST-link Utility działa tak jak wcześniej wrzuciłem zrzut ekranu.

    (Diody się zmieniły LD1 mruga zielony/czerwony, LD3 włączona, LD2 wyłączona)

    Odinstalowanie antywirusa nic niestety nie zmieniło.

    Niestety reinstalacja oprogramowania nic nie zmieniła.


  2. Marcinas, ja miałem sporadycznie takie błędy, gdy kabel USB był bardzo długi. Spróbuj może przez coś krótszego 🙂

    Najpierw używałem przewodu z zestawu jest dość długi ale użyłem krótszego około 1m jednak błąd dalej jest.

    Wyłączyłem antywirus zaraz go od instaluję może coś pomoże.

    Cały czas jest tak jakby proces kończył się przy 91% i pojawia się błąd.

    Po podłączeniu u was włączone są jakieś diody ? Gdy ja podłączę włączone są dwie diody LD1(czerwona), LD3 (Czerwona) i LD2(zielona) miga


  3. Jeny jaki regulamin 🙁

    Jak by nie można było wcześniej powiedzieć o tym że roboty muszą być włączane przez pilota IR. To nie lepiej żeby mnie zawodników było 😋

    Jakoś rok temu było normalnie i nie miałem ani razu problemu z falstartem 😋

    Super, że regulamin został tak szybko opublikowany ...

    " Robot musi zostać wyposażony w moduł startowy umożliwiający

    bezprzewodowe odpalenie konstrukcji."

    Dla mnie to jest bez sensu ale cóż 😋


  4. Witam, super pomysł z tym artykułem nie ukrywam że od początku ferii na niego czekałem 😃

    Wcześniej już próbowałem budować ms jednak nie wyszło jak chciałem i zakończyło się klopsem ...

    Jeden punkt mnie zdziwił "8. Nalewamy do dowolnego naczynia gorącej wody z dużą ilością detergentu, czekamy aż płytka ostygnie po prasowaniu i zanurzamy ją w wodzie na ok. 15 minut. Papier powinien pod odmoczeniu sam odejść, ale nie zawsze tak się dzieje. " zawsze używałem octu choć nie wiem co lepsze 😋

    Generalnie pierwszą część oceniam pozytywnie już czekam na kolejne zobaczymy co będzie każdy kto nie miał styczności z ms będzie miał możliwość nauczenia się czegoś nowego .

    Tak mi się ten artykuł podoba ,że chyba zbuduję sobie takiego małego bandytę 😃


  5. Witam

    Ostatnio mało czasu było ale jest już parę błędów wyeliminowanych. Schemat jeszcze nie jest skończony w 100% lecz generalnie nie wiem czy coś będę jeszcze dodawał może jakiś wyświetlacz.

    *Zastosowałem stabilizator LM1117 moim zdaniem rozwiąże to błędy. Co Marku myślisz o lipolu http://botland.com.pl/dualsky/835-dualsky-250mah-20c-74v.html ? Czy coś innego byś radził użyć ?

    *Z tą histerezą nie jestem pewien ale wydaje mi się, że jest to dobre rozwiązanie. Czy masz jakieś uwagi ?

    *Czy poprawne by było napięcie +3,3V na potencjometr od kompaktorów ?

    *Wszytko widoczne jest chyba na schemacie wydaje mi się ,że zastosowałem się do wszystkich uwag ?

    Czy teraz dostrzegasz jakieś błędy ?

    ScreenShot006.thumb.jpg.ffac8cd100036cacf9c0685854d1dab4.jpg


  6. "Czy widzicie może jakieś błędy?"

    Po co pytasz? Wciąż nie zmieniłeś wielu rzeczy, które zostały wytknięte. Albo ich nie rozumiesz i wolisz udawać, że nie istnieją albo nie chcesz. Oczekujesz pogłaskania po główce i namaszczenia do dalszej pracy? Nic z tego. Wg mnie schemat nie jest dobry ale nie chce mi się już powtarzać, nic z tego nie będzie. Błędy nie znikają od tego, że czekasz dzień czy dwa. Musisz je sam poprawić. Jutro będą tak samo jak są dzisiaj. Dla potomnych czytających ten wątek:

    Powiem tak inni na tym forum też mają takie błędy a wszyscy chwalą ich sprawne konstrukcje. Po za tym widziałem nie jednego robota w którym zastosowany był stabilizator 7805 a całość była zasilana z Lipolka 7,4V .Pooprawiałem dodawałem elementy na schemacie .Miałem i dalej mam pomysł na Lf zacząłem tworzyć worklog nie stety okazało się że jest dużo błędów porawiam je na bieżąco jak jest to możliwe. Faktycznie parę błędów było przez moje gapiostwo i je poprawiłem lecz niektórych nie rozumiem i nie wiem co miał bym w nich zmieniać skoro innym działają 😃.

    1. Stabilizator 7805 + LiPol 2S = spadek zasilania procesora przy trochę rozładowanym akumulatorze

    Nie wiem dlaczego tak ten błąd tobie doskwiera po pierwsze wiele konstrukcji tak mam o czym wspominałem (moja poprzednia i działał) po drugie rozwiązanie tego problemu nie jest takie łatwe bo zmian zasilania z +7,4V na +11,1V wszytko zmienia musiał bym stworzyć oddzielny stabilizator do mostków , szczególnie ,że co jeden max trzy przejazdy będę zmieniał lipola .Obecnie w sklepach nie znalazłem lipola +8,4V bo takich nie mam a one był rozwiązał ten problem który mi wyjaśniłeś były by 2V w zapasie ale niestety nie mam takowego .

    2. Komparatory - Histereza = problemy ze stabilnością sygnałów z czujników i zakłóceniami

    Komparatory specjalnie sprawdziłem i podłączyłem tak jak chłopaki z Botland Team mają https://www.forbot.pl/forum/topics7/line-follower-greennight-vt5656.htm i nawet nie mają tam zrobionego napięcia +3V tylko +5V którym zasilają czujniki. To może łatwiej podłączyć porostu pod wyjście procesora 😃 .

    3. Brak złącza UART → pytania na Forum: "Pomóżcie, co się dzieje z moim programem? Nie działa, nie wiem dlaczego i nie wiem jak to sprawdzić!"

    Pytałem czy może ktoś mi to wyjaśnić lub dać link tłumaczący jakie ma to zastosowanie po co się to stosuje, co to daje itp. Lecz mogę powiedzieć że obecnie się nad tym zastanawiam.

    4. Zasilanie czujników 3V robione bez sensu wypasioną przetwornicą zamiast zwykłą diodą Zenera.

    Rezygnuję z napięcia +3V bo w obecnym stanie nie ma to sensu

    5. AREF podpięte do VCC to chyba najgorsza opcja wykorzystania wejścia referencyjnego. Już lepiej dać mu kondensator i zostawić w spokoju.

    Dlaczego ? Czy tak jak jest było by nie poprawnie ?

    6. Jedna nóżka GND procesora w powietrzu.

    Jest podłączone.

    Podsumowując jednak chciał bym żebyś mi pomagał jak to jest możliwe ale jak nie rozumiem błędów które mi wytykasz to nie wiem jak je poprawić .Masz rację sam ciągle się zastanawiam czy budować tą konstrukcję fajnie było by mieć takiego LF ale jest dość trudny choć jak nie teraz to kiedy ? Postaram się poprawić wszystkie błędy bo chciał bym żeby ta konstrukcja była prawna dodam tylko taką swoją refleksję łatwiej tworzy się płytki z elementami przewlekanymi 😃 Nie czekam parę dni tylko odrazu odpowiadam wtedy kiedy mam czas a nie że czekam dzień dwa:(

    Pozdro.


  7. Witam ostatnio niestety mam mało czasu ale będzie go teraz co raz mniej więc o to wersja schematu nazwałem go wersją 2.1.2 😃 trochę było popraw no ale teraz CHYBA jest ok ?

    Dobra nie będę przedłużał co dodałem :

    *złącze Lcd (zobaczymy jak w praktyce to wyjdzie )

    *Przełączniki (aż dwa bo wszystkie wyprowadzenia są wykorzystane a tyle wystarczy i koniec kropka !)

    *Led-y a tak bo mam fajny pomysł co do nich pomiga wam za jakiś czas na forum

    *napięcia poprawione

    *co jeszcze nie wiem chyba wszystko

    Czy widzicie może jakieś błędy? Bądź macie jakiś sugestie czekam na odpowiedzi z potwierdzeniem poprawności lub jej braku 😋 zobaczymy co przyniesie jutro jeśli nie będzie już błędów to wreszcie rozpocznę tworzenie płytki ehhhhhh zobaczymy co będzie może uda się przed świętami mieć polutowane i oczekujące na program z waszą pomocą oczywiście 😅

    Dzięki wszystkim co dotychczas się udzielali i pomagali wielki THX


  8. Nieścisłość jest w tym, że są cztery miejsca w których Twoje "kompaktory" mają coś wspólnego z szyną zasilania:

    - zasilanie samych układów, nie pokazane na schemacie (nie wiem dlaczego) ale musi być +5V

    - oporniki podciągające wyjścia, też muszą być do +5V

    - zasilanie czujników - tu robimy +3V

    - zasilanie potencjometru - też +3V

    Jeśli tak masz - wszystko jest OK.

    Zamieszczam ponownie schemat moim zdaniem tak jest ale możesz sprawdzić 😃

    "ale jest tak jak napisałeś "

    Rozumiem, że robisz najpierw 5V a potem z tego 3V, OK, ale czym? Przetwornica robi 5V a potem co? Zener? Jeśli sprawdziłeś i przetwornica sobie nie poradzi, musisz ją zmienić. Nie można zostawiać takich baboli w projekcie tym bardziej, że o nich wiesz. To byłby strzał we własne kolano. Może daj po prostu stabilizator liniowy low-drop, np. nieśmiertelny LM1117 lub coś innego: LP2950, L4941 itp Są tego dziesiątki. Ten ostatni by tu pasował jak ulał. Może wskaż sklep gdzie kupujesz jeśli samemu trudno Ci coś znaleźć to dobierzemy. 3V to mała dioda Zenera 2.4V, jeden opornik i tranzystor npn - tanio i szybko.

    Jest tak najpierw jest 7805 z niego jest +5V które idzie na przetwornice i z niej uzyskuję +3V. Przetwornica sobie nie poradzi z tym z tym aby z 7,4 uzyskać 5 a nie z tym aby z 5 uzyskać +3V z tym sobie poradzi taki tez jest jej cel . Ja chciałem zamawiać w http://botland.com.pl/

    Przyciski przydają się do szybkich zmian trybów pracy, powtarzania jakichś testów, wywoływania kalibracji czujników itp. Robot nie tylko jeździ - to tylko sam finał zabawy. Wcześniej spędzasz całe dnie na pisaniu funkcji które przydają się raz na jakiś czas. Jeśli program się rozrośnie (a chyba tak zamierzasz) to będzie Ci potrzebny jakiś interfejs do "wnętrza" programu. Do tego właśnie przydają się przyciski, diodki LED a nawet jakiś wyświetlacz przy zadawaniu parametrów, wpisywaniu wartości numerycznych, ustalaniu czasów, poziomów mocy, napięć itp. Szybko zauważysz, że nie ma sensu wpisywać do programu dziesiątek stałych i przy każdej zmianie kompilować i programować nowy kod. Lepiej raz zrobić interfejs programowy umożliwiający zmiany wartości prawie wszystkiego i szybkie puszczanie kolejnych jazd testowych z nowymi nastawami. Liczba przypadków do sprawdzenia na trasie jest tak wielka, że po prostu przestanie Ci starczać czasu na kolejne programowania procesora.

    Tylko że dokładając jeszcze ekranik i wszystkie rzeczy z niem związane nabijam tylko dodatkową wagę jak już robić to taki jak w tym robocie podobny zewnętrzny https://www.forbot.pl/forum/topics7/line-follower-impact-wersja-druga-vt7424.htm można pomyśleć tylko potem skończy się tak że przekombinuję konstrukcję i będę miał problemy z zaprogramowaniem i wszystkim nie wiem muszę to przemyśleć wiem że miało by to na pewno istotne znaczenie mogło by pomóc ale trzeba mieżyć siły na możliwość nikt od razu nie zbudował robota który był najlepszy ja chcę porostu zbudować fajnego solidnego lf który będzie miał jakieś tam szansę w zawodach ale to nie jest najważniejsze moim zdaniem.

    Mniej więcej do tego samego służy UART. Zrób mu (i sobie) tę przyjemność i chociaż wyprowadź, jak Koledzy radzą jego piny plus zasilanie i masę na osobne złącze (chyba też już o tym pisałem). Rzuć okiem na podobne, ukończone projekty na tym Forum. Dziś już prawie każdy ma coś takiego. Opis UARTa i jego wyprowadzeń znajdziesz w danych procesora. Tutaj masz dwa porty szeregowe. Piny jednego są zajęte niestety przez programator (co nadal nie wyklucza ich używania) ale drugi jest wolny - skorzystaj z tego.

    Poczytam poszukam o tym informacji 😃

    Niewątpię, że konstrukcję już sobie przemyślałeś - to się chwali. Pytałem tylko o przesyłanie danych. Robiąc to równolegle - tak jak masz teraz na schemacie, jesteś już na początku skazany na daną (lub mniejszą) liczbę czujników. 15 kabelków to max 15 czujników. Wstawiając na płytkę czujników rejestry przesuwające (koszt chyba z 1.50zł/szt) i podłączając to do SPI procesora przesyłasz sygnały szeregowo. Niezależnie od liczby czujników zawsze będą tylko trzy druty (plus zasilanie, oczywiście) - to chyba coś, prawda? Możesz wtedy zrobić płytkę z 3, 15 lub 29 czujnikami a płyta główna nie zmieni się. Będziesz musiał zmienić tylko fragment programu - to wszystko.

    Akurat od samego początku chciałem tego robota robić tylko na 15 czujników taki miałem zaplanowany wygląd i rozłożenie czujników gdzie 15 było wystarczającą ilością przynajmniej dla mnie dzięki za fajny pomysł ale jeszcze nie wiem czy w tej konstrukcji z niego skorzystam .

    Dobra w rzucę teraz jeszcze raz schemat jak wygląda na teraz najwyżej będę go później poprawiał chciał bym się upewnić czy teraz jest dobrze czy trzeba coś zmienić bo jest źle bo dodać coś zawsze można tak jak mówiłem nie chcę przekombinować konstrukcji żeby móc ją ogarnąć a nie zbudować coś z czym nie będę nic potrafił zrobić


  9. Ale to jest tylko włącznik zasilania. Ja bym dodał jeszcze tac swiche. Możesz sobie zaprogramować jakiś tryby jazdy.

    Zastanowię się nad tym 😃

    A, już kiedyś o to pytałem - skąd wzięło się słowo "kompaktory"? To są komparatory (ang. compare - porównywać).

    Sorry ale nie wiem o co chodzi nie pytałem o to ale dzięki 😃


  10. Witam tutaj tak mała nie zgodność się pojawiła kompaktory wraz z czujnikami obecnie na schemacie są podłączone +3V tak jak wcześniej pisałeś żebym zrobił, dlatego stworzyłem dodatkowy stabilizator impulsowy który z napięcia +5V będzie robił na +3V impulsowy dlatego bo nie znalazłem żadnego liniowego 😃 A w ostatnim poście piszesz że mają być na +5V to jakie w końcu ma być na +3V czy na +5V ??? (specjalnie to analizowałem 🙂)

    "Czyli napięcie wejściowe mogło by wynosi +3V "

    Tak, napięcie wejściowe nie powinno przekraczać 3V. Dotyczy to zarówno napięcia z potencjometru jak i z samych czujników. Ponieważ producent nie gwarantuje poprawnego działania komparatora poza zakresem napięć wejściowych 0..3V (przy zasilaniu 5V) to może się zdarzyć, że sygnał do procesora może mieć stan zupełnie nie odpowiadający temu, co widzi czujnik. Niewielu ludzi na to zwraca uwagę ale też (chyba) niewielu dokładnie testuje i wymaga faktycznie w pełni poprawnego działania od swoich układów. Masz szansę to zmienić.

    Oczywiście komparatory są wciąż zasilane z 5V tak? To dobrze.

    Właśnie teraz przetwornica jest wstawiona bez sensu. Jeżeli już koniecznie chcesz jej użyć, zrób odwrotnie: niech to ona daje Ci +5V (choć nie wiem, czy będzie pracować przy tak małej różnicy napięć we-wy - sprawdź to) a dopiero z tego zasilania zrób 3V czymkolwiek. Zresztą w obu przypadkach główna zaleta układu impulsowego a więc sprawność będzie tu zupełnie niewykorzystana. Ani tu mocy jakiejś wielkiej nie potrzebujesz ani też różnicy napięć nie ma prawie żadnej ale skoro musisz...

    Nie da się za pomocą tej przetwornicy przy tak małym napici stworzyć na wyjściu napięcia +5V sprawdzałem to 😋

    Połączenie w łańcuch (7.4V → 5V → 3V) zapewnia, że najpierw zrobi się prawidłowe 5V a dopiero wtedy urośnie 3V - tak jest bezpieczniej i niech będzie to wytyczna do wszystkich Twoich następnych konstrukcji.

    Tak jest teraz podłączone ale faktycznie złego screen-a dałem gdzie jest z +7,4V na +5V i z +7,4V na +3V mój błąd ale jest tak jak napisałeś podłączone 😃

    Czy myślałeś o zmniejszeniu liczby drutów między czujnikami a procesorem? Jak wyobrażasz sobie konstrukcję mechaniczną? Czy będzie jedna płytka czy dwie różne połączone np. taśmą?

    Sądzę ,że robot będzie składał się z dwóch modułów czyli pierwszy ten co teraz robię i potem osobno czujnik całość jak ma wyglądać jest już dawno przemyślana tak będzie podłączona za pomocą taśmy .Wygląd zewnętrzny robot jest przemyślany 😃 Wszytko będę opisywał na bieżąco jak tylko schemat będzie poprawny i będę mógł robić płytkę mam nadzieję że w październiku będę miał już wytrawioną płytkę ale na razie jest etap schematu 😃

    Wyprowadź sobie piny do rs i podobne na złącze.

    Mógł byś mi to opisać co to jest co to da itp bo nie wiem co to a wolę zapytać niź nie wiedzieć może masz jakąś stronę gdzie to jest opisane ???

    Może dodaj jakiś przycisk do awaryjnego włączenia/ wyłączenia przejazdu.

    Już jest na tym schemacie co zamieściłem na górze 😃


  11. Witam, trochę się zmieniło od ostatniego czasu było trochę problemów ale jest już poprawiona wersja schematu.

    *Jednak poczytałem o tym zasilaniu i zdecydowałem się na Li-pola +7,4V z 300mA wszytko zależy jaki będzie akurat w sklepie w każdym bądź razie poczytałem i zobaczyłem ,że wiele konstrukcji stosuje napięcie +7,4V razem z stabilizatorem 7805 nie wiem ale w poprzedniej konstrukcji tak para nieźle sobie radziła nie mogę narzekać .

    *Stworzenie od dzielnego stabilizatora w moim przypadku impulsowego do zmniejszania na pięcia na +3V specjalnie na kompaktory LM339 i czujniki KTIR0711S uważam że jest to dobre rozwiązanie uzyskam napięcie taki jakie jest mi potrzebne i jak radził mi "marek1707" przy okazji wykorzystam przetwornicę którą chciałem tu wcześniej bez sensu władować 😃

    *Napięcie +5V będzie podpięte pod CPU, złącze programowania, tsop,

    *Dodałem 7 Led-ów macie rację może to fajnie wyglądać a nie zajmuję dużo miejsca a fajnie będzie się prezentowało jeden led będzie osobny do zmiany stanu akumulatora w sensie tak dioda ostrzegawcza jak radził marek1707.

    *Bez pośrednio z li-pola będą zasilane dwa mostki H no a co za tym idzie silniki ale po za tym sterownik do turbiny ( http://www.hobbyking.com/hobbyking/store/uh_viewItem.asp?idProduct=4318 ) oczywiście do niego będzie podpięta turbina.

    *Dodałem awaryjny załącznik/wyłącznik

    *Sygnały mosi ,miso,sck,reset podłączone zgodnie z radą "pawcio0928" z noty katalogowej

    *Napięcie mierzone jest +7,4V (gdyby nie było widoczne na zdjęciu )

    Nie wiem co tam jeszcze się zmieniło ale teraz jest już lepiej a wy jak sądzicie ?

    A schemat wrzucą w jpg. w pdf-ie gdyby było coś nie wyraźne 😃

    untitled.pdf

    ScreenShot001.thumb.jpg.74ebe37d2f8ad428385c5ed2613facc7.jpg


  12. "co tutaj miało by nie działać dlaczego tak nie można "

    Hm, spróbuj skojarzyć następujące fakty:

    - "W czasie całej zabawy napięcie akumulatora powoli spada"

    - "Zaczynasz od trochę ponad 8V a kończysz na 6V"

    - "Stabilizator 7805 potrzebuje ze 2V "nadmiaru" żeby zrobić 5V"

    i napisz mi tu proszę otwartym tekstem jaki będzie "nadmiar", gdy na wejściu stabilizator dostanie 6V a na wyjściu zrobi 5V. Uznaj, że ja wiem lecz chcę się przekonać, czy Ty także umiesz liczyć i rozumiesz co czytasz - to taki mały test na rokowania dalszej współpracy.

    No to wtedy może by zmienić na np taki li-pol http://botland.com.pl/dualsky/566-dualsky-250mah-20c-3s1p-111v.html było by on wtedy dobry bo było by w zapasie ponad 2 😃

    "co dwa przejazdy będę ładował lub zmieniał akumulator "

    Naprawdę chce Ci się biegać z tym co chwila? Może właśnie po to robisz(?) pomiar napięcia baterii by to procesor Cie ostrzegał (diodką, niejechaniem) o rozładowaniu akumulatora.

    Dobra dorzucę tam led-a to ułatwi pracę ale zbytnio nie wiem na jakiej zasadzie ma działać ten pomiar wstępnie w ogóle nie chciałem go stosować ale zostałem na niego namówiony .

    "niestety jeszcze słabo idzie mi korzystanie z kart katalogowych "

    Nikt nie obiecywał, że będzie łatwo ale postaraj się - to dość nośny temat np. na elektrodzie. Zwykle wyskakuje gdy ktoś ma zamiar lub właśnie wbudował komparator i odkrywa dziwne (jego zdaniem) zachowania.

    "Czyli napięcie wejściowe mogło by wynosi +3V "

    Tak, napięcie wejściowe nie powinno przekraczać 3V. Dotyczy to zarówno napięcia z potencjometru jak i z samych czujników. Ponieważ producent nie gwarantuje poprawnego działania komparatora poza zakresem napięć wejściowych 0..3V (przy zasilaniu 5V) to może się zdarzyć, że sygnał do procesora może mieć stan zupełnie nie odpowiadający temu, co widzi czujnik. Niewielu ludzi na to zwraca uwagę ale też (chyba) niewielu dokładnie testuje i wymaga faktycznie w pełni poprawnego działania od swoich układów. Masz szansę to zmienić.

    Dziękuję za wytłumaczenie 😃 teraz rozumiem dlaczego 😃 A jak można do pytać to jaki stabilizator byś do tego polecał taki żeby była na +3V jak to można policzyć sprawdzić ?

    "No jak bezpośrednio z li-pola daję tak jak na mostki h tb6612 no i na regulator do turbiny potem jest stabilizator na razie tylko na +5V ale będę czekał na odpowiedz "

    Przepraszam ale kompletnie tego nie rozumiem. Pisałem o pomiarze napięcia baterii a Ty mi tu jakieś dyrdymały smażysz. Odnieś się proszę do konkretu: mierzysz przetwornikiem A/D (oporniki R22/R23) szynę 5V - po co?

    Wszyło takie masło maślane ale już piszczę co miałem na myśli dawałem tam napięcie +7,2V bo takie szło z akumulator ale teraz zamienię na ten co powyżej zamieściłem li-pol czyli będzie +11V, pewnie było nie wyraźne dlatego mogło się wydawać że jest +5V w każdym bądź razie teraz jest poprawnie.

    Nie dawaj kolejnych schematów dopóki tak wiele problemów jest nierozwiązanych. O każdym można rozmawiać szczegółowo bez każdorazowego ładowania wersji z nowo-podłączoną diodką LED.

    Ok myślałem ,że to ułatwi 😃


  13. Witam

    To może po kolei 😃

    "Nie rozumiem pod koniec jakiej pracy ??"

    Normalnie jest tak, że odłączasz akumulator od ładowarki i wkładasz do robocika - to jest początek pracy. Koniec jest wtedy, gdy akumulator jest wyczerpany i musisz wykonać operację odwrotną (robot → ładowarka). W czasie całej zabawy napięcie akumulatora powoli spada. Zaczynasz od trochę ponad 8V a kończysz na 6V, proste. Jeśli naładujesz powyżej 8.4V np. zepsutą lub niepasującą ładowarką, możesz wyrzucić go do kosza. Jeśli rozładujesz poniżej 6V - to samo. Stabilizator 7805 potrzebuje ze 2V "nadmiaru" żeby zrobić 5V. Sam widzisz, że tu się nie nadaje.

    hymmm no tak prawdopodobnie chciałem użyć tego li-pola http://botland.com.pl/dualsky/835-dualsky-250mah-20c-74v.html we wcześniejszej konstrukcji tak robiłem i nic się nie uszkodził przecież ten stabilizator by zmniejszał z 7,4 v na 5V to co tutaj miało by nie działać dlaczego tak nie można przecież miał by nadmiaru aż 2,4V tak ?Po za ty co dwa przejazdy będę ładował lub zmieniał akumulator ale to chyba nie istotna informacja 😃

    Histerezę wrzuć w wyszukiwarkę - na pewno coś znajdziesz. Możesz zacząć od kart katalogowych komparatorów. Nawet tam jest opisany układ odwracający i nieodwracający z histerezą.

    no dobra http://pl.wikipedia.org/wiki/Histereza niestety jeszcze słabo idzie mi korzystanie z kart katalogowych ale załóżmy że mniej więcej na podstawie tego linku wiem już co to oznacza.

    "no i z tego co widzę to ten napięcie powinno być ok chyba że się mylę ?"

    Tak, mylisz się. Parametr "Input Common-Mode Voltage Range" ma zakres od 0 do (Vcc-2V) dla zasilania 5V a to oznacza, że producent nie gwarantuje prawidłowego działania komparatora gdy napięcie wejściowe przekroczy 3V.

    Czyli napięcie wejściowe mogło by wynosi +3V czy lepiej dać +2V na wejście wtedy trzeb było by stworzyć dodatkowy jakiś stabilizator który był by specjalnie tylko i wyłącznie z myślą o komparatorach ?

    "dam teraz w pdf i jpg."

    Co nie zmienia faktu, że napięcie wciąż mierzysz dziwnie. Powinieneś chyba spróbować mierzyć to, które przychodzi wprost z akumulatora, prawda?

    No jak bezpośrednio z li-pola daję tak jak na mostki h tb6612 no i na regulator do turbiny potem jest stabilizator na razie tylko na +5V ale będę czekał na odpowiedz 😃

    "Jak to zrobić mógł byś mi to szczegółowo opisać"

    Zmieniając podłączenie czujnika podczerwieni z obecnego PD7 (o ile dobrze widzę) na coś innego, oznaczonego np. INT-coś-tam.

    "no czytam o które złącze chodzi bo nie wiem"

    O złącze którego jeszcze nie zrobiłeś. Wyprowadź linie UARTa procesora na jakieś złącze (plus masę i zasilanie 5V) lub zrób od razu gotowy interefejs do portu szeregowego komputera. Nawet się nie domyślasz, jak Ci to ułatwi życie.

    "co proponujesz"

    Proponuję dokładnie to co napisałem. Może powiedz, czego nie rozumiesz: czy wyrażenia "rejestr przesuwający", czy "SPI" czy może jeszcze czegoś innego. Zacznij od specyfikacji interfejsu SPI zawartej w danych katalogowych procesora (i tak muisz znać to na wylot robiąc poważny projekt na jaki się zasadziłeś) a potem połącz to (na razie w myślach) np. z rejestrem 74165. Jeśli coś Ci zaświta, napisz. Oczywiście tylko wtedy, gdy jesteś takim rozwiązaniem zainteresowany.

    Te problemy w następnym poście najpierw chciał bym tamto wyjaśnić a i schemat też wrzucę później wieczorem bo niestety teraz nie mogę powiem tylko że dodałem Ledy 😃


  14. Chyba nie do końca zajarzyłeś o co chodzi z tym pinem zasilania na złączu turbinki. Przez kontakt nr 3 to Twój układ dostanie zasilanie z regulatora trójfazowego. Jeśli chcesz je wykorzystać (obciążalność pewnie min. 1A), nie jest Ci potrzebny pokładowy stabilizator +5V. Jeśli natomiast chcesz koniecznie sam sobie robić własne 5V to musisz pin 3 tego złącza pozostawić niepodłączony.

    Faktycznie źle zrozumiałem już usunąłem i zostawiłem pin 3 wolny wolę mieć osobny stabilizator 5V na płytce 😃

    No i pominąłeś milczeniem uwagę o stabilizatorze 3V. Po co Ci impulsowy przy poborze prądu kilkanaście mA i po co w ogóle takie napięcie? Procesor zasilany 5V jest (potencjalnie) szybszy - możesz go rozkręcić chyba do 16MHz w odróżnieniu od wersji L, pracującej tylko do 8MHz. Poza tym zasilając procesor, a więc centralną część Twojej logiki z 3V musisz dopasować wszystkie układy z nim współpracujące do tego napięcia. Nie możesz np. wyjść komparatorów dających jak widzę 0 lub 5V doczepić wprost do wejść procesora - jest to poważny błąd w projekcie. Układy generalnie nie lubią widzieć na swoich wejściach napięć wyższych niż własne zasilanie - przejrzyj cały schemat pod tym kątem. Zrobienie jednego zasilania 5V upraszcza sprawę.

    Masz rację zmieniłem już i usunąłem stabilizator impulsowy +3,3V myślałem że to pozytywnie wpłynie na układ ale jak nie na początku chciałem dawać jeszcze modem bluetooth ale stwierdziłem że jest to nie potrzebne więc faktycznie bez sensu ten stabilizator 😃

    Jeśli Twoje 7.4V będzie pochodzić z akumulatora LiPol, to pod koniec pracy dostaniesz z niego tylko 6V - to za mało do prawidłowej pracy stabilizatora 7805. To też musisz zmienić.

    Nie rozumiem pod koniec jakiej pracy ??

    Komparatory nie mają histerezy - jesli to Twój pierwszy schemat to możesz tego nie wiedzieć ale przy kolejnym wypadałoby się z zagadnieniem trochę "oczytać". Bez tego oczywistego "wyposażenia" komparatorów jest to czysta amatorka.

    Nie jest to mój pierwszy schemat ale pierwszy raz korzystam z komparatorów faktycznie nie wiem co oznacza pojęcie histerezy nawet nie wiem gdzie mógł bym o tym doczytać jakieś dodatkowe info jak masz jakąś godną polecenia to chętnie przeczytam i poprawię dopiero się uczę ale wydaje mi się że są poprawnie podłączone wkażdym bądź razie ja nie widzę błędu (niestety ).

    Mając taki procesor możesz puścić wodze fantazji i zrobić kilka podukładów, które nie tylko będą jeździć ale dadzą też trochę zabawy. Koledzy wspomnieli już o nieocenionych diodkach LED i/lub kilku przyciskach. Pomyśl o jakimś wyświetlaczu - choćby od komórki, to nie boli, jest małe a jak już uruchomisz jazdę tego swojego cuda to zabawa się nie skończy na wypatrywaniu linii. Naprawdę tak ściubolisz płytkę, że nie ma na niej miejsca na diodki? To znaczy, że zrobiłeś jakieś błędy w założeniach.

    Niestety mam darmową wersję Eagla i już teraz nie mogę zmieścić swojej płytki w tak małych rozmiarach jak 100x80 mm. Diody dały by fajny efekt to prawda zastosuje je ale jeszcze nie wiem ile , jakie ekraniki polecasz myślałem czy by nie zrobić czegoś podobnego co widziałem na zawodach z oddzielnym ekranem niestety nie ma jeszcze takiej wiedzy.

    Złącze portu szeregowego może okazać się zbawienne, jeśli rzeczywiście program nie będzie trywialny a Ty stracisz kilka dni na zastanawianiu się jakie wartości mają niektóre zmienne w programie i dlaczego (do jasnej..) to wszystko nie działa.

    Tego zdanie nie rozumiem nie wiem no czytam o które złącze chodzi bo nie wiem sorry 🙁

    Proponuje przejrzeć karty katalogowe użytych komparatorów i zastanowić się nad ich dopuszczalnym napięciem wejściowtym. Czy rzeczywiście możesz im zapodać do 5V z potencjometru? Podpowiedź: tam przy okazji będzie coś o histerezie.

    http://botland.com.pl/komparatory/655-komparator-analogowy-lm239smd.html Będę stosował te komparatory no i z tego co widzę to ten napięcie powinno być ok chyba że się mylę ?

    Plik ze schematem ma marną rozdzielczość ale o ile mogę dostrzec, pomiar napięcia akumulatora robisz z 5V? To chyba dość dziwne, nieprawdaż? Co ma poziom tego napięcia do napięcia baterii?

    Mój Błąd 😃 dam teraz w pdf i jpg.

    Czyjnik podczerwieni podłącz do jakiegoś wejścia przerywającego lub choćby zatrzaskującego stan timera, inaczej zużyjesz dużą część mocy obliczeniowej na podglądanie stanu tego wejścia i nie będziesz mógł na bieżąco odbierać transmisji robiąc jednocześnie kilka innych rzeczy związanych z samą jazdą.

    Jak to zrobić mógł byś mi to szczegółowo opisać 😃

    Chce Ci się ciągnąć kilkanaście ścieżek z daleka tylko po to, by wczytać stan prostych sygnałów cyfrowych? Może zrób jakieś rejestry przesuwające, podłącz je do SPI i opędź sprawdę dowolnej liczby czujników tylko trzema drutami?

    To też bym prosił rozpisać jak to zrobić żeby było poprawnie co proponujesz 😃

    A z projektem płytki zaczekaj do momentu aż będziesz absolutnie pewien, że na schemacie jest wszystko to co powinno być i w dodatku prawidłowo połączone. Rozumiesz, że to jeszcze nie ten moment, prawda?

    Wiem zaczekam z projektem płytki najpierw schemat musi być w 200% sprawny 😃

    *Odpowiadałem w cytacie od razu pod pytaniami 😃

    ScreenShot015.thumb.jpg.50335ae8c9284219aaaf1661ec0e10e8.jpg

    untitled.pdf


  15. Jest napisane że zamiast do pinu MOSI podpinasz do PDI, a zamiast MISO do PDO. Natomiast SCK zostaje normalnie.

    [ Dodano: 09-09-2012, 17:21 ]

    Zmieniasz sobie w obciach eagla z cali na cm. Następnie zaznaczasz funkcją mark środek gdzie ma być otwór. Bierz narzędzie circle wybierasz warstwę dimension lub inną i naciskasz na znaczek który zrobiłeś i patrzysz na kordy. W ten sposób wiesz jaka jest wielkość koła

    Dziękuję za te złącze nie zauważyłem a info w ds jest na 301 str 😃 teraz dzięki Panu mam poprawnie podłączone zaraz zacznę robić pbc i wykorzystam tą informację a jeszcze żeby tą turbinę zamontować to dać otwór na 29mm nigdy tego nie robiłem dlatego pytam wolę zapytać niż nie wiedzieć lub zrobić głupi błąd:D

    ScreenShot013.thumb.jpg.c2d62ed0af5aba5c4608557cfb6efc70.jpg

×
×
  • Utwórz nowe...