Skocz do zawartości

Dzonzi

Użytkownicy
  • Zawartość

    30
  • Rejestracja

  • Ostatnio

Reputacja

-1 Słaba

O Dzonzi

  • Ranga
    3/10

Informacje

  • Płeć
    Mężczyzna
  • Lokalizacja
    Nisko
  • Zainteresowania
    Elektro-mechanika

Ostatnio na profilu byli

Blok z ostatnio odwiedzającymi jest wyłączony i nie jest wyświetlany innym użytkownikom.

  1. Witam Mam ten pin nie podłączony i wygląda jakby LCD działał mi normalnie. Mam podłączoną tylko masę po drugiej stronie, tą do pooświetlania. Czy coś tracę nie podłączając masy po lewej stronie?
  2. tylko kurczę nie wiem jak to napisać w programie, bo dosyć średnio ogarniam programowanie.
  3. @atMegaTona Oczywiście, masz rację, ale docelowo to urządzenia ma badać silniki elektryczne, którą potrafią utrzymać równe obroty. Będzie głupio wyglądać, jeżeli będę mierzył prędkość obrotową silnika synchronicznego i pomiary mi będą wychodzić np. 1480-1500-1520
  4. @atMegaTona No to może mierzyć czas 1 obrotu, następnie liczyć do ilości obrotów na minutę, wyświetlić tą wartość na sekundę i znów zmierzyć jeden obrót? Wtedy mierzylibyśmy np. tylko 1 z obrotów występujących w sekundzie.
  5. @RFM Jak w takim razie najlepiej policzyć impulsy? Albo jak pozbyć się bezwładności? Teraz mi pokazuje 1176 lub 1200 RPM i nic pomiędzy. 24 rpm błędy przy takim pomiarze to chyba sporo. To jest ok. 24 obrotów na sekundę czyli przerwanie wychodzi co jakieś 41 milisekund. Z jaką dokładnością arduino potrafi zmierzyć czas między dwoma kolejnymi wywołaniami przerwania?
  6. Na razie wysunąłem wniosek, że nie ma za dużej różnicy między tym forum, a elektrodą
  7. o kurczę to ty jeszcze łatwiej to zrobiłeś. Tak to jest jak się nie programowało od gimnazjum ;/
  8. Mam takie coś w arduino: float f; f = (2*RPM)/60; następnie wyświetlam f w LCD i mam wyniki typu 50.00, 51.00 itd Na miejscach po przecinku zawsze są zera. Co jest źle? Do usunięcia. Rozwiązałem problem.
  9. Zrobiłem wg. tego kursu https://forbot.pl/blog/kurs-arduino-wyswietlacz-tekstowy-lcd-id4263 Wgrałem ten sam kod i wyświetliło mi w obu liniach jakieś randomowe litery, znaczki i symbole. Było nawet tak, że poszczególne kratki wypełniały mi się po kolei znakiem +. Sprawdziłem połączenia i jest tak jak w kursie ;/
  10. A może opaska gumowa którą nałożę na wał i nakleję na nią odblask? Etui od telefonu mam gumowe i nie odbija IR nawet z 1 milimetera, więc chyba by się sprawdziło idealnie.
  11. No właśnie nie mam żadnego regulatora ;/ Podłączyłem na sztywno do płyty głównej. Będę musiał iść i wypróbować na wale jakiegoś silnika elektrycznego. Tylko mam jeszcze taki problem, że wał silnika jest przecież z metalu, a metal odbija IR ;/
  12. Dobra. Teraz mi pokazuje 1176 lub 1200 RPM podczas gdy prędkość tego wentylatora odczytana przez program SpeedFan jest 1185, 1191, 1166... tak się zmieniają te wartości.
  13. No to teraz mi pokazuje 12 rpm, co jest oczywiście niemożliwe, bo na oko widać, że kręci się dużo szybciej.
  14. Bardziej *60000 bo mnożę milisekundy czyli *1000 żeby otrzymać sekundę i *60 żeby otrzymać minutę.
×
×
  • Utwórz nowe...