Skocz do zawartości

certino

Users
  • Zawartość

    15
  • Rejestracja

  • Ostatnio

Reputacja

0 Neutralna

O certino

  • Ranga
    2/10

Informacje

  • Płeć
    Mężczyzna
  • Lokalizacja
    Warszawa
  • Zawód
    Automatyk
  1. Witam Czy ma ktoś z Was może sprawdzoną bibliotekę do tego czujnika dla STMa? Walczę z tym ustrojstwem dosyć długo i nie mogę się uporać.
  2. No a właśnie spaliła jeden kanał, ten który w tym momencie miał akurat działać.
  3. Dziękuję pięknie za super wytłumaczenie. Teraz już wiem czemu spalił się mostek. Pozdrawiam
  4. Witam Zanim przejdę do problemu po krótce opiszę hardware. Siłownik z silnikiem prądu stałego 24V, z czujnikiem halla dwukanałowym, który generuje impulsy z częstotliwością około 50 Hz na kanał. Silnik spięty z mostkiem VNH3SP30, dalej amtega 16. Na początku pierwszy problem. W bascomie linia kodu: Config Timer1 = Pwm , Pwm = 10 , Compare A Pwm = Clear Down , Compare B Pwm = Clear Down , Prescale = 64 I teraz moje pytanie. 1) Jak się przelicza dokładnie częstotliwość pwm z uwzględnieniem taktowania procka, wartości pwm i prescale z powyższej linii kodu ?? Bo przy ustawieniach pw
  5. certino

    Sygnały z czujnika halla

    A jak to sprawdzić ?? Do samego czujnika nie mam żadnej dokumentacji, nie wiem jaki to model bo to wszystko zalane jet plastikiem. [ Dodano: 01-12-2011, 22:37 ] Problem rozwiązany, dziękuję wszystkim za pomoc i wskazówki. Rozwiązanie: wystarczyło poprowadzić zewnętrzny pull-up pod wyjście z halla i wszytsko śmiga jak należy.
  6. certino

    Sygnały z czujnika halla

    Witam A więc nota siłownika halla w załączniku (typ_007_02) Na wejście podaję 5V, na wyjściu otrzymuje około 4.9 V ale w doniesieniu do + a nie GND. Teraz transoptor. Do testów chciałem użyć cny-17. Połączyłem według schematu: Ale niestety nie działa. Co nie tak zrobiłem ?? Typ_007_02.pdf
  7. certino

    Sygnały z czujnika halla

    Co do rozwiązania - czy będzie ono odpowiednio szybkie ? Impulsy bardzo szybko się generują. Co do noty. Na necie nie ma nigdzie, producent dał mi tylko schemat kabli, bez konkretnego modelu czujnika, ale w tym schemacie jest również coś nie tak, bo z siłownikiem nie zgadza mi się. Czekam na wyjaśnienie. Jak tylko dostanę będę kontynuował temat.
  8. certino

    Sygnały z czujnika halla

    Dobra 5 V już mam, teraz kwestia odwrócenia biegunów podawanych na atmege.
  9. Witam Potrzebuję sterować siłownikiem z silnikiem prądu stałego z czujnikiem halla. Czujnik ten według producenta miał dawać sygnały na poziomie 5 v (czujnik 2 kanałowy). Niestety czujnik nie dosyć że daje sygnały 12 v, to jeszcze w doniesieniu do + a nie do masy ( w połączeniu wyjścia z masą nie ma nic). W związku z tym nie mam pomysłu jak to sprzęgnąć z Atmegą 16. Poziom 12 V jeszcze by jakoś zbił do 5 ale to odniesienie do + to mnie zbija z tropu
  10. Witam Nie zakładam wciskania 2 przycisków jednocześnie, dlatego to co mam mi wystarczy. Co do drgań styków nie mam problemu są wyeliminowane programowo i dodatkowo dołożyłem ceramik przy każdym porcie do masy. Wciśnięcie przycisku powoduje 1 przerwanie więc nic nie drga.
  11. Odwrócenie diod pomogło. Aczkolwiek jest to dla mnie dziwne ale ważne że działa. Dziękuję wszystkim za pomoc. Pozdrawiam
  12. A odwrotnie diody to przypadkiem nie będzie cały czas niskiego stanu na przerwaniu ?
  13. Chodzi aby wywołać jednym switchem stan niski na danym porcie i na przerwaniu. Na porcie się wywołuje ale na przerwaniu już nie. Według mnie jak nie będzie diod to naciśnięcie dowolnego switcha wywoła stan niski na przerwaniu i na wszystkich portach jednocześnie.
  14. Tak ale wtedy jak wcisnę switch1 to będę miał stan niski na porcie 1 i 2 i nie będę wiedział który switch wciśnięty.
  15. Witam. Obrazek przedstawia kawałek układu. Kreski symbolizują switche z jednej strony podłączone do masy, z drugiej do portu. Dodatkowo dołożony jest ceramik łączący z masą. Z założenia miało by to działać tak, że: Na porcie jest stan wysoki, tak samo jak przerwaniu. Po wciśnięciu switcha jest zwarcie do masy na porcie (stan niski). Niestety na przerwaniu nie pojawia się stan niski (napięcie spada tylko o jakieś 0.3 V). Dioda jest jest po to by kilka switchy podłączyć pod jedno przerwanie, a jednocześnie by np switch 2 nie działał na port 1. Gdzie może być problem ??
×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.