Skocz do zawartości

Sabre

Moderator
  • Zawartość

    3037
  • Rejestracja

  • Ostatnio

  • Wygrane dni

    137

Wszystko napisane przez Sabre

  1. @ethanak to jest właśnie joystick podobny do tych z jakichś nowych padów od chyba xboxa albo PS, nie wiem dokładnie. On ma zupełnie inny sposób mechanicznego sprzężenia z potencjometrami. Tam są ścieżki rezystancyjne naniesione na laminat, który widać od spodu. A nie tak jak w tych chińskich modułach mechaniczne sprzężenie z potencjometrem kiepskiej jakości. Kupiłem na ebayu joysticki z potencjometrami alpsa, ponoć oryginalne, ale jeszcze ich nie testowałem czy się czymś różnią od tych chińskich. Wyglądają identycznie, więc można je podmienić jeśli okaże się, że potencjometry są rzeczywiście lepsze i ruch gałki jest odwzorowany w rezystancji w większym zakresie ruchu.
  2. @piotrva za dużo zabawy, nie mam drukarki 3D. I niestety to nie byłoby to samo, te są pokryte gumą na wierzchu. Myślałem w którymś momencie o przerobieniu ich na magnetyczne, tak jak w bardzo dobrych komercyjnych aparaturach RC (są magnetometry, które liniowo mierzą pole magnetyczne z wyjściem analogowym w obudowie zbliżonej do TO92), ale prawdę mówiąc te zdają egzamin jak na razie. Planuję zrobić drugą aparaturę bo chcę trochę inną niż tą, którą już zrobiłem, do małych samolotów RC. Mają powstać wkrótce, ale zobaczymy co z tego wyjdzie.
  3. @piotrva nie opłaca się, to po pierwsze (dobre są drogie), a po drugie są znacznie większe, co przekreśla ich użycie do małej aparatury zabawkowej. Myślałem nawet o wymianie potencjometrów w tych joystickach, ale to również jest mało praktyczne ze względu na ich specyficzność. Pewnie nie znalazłbym w takich samych obudowach ale o lepszej jakości, czy raczej większym zakresie rezystancji w stosunku do wychylenia gałki.
  4. @ak95 u mnie odwrotnie, od środka jest ok, a od połowy wychylenia już nie ma zmiany wartości. Widać to na filmie, który dodałem. Szukałem w miarę tanich joysticków tego typu o lepszej jakości, ale nic takiego nie znalazłem. Są joysticki, które są do padów xboxa chyba albo PS, i one są mniejsze i ponoć lepsze, ale mi by już nie pasowały bo są dużo niższe bo są bez płytek dodatkowych jak te tutaj.
  5. Za koszt tych modułów niczego lepszego nie da się kupić. Ja zrobiłem coś podobnego dwa lata temu. Moje radio ma dodatkowo przetwornicę zasilającą radio 5V z akumulatorka li-ion 18650 i płytkę zabezpieczającą ogniwo przed rozładowaniem i jednocześnie układem ładowania. Do tego dodałem jeszcze wyświetlacz graficzny od Nokii 3110? Radio to steruje samochodzikiem kupionym na aliexpress.
  6. To jest zwykły laminat szklano-epoksydowy, ale nie pokryty miedzią. Można taki kupić, ale osobiście widziałem i kupowałem tylko taki bez otworów. Często w sklepach modelarskich jest, wystarczy szukać po słowach kluczowych: laminat szklano epoksydowy FR4 lub G10. Ewentualnie płyta szklano epoksydowa. Tutaj masz różne, tu również. Napisz może do czego go potrzebujesz i czy musi być z otworami.
  7. @Elvis niby tak, dużo zależy od zbyt dużej ilości zbiegów okoliczności. Tutaj sam przyznasz, że jest zbyt dużo niewiadomych i zbyt dużo postawione jest na przypadek. Brak wyznaczonego prądu diody transoptora, brak ograniczonego prądu fototranzystora, i tym samym bazy BC911. Maksymalny prąd kolektora fototranzystora to 50mA, oczywiście prawdopodobnie taki prąd nie popłynie bo wtedy VCE wzrośnie i prąd sam spadnie. Ten układ to taki przypadek gdy urządzenie zbudowanie niezgodnie ze sztuką działa prawidłowo, ale tylko dlatego że układ ustabilizuje się sam dla tej nieszczęsnej baterii 1,5V. W pewnym momencie ktoś to skopiuje a ktoś się zapomni i zbuduje ten układ i da zamiast baterii 1,5V inne napięcie albo zasilacz i spali transoptor nie mając zielonego pojęcia o tym co i dlaczego się stało. Dlatego właśnie nie powinno się powielać takich układów zrobionych niezgodnie ze sztuką.
  8. Układ nie jest wykonany prawidłowo, to prawda, ale działa. Działa tylko dzięki przypadkowi czy raczej pewnym ograniczeniom jakie na układ zostały narzucone. Nie wiem skąd @Bystrzacha wziął taki schemat i na podstawie jakiego toku rozumowania podłączył tam baterię 1,5V. Układ działa tylko dlatego, że suma napięć VCE fototranzystora w nasyceniu i VBE BD911 będą równe właśnie około 1,5V (około 0,8V dla fototranzystora z PC817 i około 0,7V dla złącza baza-emiter tranzystora BD911). Przy zasilaniu tych złącz z baterii 1,5V prąd powinien się sam ustabilizować na poziomie około 20-30mA zgodnie z dokumentacją PC817. Nie jest to prawidłowe wykorzystanie tych elementów i baterii 1,5V. Przy takim podłączeniu, prąd tranzystora BC911 nie będzie zbyt wysoki i raczej nie spodziewałbym się niczego powyżej 1A. Układ będzie działał nawet na nieświeżej baterii, bo spadek napięcia zasilania tych złącz, spowoduje mniejszy prąd kolektora fototranzystora, przez co jego napięcie VCE spadnie, bałbym się bardziej sytuacji, gdy zostanie podłączona nowa bateria, której napięcie może przekroczyć 1,6V. Spowoduje to przepływ zbyt wysokiego prądu przez fototranzystor i może doprowadzić do jego uszkodzenia.
  9. Zgaduję, że może być problem z zasilaniem, 9V bateria nie nadaje się do zasilania czegokolwiek co pobiera powyżej 100mA, a na pewno cały taki robocik pobiera dużo więcej prądu. Spróbuj zasilić z czegoś o większej wydajności prądowej, np. z jakiegoś lepszego zasilacza. Ewentualnie zrób test samego czujnika i arduino bez zasilania czegokolwiek więcej, czyli bez silników i innych wodotrysków.
  10. Czym zasilacie arduino i czujnik? Z tego co pamiętam to zasilanie przy tym czujniku musi być dość czyste a przy samej płytce czujnika spory kondensator.
  11. Nie chcę krytykować ani twórcy, ani produktu, ale widziałem online maszynkę do produkcji filamentu z resztek po drukowaniu i tamto to był szczyt techniki w porównaniu z tą maszynką. Miał kilka silników, zamknięty dość duży pojemnik do grzania tworzywa. Do tego chłodzenie wychodzącego filamentu w wodzie. I szczerze, to komentarz testującego ten filament był kiepski, że mimo tych wszystkich technikaliów to daleko temu filamentowi do nowego kupionego w sklepie, bo wcale nie jest łatwo kontrolować średnicę. Tutaj widzę nie topienie, tylko bardziej rolowanie wstążki w niesklejony, wyciągnięty rulon, który mam wrażenie, że jest pusty miejscami w środku. I zgodzę się z @Elvis , że wygląda to na reklamę produktu, który ma więcej wad niż zalet. @sergiuszf ja poproszę o zdjęcie i to nie byle jakie zdjęcie, a zdjęcie makro jakiegoś wydruku z użyciem tego filamentu. Oraz zdjęcie makro samego filamentu, bo to kluczowe przy takiej konstrukcji. Na razie to taka reklama produktu, który ładnie wygląda, coś robi, ale efektów jego pracy nie widzieliśmy tak naprawdę. Coś takiego może się nadawać co najwyżej do tych długopisów drukujących dla dzieci, bo widziałem, że ktoś używał do takich długopisów surowych pasków wyciętych właśnie z butelek.
  12. Można tak podłączyć zasilanie, ale no właśnie ale. RasberryPi pobiera prąd zawsze, dlatego rozładował Ci się pierwszy pakiet. A co do napięć na poszczególnych ogniwach, to świadczy to albo o kiepskiej jakości pakietu, albo o ładowaniu bez ballancera. Wtedy ogniwa nie ładują się równo, dlatego zawsze któreś rozładuje się szybciej w pakiecie. Ewentualnie mają nieco inną pojemność, przez co dwa rozładowały się szybciej.
  13. Na tym wyjściu nie ma napięcia ponieważ ten pakiet ma płytkę zabezpieczającą tzw BMS. Ona odcina napięcie na wyjściu żeby nie rozładować pakietu bardziej co mogłoby doprowadzić do uszkodzenia ogniw, albo całego pakietu. Gdybyś miał zasilacz z regulacją prądu i napięcia mógłbyś naładować każde z ogniw osobno podłączając się pomiędzy odpowiednimi stykami, ale nie doradzę Ci nic więcej bo to może się źle skończyć jeśli będzie ładowane w nieodpowiedni sposób. Gdybyś zrobił zdjęcie makro tego układu z dużą ilością nóżek, ewentualnie spisał oznaczenie układu (o ile w ogóle jest), bo możliwe, że ta płytka jest również kontrolerem ładowania, to wtedy możliwe byłoby naładowanie tego pakietu. Pakiet nie ładuje się w głośniku?
  14. Zostanę pewnie zlinczowany przez niektórych, ale tak, możesz tak zrobić ale pod jednym warunkiem. Sprawdź najpierw organoleptycznie jaki rzeczywiście prąd będzie płynął przez taką gałąź złożoną z 4 diod połączonych szeregowo i zmierz napięcie na każdej diodzie. Da Ci to pojęcie z czym masz do czynienia. Wiem z doświadczenia, że najtańsze diody mają ogromny rozrzut parametrów i niestety każda z diod może mieć, i na pewno będzie miała, inne napięcie przewodzenia. Do tego zasilacz którego użyjesz musi być stabilizowany, te 12 czy 24V muszą na nim być od razu bez obciążenia. Jeśli przez gałąź popłynie 10mA i mniej to spokojnie możesz takie połączenie wykonać. Musisz się jednak liczyć z tym, że jak złożysz 30 takich gałęzi, to jedna z nich może mieć mniejszy spadek napięcia niż pozostałe (zależy to od jakości diod) i wtedy przez tą gałąź popłynie większy prąd niż przez pozostałe. Może to spowodować nierówne jasności świecenia poszczególnych gałęzi. Najlepiej byłoby gdybyś każdą gałąź przetestował pod kątem płynącego prądu, jeśli różnica będzie na poziomie 1-2 mA przy założeniu, że normalnie popłynie 10mA to nic nie powinno się wydarzyć złego. I teraz tak, proszę nie pouczać mnie, że tak się nie robi, bo robi się i to od dawna. Diody zasilane poniżej nominalnego prądu w gałęziach gdzie nie będzie możliwości wzrostu napięcia mogą być w ten sposób łączone. Dodam tylko, że oczywiście jednej diody nigdy nie można tak podłączać bo z hukiem się spali. Do tego często bywa tak, że soczewka diody wybucha i to z niezłym impetem. W tym przypadku spadek napięcia na 4 diodach będzie wystarczający do przepływu mniejszego prądu niż nominalny. Tak być powinno, ale przy diodach niewiadomego pochodzenia i o nie wiadomo jakich parametrach, najpierw trzeba wykonać pomiar dla jednej takiej gałęzi.
  15. Jeden z finałowych przejazdów Cukiereczka na Robomaticonie. Przepraszam za jakość, ale przy takim oświetleniu w sali (zasłonięte zasłony) to mój smartfon zbyt ładnie na nagra.
  16. Osobiście nie rozumiem sensu tego pytania. KTIRy mają to do siebie, że ułożone katalogowe 2mm od powierzchni toru (do powierzchni czujnika), widzą trochę szerzej niż ich pole powierzchni. I te trochę to wcale nie jest takie trochę, stożek podczerwieni ma 4mm drogi w tą i z powrotem. Po co więc ustawiać KTIRy tak, aby dotykały się obudowami? Mateusz, jeszcze raz gratuluję Ci wygranej i dziękuję za opisanie Cukiereczka.
  17. Byłem na zawodach jako widz, obszedłem całą aulę na około dwa razy i zachodząc w głowę, czy jestem ślepy czy czegoś jednak nie wiem, poszukałem kogoś z organizatorów, aby zapytać gdzie są linefollowery. Dowiedziałem się wkrótce, że są na drugim piętrze w sali 206. Nigdzie nie widziałem żadnej informacji, że tam są te zawody organizowane (może gdzieś taka informacja była, ale nie rzucała się w oczy). Spędziłem w tej sali większość czasu do końca zawodów. Widać było pewien brak doświadczenia u organizatorów, ale podejrzewam, że większa ich część robiła to pierwszy raz . Były problemy z odklejającą się taśmą na torze, ale każda zgłoszona uwaga co do toru praktycznie od razu skutkowała jego naprawą. Osobiście pamiętam czasy, gdy to zawodnicy biegali ze ściereczkami i przed przejazdami czyścili sami tor. Przez umiejscowienie toru w innej sali na 2 piętrze a nie na parterze, to miejsce odwiedzało mało widzów. Można było praktycznie cały czas stać przy barierce i oglądać przejazdy. I tutaj dziękuję wszystkim, którzy ze mną rozmawiali, za cierpliwość , wróciłem do domu z bólem gardła . Gratuluję Mateuszowi zajęcia pierwszego i drugiego miejsca w linefollowerach, a Kornelii zwycięstwa w minisumo. Mam nadzieję, że następnym razem spotkamy się po tej samej stronie barierek, trochę mnie zmobilizowaliście do ukończenia dawno odkładanych nowych linefollowerów .
  18. Ktoś się wybiera ? Ja najprawdopodobniej będę , w roli widza tylko, a może i aż. Dawno nie brałem czynnie udziału w zawodach.
  19. @grg0 , no tak masz rację, nie wiem jak mogłem to przegapić, że sterowanie diodą dodaje kolejną negację. Gdy tworzyłem schemat tego odbiornika, traktowałem 6N137 jako element, który neguje to co jest na wejściu. A przy sterowaniu zgodnym z dokumentacją, on nie neguje wejścia, bo 0 na diodzie da 0 na wyjściu. Eh, człowiek czasami zbyt szybko wszystko układa z tylko prostą analizą. Tak więc to co pisałem 2 posty wyżej jest błędne:
  20. Ale schemat się nie zmienił jeśli chodzi o logikę. Zmieniłem tylko sposób w jaki steruję diodą, czy za pomocą logicznej 1 czy 0. Ilość negacji w obwodzie jest taka sama. Nie wrzucałem schematu ze względu na brak elementów w bibliotece eagla (a nie czułem potrzeby ich tworzenia ze względu na jednostkowość użycia), mam na schemacie inne elementy wrzucone, które mają identyczne obudowy. W dokumentacji 6n137 każą zasilać anodę diody do Vcc a sterować od strony katody. I tak zrobiłem i mi to nie działało. Teraz steruję diodą od strony jej anody, a katoda jest podłączona do GND. Ilość negacji się przez to nie zmienia, bo czy starujesz 0 czy 1, obwód musi zanegować 2 razy ten sygnał bo raz neguje 6N137. Według mnie, któryś z elementów miał zbyt niską wydajność prądową i nie przechodziła jakaś 1 albo 0. Choć elementy dobierałem tak, aby tą wydajność miały jako source i jako sink, czyli i w 0 ,i w 1.
  21. Poniekąd wszystko jest jasne i wszystko już działa poprawnie. Nie do końca rozumiem dlaczego, ale działa. Tak jak mi doradzał @grg0 sprawdziłem czy wszystko działa na krótko. Okazało się, że z pominięciem kabla dalej jest tak samo, czyli brak właściwych kolorów na diodach WS2812B a zamiast animacji kolorów jest w przeważającej części kolor biały. Dało mi to poniekąd do myślenia, ten kolor biały, że może sygnał nie tyle nie przechodzi po kablu nieprawidłowo, co gdzieś jest brak negacji i sterowanie nie jest takie jak być powinno. Do tej pory było tak: dioda transoptora była zasilana z plusa a jej minus był zwierany sygnałem z bufora SN74LVC1G126 do masy, potem był 6N137 a na jego wyjściu bramka NAND ze spiętymi obydwoma wejściami i podciągniętymi przez rezystor 350 Om do Vcc, wyjście tej bramki szło na wejście diod WS2812B. Teraz jest tak: dioda transoptora jest zasilana sygnałem z bufora SN74LVC1G126 a jej katoda jest podłączona do masy. Reszta jest bez zmian, a mimo to działa. Odwróciłem sterowanie na wejściu i zaczęło działać. Analizując połączenia doszedłem do wniosku, że oryginalne połączenie musiało nie dawać w którymś momencie odpowiedniego potencjału i nie przechodził sygnał poprawnie, pomimo, że z wejścia na wyjście sygnał jest dwukrotnie negowany niezależnie od połączenia 1 czy 2. W pierwszym połączeniu 0 z mikrokontrolera za buforem było dalej 0, po przejściu przez 6N137 dawała 1 i po zanegowaniu przez NAND wychodziła znowu 0. W nowym połączeniu jest tak, że 1 z mikrokontrolera za buforem daje 1, po przejściu przez 6N137 daje 0 i po zanegowaniu przez NAND wychodzi znowu 1. Logika poprawna w obu przypadkach a mimo to pierwsze połączenie nie działało, dopiero zamiana sposobu sterowania diody 6N137 zadziałała. Dziękuję wszystkim za pomoc, już dzisiaj nie mam głowy do analizowania tego czy któryś z elementów miał za małą wydajność prądową do odpowiedniego sterowania 0/1. Teraz pora na kolejne wyzwanie, napisanie aplikacji na Androida, która przez BT sterowałaby ledami. Znacie jakieś proste środowisko do stworzenia takiej apki?
  22. Ok, ale w takim razie czy pominąć zupełnie transoptor i użyć 2 driverów RS485? Kabel leży razem z kablem od 230V, dlatego chciałem optoizolację.
  23. Dzisiaj trochę nie mam czasu żeby wybebeszyć płytki i spiąć je na krótko, jutro mnie nie ma. Mam nadzieję, że w weekend wrócę do tematu. Co do RS485 to niekoniecznie on obsłuży taką prędkość transmisji, ale mogę się mylić. W ostateczności zmienię koncepcję i zamiast sterować ledami bezpośrednio, będę po kablu przekazywał tylko informację co ma się wyświetlać, a na miejscu kolejny mikrokontroler zinterpretuje tą informację i zamieni ją na sterowanie dla WS2812B. Wtedy pewnie wystarczy dużo niższa częstotliwość i sygnał przejdzie bez problemu przez moje ustrojstwo ;). Wczoraj sobie przypomniałem dlaczego pod tynk poszedł ten kabel. Był tani, to po pierwsze, po drugie na początku to miało być sterowanie zwykłą tasiemką RGB. Kabel poszedł w ścianę, potem weszły diody inteligentne i koncepcja mi się zmieniła na właśnie WS2812B :).
  24. Szczerze, to nie sprawdziłem tego, z kilku powodów. Sprawdzę jutro, jeśli znajdę chwilę. Układ był podzielony, tzn. część jest lokalnie i działa wraz z układami wyjściowymi, a część ledów jest właśnie na kablach przez transoptory. Nie testowałem tego obok siebie bo na papierze wyglądało, że zadziała. Rezystor jest podzielony na pół, 180 Om na wyjściu przy nadajniku i 180 Om na wejściu przed transoptorem, pomiędzy rezystorami kabel.
×
×
  • Utwórz nowe...