Skocz do zawartości

wyoyo

Users
  • Zawartość

    24
  • Rejestracja

  • Ostatnio

Reputacja

0 Neutralna

O wyoyo

  • Ranga
    2/10

Informacje

  • Płeć
    Mężczyzna
  1. wyoyo

    Linefollower nie reaguje na linie

    Niee, tylko kilka ceramicznych przy silniczkach i przy 20 i 21 nóżce uC. Podobnie jak na schemacie.
  2. wyoyo

    Linefollower nie reaguje na linie

    Napisałem taki program: $regfile = "m8def.dat" $crystal = 1000000 'Konfiguracja sterowania sprzętowym PWM Config Timer1 = Pwm , Pwm = 8 , Prescale = 1 , Compare A Pwm = Clear Down , Compare B Pwm = Clear Down 'Konfiguracja portów Config Portd = Output Config Portb = Output 'Opis portów 'Enable1 - Silnik lewy - Portb.1 (PWM1A) 'Enable2 - Silnik prawy - portb.2 (PWM1B) 'Input1 - Silnik lewy A - Portd.3 'Input2 - Silnik lewy B - Portd.2 'Input4 - Silnik prawy A - Portd.0 'Input3 - Silnik prawy B - Portd.1 'Dioda - Portd.6 'Czujnik lewy - ADC5 'Czujnik środkowy - ADC4 'Czujni
  3. wyoyo

    Linefollower nie reaguje na linie

    Niestety, wgrałem program, jeżdżą w dwie strony zależnie od programowania, sprawdzałem podłączenia od czujników do uC i wszystko gra, robot dalej nie reaguje na linię. Co jeszcze mogę zrobić ?
  4. wyoyo

    Linefollower nie reaguje na linie

    Zmniejszyłem napięcie, odległość czujników wynosi 0,2 mm dalej to samo, czujniki nie reagują, robot nie staje w miejscu gdy czujniki są nad białym polem, nie reaguje też na linie.
  5. wyoyo

    Linefollower nie reaguje na linie

    Napięcie wynosi 5,7 V przed włączeniem układu, a po włączeniu wynosi 4,7V. Odległość czujników to około 0,5cm
  6. Zrobiłem robota zgodnie z tym artykułem: https://www.forbot.pl/forum/topics20/dla-poczatkujacych-przepis-na-robota-w-pelni-programowalny-line-follower-vt2356.htm Po zlutowaniu płytki i wgraniu programu zamieszczonego w załączniku artykułu, robot tylko jeździ do przodu. Nie reaguje na czujniki. Ponadto jeden czujnik jest uszkodzony, ponieważ nie świeci się dioda UV pod aparatem komórkowym, po zamianie miejscami 2 czujników reakcja taka sama. Zmierzyłem napięcie jakie przechodzi przez fototranzystor w układzie podczas różnych sytuacji. Gdy czujnik jest znajduje się nad białą kartką napięcie wyn
  7. Jeśli można wiedzieć, w jakim czasie od zagadki, przyszedł poprawny e-mail wygrywający ? Ostatnio było to 2 minuty, ciekawy jestem jak tym razem.
  8. Witam, mam mały problem z tym projektem. Po zlutowaniu robota i wgraniu programu z artykułu, robot jedzie do przodu, nie reagując na czujniki, ponadto jeden z nich pod aparatem z komórki nie świeci. Co mogę sprawdzić, zrobić aby robot reagował na linię ?
  9. na razie jednak zrobię tak jak jest w artykule, a ewentualnie następnego robota zrobię z innymi czujnikami i płytką zaprojektowaną
  10. Czyli na tej płytce to ciężko będzie dać SMD tak ? Czy tylko wystarczy inaczej przylutować (nie wiem nawet jak )
  11. Mam dwa pytania, po pierwsze, czy dodanie dwóch czujników znacznie polepszy działanie robota? Po drugie, chciałem się zapytać czy można użyć inne czujniki niż CNY70, tak, aby nie trzeba było zmieniać nic w schemacie i żeby były równie dobre jak CNY70.
  12. znalazłem coś takiego w domu: http://ep.com.pl/files/2138.pdf tylko oczywiście nie działa. Próbować lutować wszystko od początku ?
  13. Zrobiłem światłoluba i lineflowera programowalnego, z artykułów. Trochę się nauczyłem przy tym programowania, ale nie umiem zbyt dużo.
  14. Przejrzałem te artykuły i pytania już wcześniej, ale nie bardzo jest mowa o takich robotach.
  15. Witam, chciałem zrobić od podstaw robota z dwoma silnikami i ogólnie jak najmniejszą ilością części, który będzie sterowany pilotem (który również chce zrobić). Robot ma tylko jeździć we wszystkie strony. Sądzę że to nie jest zbyt skomplikowane, ale proszę o pomoc, może są jakieś linki z opisem do czegoś podobnego. Z góry wielkie dzięki za pomoc Pozdrawiam Wojtek
×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.