Skocz do zawartości

Phil

Użytkownicy
  • Zawartość

    200
  • Rejestracja

  • Ostatnio

  • Wygrane dni

    4

Phil wygrał w ostatnim dniu 10 maja 2015

Phil ma najbardziej lubianą zawartość!

Reputacja

13 Dobra

O Phil

  • Ranga
    5/10
  • Urodziny 03.04.1998

Informacje

  • Płeć
    Mężczyzna
  • Zainteresowania
    Robotyka, Elektronika, Geocaching

Ostatnio na profilu byli

Blok z ostatnio odwiedzającymi jest wyłączony i nie jest wyświetlany innym użytkownikom.

  1. 1. Jeśli to możliwe, staraj się unikać projektowania "na styk", szczególnie, jeżeli nie masz wszystkich części u siebie. Dobrze jest sobie zostawić margines, gdyż czasem niektóre elementy np. akumulatory mogą mieć wymiary odbiegające od tych podanych na stronie sklepu/producenta. 2. Projektując elektronikę spróbuj wykorzystać wszystkie piny mikrokontrolera. Jeśli zostaną jakieś "wolne" podłącz do nich np. dodatkowe diody LED i/lub przyciski. Możesz też przeprojektować schemat tak, by wyprowadzić jakiś interfejs komunikacji np. UART. Ułatwi to późniejszą pracę przy programowaniu układu.
  2. Phil

    [Microsumo] Fila

    fazi787, zgodzę się z Trekerem. Pług warto przemyśleć w miarę wcześnie, a jeżeli rzeczywiście chcesz sobie zostawić na koniec, to polecam zostawić sobie trochę wolnego miejsca. Co do połączeń kablami, to postaraj się ograniczyć ich ilość do minimum i przemyśl jak będą przebiegać wewnątrz robota. Jeden TB6612 to nie za mało do 2x Pololu HP? W xSumo może dojść do zatrzymania wału, a prąd może przekroczyć maximum dla tego mostka. U siebie w bocie dałem na wszelki wypadek dwa zmostkowane. Chciałem mieć pewność, że nic się nie zepsuje
  3. Nie wiem jak w tym, ale w zeszłym roku i dwa lata temu na Roboxy w strefie serwisowej były hotairy chyba, na pewno zwykłe stacje lutownicze i oscyloskopy jak się nie mylę.
  4. Phil

    Atmega644 - pozycjonowanie serwa

    Ale zdajesz sobie sprawę, że 50ms to 0,05s? Zwiększ wartości.
  5. Phil

    Atmega644 - pozycjonowanie serwa

    Pokaż jak wyglądały "Zabiegi z delay"
  6. To pytanie może się wydawać głupie, ale czy na pewno wszystko co ma być podłączone do +5V jest podłączone? Bo po schemacie widać, że VCC procka nie jest połączone z "VCC_5V_ZASILACZ"...
  7. Brak rezystora 10k łączącego RESET z VCC...
  8. Phil

    Alternatywa dla Sharpa

    mosi2, no właśnie niestety produkcja tych czujników została zatrzymana. Nigdzie ich nie można dorwać... Póki co jedyną alternatywą z gotowych rozwiązań zachowując małe rozmiary, są sharpy 10cm, ale to nie to samo
  9. Phil

    Typhoon

    aixI, racja, akumulator jest przyduży, akurat taki miałem i tak zostało. Poza tym jakby na to nie patrzeć robot za szybki też nie jest i większych prędkości nie osiągnie, choćby ze względu na budowę - jest krótki, rozstaw kół też jest mały. Teraz bym pewnie użył z mniejszą pojemnością. Co do mocowań Pololu - naczytałem się tylu negatywnych opinii, że nawet nie myślałem, żeby ich użyć. Taśma widoczna na filmach ma szerokość 19mm. Postaram się dodać więcej zdjęć do opisu. Treker, popracuję nad omijaniem przeszkód. Tak naprawę niedawno dolutowałem czujnik przeszkód, więc jest to nowa funkcja w robocie, przydały by się enkodery, ale cóż. Co do kątów prostych: ostatni film był nakręcony najwcześniej(zaraz dodam o tym informację w opisie), więc i algorytm był dość stary. Obecnie jest napisany tak, że nie ma możliwości, żeby tak wypadał na zakrętach. EDIT: Nie doczytałem aixI, kodu nie wrzuciłem bo straszny śmietnik mam tam, schemat też do najładniejszych nie należy. Ogólnie innowacji nie ma, ale może jak ogarnę to wrzucę.
  10. Hudyvolt, nie miałem takiego, dodałem 3x22uF równolegle przy "wadliwym" czujniku i szumy pozostały, ale się znacznie zmniejszyła ich ilość i częstotliwość. Dodałem jeszcze jedną taką "baterię kondensatorów" przy sąsiadującym czujniku i zdaje się że zanikły totalnie. Dodam jeszcze przy dwóch pozostałych na wszelki wypadek. Wnioski: -dobre filtrowanie kluczem do sukcesu -należy wczytywać się głębiej w notę katalogową Dzięki wielkie Wam za pomoc i zainteresowanie się tematem
  11. Rezystor sprawny, dla pewności wymieniłem, bez zmian. napięcie na nóżkach czujnika wynosi +/- 4.8V, chyba nie powinno robić problemu. Połączenia sprawdzone, są ok. W stanie detekcji na wyjściu jest blisko 0V, w stanie ustawionym ok. 4.8V. Napisałem program, który mi filtruje te impulsy, będę musiał to chyba jakoś przeżyć...
  12. Czujnik jest ustawiony prostopadle do innych, nie ma możliwości, żeby tak świecił.
  13. No więc sprawa wygląda tak: mam płytkę z 4 czujnikami sharp GP2Y0D340K, 3 z nich działają prawidłowo, jeden jak się okazuje ma pewien defekt. Niby działa jak powinien: gdy wykryje przeszkodę daje odpowiedni stan na wyjściu, ale gdy nic przed nim nie ma to ma tendencję do nagłych zmian stanów na wyjściu. Podłączony jest jak w nocie katalogowej. Wykluczyłem winę mikrokontrolera, którym odczytuję stan, podłączając czujnik do różnych nóżek. Dodałem dodatkowy kondensator 100nF na zasilaniu, bez efektów. Co może być przyczyną? Mam nadzieję, że nie jest to wrodzona wada... tych czujników już chyba nigdzie nie dostanę, a zawody się zbliżają wielkimi krokami
  14. Phil

    Bugi na forum bądź stronie

    U mnie widać to samo (podwójnie).
  15. No to powodzenia, trzymam kciuki. Czasu masz niewiele, ale cel jest możliwy do osiągnięcia.
×