Skocz do zawartości

aixI

Użytkownicy
  • Zawartość

    782
  • Rejestracja

  • Ostatnio

  • Wygrane dni

    13

Posty napisane przez aixI


  1. Jeżeli ma to być robot edukacyjny to, np. jeden mostek H (TB6612) styknie, ale jeżeli ma wygrywać zawody, a jak chodzi o minisumo, to jeden mostek H (TB6612) będzie zły, bo może się szybko spalić pod wpływem obciążenia, długiego zatrzymania, uderzania się robota z innym robotem. Lepiej dać jeden mostek na jeden silnik czyli trzeba byłoby kupić dwa mostki na dwa silniki.

    • Lubię! 1

  2. Turech - ja sam sprawdzam pracę mojego robota właśnie przez diody LED, RS232 (UART) po kablu i bezprzewodowo przez Bluetooth'a - moduł BT jest mały (wymiary) i potrzebuje tylko czterech pinów (VCC, GND, TX, RX) i można pracować. Takie małe, a cieszy 🙂

    Przy okazji mogę polecić ten artykuł.


  3. Masz jeszcze cztery piny wolne - może wykorzystaj je do czegoś? Np. wolny pin ADC wykorzystaj na pomiar napięcia z akumulatora, aby Ci się nie rozładował poniżej ustalonego progu i oczywiście nie zepsuł. Możesz dodać też kolejną diodę LED - naprawdę się przydają podczas sprawdzania programu 🙂

    Tak ogólnie schemat wygląda ok.


  4. Jeżeli tak masz połączone, to źle podłączyłeś fototranzystor - tam gdzie teraz masz masę masz kolektor, a powinien być na masie emiter - zgodnie ze schematem z pierwszego postu.

    Czemu aż tak duży rezystor ograniczający prąd diody IR - 1k to przesada. Daj jakiś 220-330R (Ohm)


  5. Widzę, że testujemy ShoutBox'a na górze strony - wygląda spoko niż na samym dole i inaczej niż na innych forach. Jedyne co zmieniłbym w ShoutBox'ie na górze, to to, aby miał nową i ładniejszą szatę graficzną i moim zdanie będzie dobrze.


  6. Czy może ktoś potwierdzić czy te silniki nie będą zbyt dużym obciążeniem dla mostka L293D?

    Mogą być, jednakże prąd obciążenia wynosi 1A, a mostek ma na pojedynczy kanał tylko 600mA (jak dobrze pamiętam) i chwilowy prąd obciążenia 1,2A. Ogólnie mostek da radę.

    Czy konieczne będą ewentualne zmiany w schemacie?

    Raczej nie bo tylko kupujesz same podwozie z silnikami i kołami.


  7. Nie rozumiem... Mam czujnik który wysyła logiczne 1 (5V) lub logiczne 0 (0V). Podpinam to do pinu uC tak jak zwykłego switcha i odczytuję wynik. Czemu więc wszyscy mnie przed tym ostrzegają ? Przecież ADC będzie porównywało napięcie do tego podanego mikrokontrolerowi na nóżkę AVCC i jeśli się zgadza to 1 a jak nie to 0. Jaka róznica jest między ADC a zwykłym pinem ?

    Ty w swoim procku (ATtiny2313) nie masz przetwornika analogowo-cyfrowego (ADC), to po pierwsze.

    Chodzi mi (nam - osobom z Forum), że możesz mieć problemy podczas jazdy swoim robotem, ze względu, np. na oświetlenie, (może) rodzaj materiału po którym Twój robot by jeździł.

    Przeczytaj ten temat.


  8. MrWeb123 dużo ryzykujesz podłączając wyjścia czujników bezpośrednio do pinów I/O mikrokontrolera. Jak nie chcesz używać ADC (którego ATtiny2313 nie ma), to może daj jakiś komparator - będzie lepiej odczytywać logiczną jedynkę albo zero.

    Masz wolne piny RX i TX, to wykorzystaj je na interfejs UART/USART - to nie gryzie 🙂


  9. Już chyba wiem gdzie problem. Spiąłem tak, silnik stoi. Wypinałem podstawkę (miałem wlutowaną podstawkę, podstawkę, a w niej procek), silnik ruszył i stanął. Wpiąłem sam procek w podstawkę, ruszył, pochodził z 10s, stanął. Rzuciłem płytką z 5cm, znowu ruszył. Użyłem taniego PCB, za cholerę ni chciało lutować i musiały powstać zimne luty.

    Za bardzo nie rozumiem opisu ale udało się w końcu uruchomić silnik, tak aby działał jak chcesz? (w tym przypadku 5 sec - kręci, 5 sec - stoi).


  10. 1. Narysuj ten schemat po Bożemu (w programie Eagle...), przynajmniej się czegoś nauczysz, a nam Forumowiczom będzie się lepiej czytało takie schematy.

    2. Zrób zdjęcie i wrzuć je na Forbota (nie na inne strony).

    3. Napisz jeszcze bardziej prostszy program do włączenia silnika w jedną stronę (obojętnie którą), np. na 2 sekundy i 2 sekundy przerwy (silnik się nie kręci).

    Po tym jak to wykonasz zobaczymy co się da zrobić.

×
×
  • Utwórz nowe...