Skocz do zawartości

Torkness

Użytkownicy
  • Zawartość

    6
  • Rejestracja

  • Ostatnio

Reputacja

0 Neutralna

O Torkness

  • Ranga
    2/10

Informacje

  • Płeć
    Mężczyzna
  1. Witam, od kilku dni korzystając z różnych poradników staram się uzyskać możliwość korzystania z Raspberry Pi z dowolnego miejsca. Póki co to się nie udało a na dodatek powstało kilka wątpliwości odnośnie bezpieczeństwa. Niektóre poradniki z których korzystałem: http://malinowepi.pl/post/43316048520/raspberry-pi-i-zmienne-ip-ddns http://raspberrypi.stackexchange.com/questions/6757/how-to-use-ssh-out-of-home-network http://computers.tutsplus.com/tutorials/take-control-of-your-raspberry-pi-using-your-mac-pc-ipad-or-phone--mac-54603 Chciałbym się upewnić czy dobrze zrozumiałem zasadę
  2. Witajcie, mam do skomunikowania z atmegą 328p moduł GSM (Fibocom G510). Problem polega na "nieregularnych" odpowiedziach modułu. Nie mam pomysłu jak określać w którym momencie ustawiać flagę, informującą że rozkaz jest gotowy do przesłania. Opierając się na "bluebooku" kombinowałem ze zliczaniem LF i/lub CR ale czasem w komendzie zwrotnej dostaję 2, 3 a czasem nawet 4 razu te znaki. Długość komend/ilość odebranych znaków też nie wchodzi w grę bo ta waha się między 8 a 75. Zastanawiam się nad jakąś formą czasowego wyzwalania flagi (np 400ms od pierwszego znaku). Nie zależy mi na bardzo szybkiej
  3. Cześć, Podczas odczytywania string'a przez uart (wykorzystuje przerwania) mam spory problem z przepisaniem danych do zmiennej typu char[]. Tablica źródłowa i tablica docelowa są typu volitale. Przeszukałem kilka podobnych problemów na forum jednak nie znalazłem rozwiązania. Wolałbym nie rezygnować z oznaczenia volatile, ponieważ są to zmienne obsługiwane w przerwaniu UART. Otrzymuje 3 ostrzeżenia i 3 informacje: Warning 1 passing argument 1 of 'memcpy' discards 'volatile' qualifier from pointer target type [enabled by default] 70 3 Message 2 expected 'void *' but argument is o
  4. Witam, od 2 dni męczę się niemiłosiernie ze sterowaniem wyświetlacza. Próbuję go chociażby sprawdzić czy działa. Na początek próbuję wgrać program (wraz z bibliotekami) z wątku link lecz nic kompletnie mi nie wyświetla. Zdarzało się że wyświetlało mi pełne pola (pełne prostokąty). Wie ktoś co mogłem z tym schrzanić? LCD zasilałem początkowo 5,14V a teraz zasilam 4,39V ale po zmianie nie było poprawy. Wrzucę swój projekt z LPCXpresso. Wielkie dzięki za pomoc [ Dodano: 09-07-2013, 13:13 ] dodam że przykładając diodę do wyjść E, RS, DB4-DB7 jest sygnał (miernik ma za wolne odświeżanie), choć
  5. dokładnie nim się teraz zajmuję na majówkę przygotowałem sobie wszystkie części, niestety programator odbieram dopiero po.
  6. Witam, jest to moja pierwsza konstrukcja która była bardzo mocno oparta na poradniku z tego forum. Mimo ze elektronika nie była "zaprojektowana" przeze mnie sadze ze budowa tego robota dała mi trochę wiedzy a co najważniejsze bakcyla Pozdrawiam wszystkich robotyków )
×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.