Skocz do zawartości

Sok

Użytkownicy
  • Zawartość

    4
  • Rejestracja

  • Ostatnio

Reputacja

0 Neutralna

O Sok

  • Ranga
    1/10

Informacje

  • Płeć
    Mężczyzna
  1. Hej, mam pytanie z serii "nie bangla" Posługuję się płytką z F411RE, dostosowałem przykład do niej zdaje się, i nadal nie działa. Oto kod: int main(void) { GPIO_InitTypeDef gpio; // obiekt gpio z konfiguracja portow GPIO RCC_APB1PeriphClockCmd(RCC_AHB1Periph_GPIOA, ENABLE); // uruchomienie zegara modulu GPIO //problem solved - powinno byc RCC_AHB1PeriphClockCmd GPIO_StructInit(&gpio); // domyslna konfiguracja gpio.GPIO_Pin = GPIO_Pin_5; // konfigurujemy pin 5 gpio.GPIO_Mode = GPIO_Mode_OUT; // jako wyjscie gpio.GPIO_OType = GPIO_OType_PP; // push pull gpio.GPIO_Speed = GPIO_Fast_Speed; // nfs GPIO_Init(GPIOA, &gpio); // inicjalizacja modulu GPIOA GPIO_SetBits(GPIOA, GPIO_Pin_5); while(1);;; } dioda perfidnie nawet nie chce mrugnąć. Z góry dzięki za pomoc, i z dołu za kurs:)
  2. Też miałem problem ze sterownikami do tej właśnie karty wifi, i znalazłem też jego rozwiązanie:P Różne wersje sterownika dla różnych wersji systemu:) for 3.6.11+ #538, #541, #545, #551 and #557 use 8188eu-20130830.tar.gz for 3.6.11+ #524, #528 or #532 use 8188eu-20130815.tar.gz for 3.6.11+ #371 up to #520 use 8188eu-20130209.tar.gz źródło: http://www.raspberrypi.org/phpBB3/viewtopic.php?p=433048 żeby sprawdzić swoją wersję jest komenda: uname -a
  3. Styka. 2 omy to chyba niedużo, nie? Ok, głupie błędy są najlepsze- miałem niepołączoną masę układu i programatora. Dziękuję za pomoc, i zwracam uwagę potomnych na ten detal:P
  4. To może mi ktoś odpowie:P Witam wszystkich, i od razu na dzień dobry mam problem: Zrobiłem układ według instrukcji, pościągałem co trzeba, ale utknąłem na tym: vrdude -p atmega8 -P usb -c usbasp -U flash:w:led.hex avrdude: AVR device initialized and ready to accept instructions Reading | ################################################## | 100% 0.02s avrdude: Device signature = 0x1e9307 avrdude: NOTE: FLASH memory has been specified, an erase cycle will be performed To disable this feature, specify the -D option. avrdude: erasing chip avrdude: reading input file "led.hex" avrdude: input file led.hex auto detected as Intel Hex avrdude: writing flash (120 bytes): Writing | ################################################## | 100% 0.89s avrdude: 120 bytes of flash written avrdude: verifying flash memory against led.hex: avrdude: load data flash data from input file led.hex: avrdude: input file led.hex auto detected as Intel Hex avrdude: input file led.hex contains 120 bytes avrdude: reading on-chip flash data: Reading | ################################################## | 100% 0.67s avrdude: verifying ... avrdude: verification error, first mismatch at byte 0x0000 0x12 != 0x00 avrdude: verification error; content mismatch avrdude done. Thank you. make.exe: *** [program] Error 1 Gógiel niestety nie pomógł. Korzystam z usbaspa kupnego. Zworki raczej mam dobrze ustawione, jakakolwiek inna kombinacja powoduje wywalenie błędu jeszcze wcześniej niż teraz. Połączenia chyba też mam dobre, bo gdyby były złe, to nie zaszedł by tak daleko, no nie? Próbowałem wgrywać na dwie atmegi8, jedną L, drugą A-PU. Na żadnej nie działa. Połączenia sprawdziłem woltomierzem, zdaje się że napięcia są tam gdzie trzeba. Zatem zwracam się o pomoc, za którą z góry dziękuję __________ Komentarz dodany przez: Nawyk Używaj znaczników [ code][ /code]
×
×
  • Utwórz nowe...