Skocz do zawartości

coollerus

Users
  • Zawartość

    72
  • Rejestracja

  • Ostatnio

Wszystko napisane przez coollerus

  1. coollerus

    Problem z LCD

    LCD dziala bo sprawdzałem. Podpiąłem odwrotnie 11V. Wydaje mi się, że po tym odwrotnym podłączeniu 7805 stabilizuje nie na 5V,tylko na jakieś niższe... [ Dodano: 19 Sty 10 08:31 ] Znalazłem drugi 7805 wiec wymieniłem i teraz działa
  2. coollerus

    Problem z LCD

    Bardzo wam dziękuje. Wszystko jużdziała. Błędy które miałem to - nie dałem do r/w minusa i kondensatora 100nF przy zasilaniu lcd. A tak swoją drogą, to czy można spalić stabilizator (7805) odwrotnym podpięciem zasilania?
  3. coollerus

    Problem z LCD

    A widzisz, zapomniałem Zostawiłem miejsce i nie wlutowałem.. [ Dodano: 19 Sty 10 03:30 ] Przylutowałem, ale dalej co jakiś czas (rzadziej) coś sie pojawia...
  4. coollerus

    Problem z LCD

    OK. Dzięki. Wyświetlacz wyświetla, ale czasami przerywa i znowu sa te dziwnie znaczki, ale po chwili znowu wraca do normalnego stanu.
  5. coollerus

    Problem z LCD

    Dzięki, jutro spróbuje tak zrobic, a jeżeli chodzi o schemat to wzorowałem sie ta tym: http://wkretak.pl/wp-content/grafika/avrlcd/schem1.jpg
  6. coollerus

    Problem z LCD

    Jezeli chodzi o schemat to na szybko zrobiłem: a to program: $regfile = "m8def.dat" $crystal = 1000000 Config Lcd = 16 * 2 Config Lcdpin = Pin , Db4 = Portb.4 , Db5 = Portd.6 , Db6 = Portb.5 , Db7 = Portd.5 , E = Portd.7 , Rs = Portb.0 Config Lcdmode = Port Do Cls Lcd "WTF" End If Loop End
  7. A wiec tak. Kupiłem wyświetlacz LCD 16x2 przylutowałem do mojej plytki do LF i chciałem zaprogramowac, lecz zamiast tekstu pojawily sie jakies przelatujace znaczki i do tego tylko w 2 rzędzie... wie ktoś co zrobiłem źle?
  8. Z tym, że ja tą płytkę robiłem sam, nie ze schematu, bo coś nie mogłem sie porozumieć z eagle'em.
  9. Są tam jeszcze jakieś błędy? Bo chcę wytrawiać, a nie wiem czy wszystko jest ok.
  10. Tak, jest to eagle Dobra, dzieki. Poprawie.
  11. Czy mógłby mi ktoś sprawdzić płytkę di LF, którą wykonałem? Bedę bardzo wdzięczny. To jest schemat: Ja do niego dodałem jeszcze 2 czujniki, 2 kondensatory i dławik. A to PCB: Bardzo dziękuję. A, i nogi z uC do L293D trochę pomieszałem, żeby nie trzeba było tyle zwór. __________ Komentarz dodany przez: Nawyk Od takich pytań jest specjalny dział. Przeniosłem.
  12. Dobra, problem wydaje sie zazegnany (tylko 1 fototranzystor nie reaguje) Bardzo wam dziękuję
  13. Jak odłącze płytke z czujnikami to diody dalej świeca...
  14. Kupiłem fototranzystory i dalej nic... montowałem normalnie, odwrotnie i nic, to samo co wcześniej... diody ir działają, bo sprawdzałem aparatem. Wie ktoś o co chodzi?
  15. Spróbowałem wlutować odwrotnie, ale dalej nic... jutro kupie fototranzystory i zobaczymy.
  16. Zrobiłem tak jak mówisz i rzeczywiście się zapaliła. Spaliłem je podczas lutowania? Ale, żeby wszystkie?
  17. Teraz pojawił sie inny problem - wszystkie diody LED albo swiecą, albo gdy pokrecę potencometrem gasną. Niezależnie od tego, czy przykładam kartkę, czy nie...mogę sobie nią wymachywać, a i tak nic sobie z tego nie robią
  18. Bardzo miło z twojej strony. Jeśli chodzi o program to zauważyłem, ale nie jest to problemem. Co do tego faktycznego problemu, to narazie spróbuje sam się z nim uporać. Może żeczywiscie coś źle zlutowałem? Zobaczymy co z tego wyjdzie. Jak coś dalej nie bedzie chciało zadziałac to jutro (w sumie to dzisiaj) napiszę.
  19. Dobra, spróbuje tak zrobic.
  20. Oto mój problem. Otóż mam gdzieś połączone 5V i - i zupełnie nie wiem gdzie. Już 3 razy robiłem płytkęi ciągle to samo. Nie wiem czy to moja wina, czy może są złe płytki. Zupełnie nie wiem co o tym myśleć... Oto te pcb (kaytec'a): Potem, jeśli bedzie trzeba to wrzyce zdjecie płytki. Dzieki
  21. Dobra, wielkie dzięki. Z tym kondensatorem to już gdzieś czytałem. A może zamiast zostawiać puste, to dać tam ten kond? A, i jeszcze jedno. Czemu przy przełączniku jest ' bo nie rozumiem? Będzie czytał to?
  22. Czyli ma byc If... No tak, logiczne Dzięki
  23. To co w temacie. Bascom go nie kompiluje... A to jest program: $regfile = "attiny2313.dat" $crystal = 10000000 '$noramclear Config Portb = &B11111101 Portb = &B00000010 Config Portd = &B00000000 Portd = &B00000000 Config Timer1 = Pwm , Pwm = 8 , Compare A Pwm = Clear Down , Compare B Pwm = Clear Down , Prescale = 64 Sensor_1 Alias Pind.3 Sensor_2 Alias Pind.4 Sensor_3 Alias Pind.5 Sensor_4 Alias Pind.2 Do If Portb.6 = 1 Then Pind.3 = 0 And Pind.4 = 0 And Pind.5 = 0 And Pind.2 = 0 'przełącznik End If Loop Do If Sensor_1 = 1 And Sensor_2 = 1 And Sensor_3
×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.