Skocz do zawartości

Gielu

Użytkownicy
  • Zawartość

    17
  • Rejestracja

  • Ostatnio

Reputacja

0 Neutralna

O Gielu

  • Ranga
    2/10

Informacje

  • Płeć
    Mężczyzna
  • Lokalizacja
    Tychy
  1. Witam znowu. Płytka została już wytrawiona i polutowana. Schemat podobny do tego co podsyłałem do sprawdzenia jednak z poprawkami. Robot działa. Sprawdzam narazie poszczególne funkcje. Czujniki na podczerwień widzą, silniki po podłączeniu też się kręcą, pozostaje mi teraz napisać program. Jeszcze tylko kilka pytań. Czy czujniki sfh podłączyć poprzez ADC czy tylko jako input? Obawiam się że jak będzie bez pomiaru napięcia to będę miał fałszywe wskazania jak coś będzie widziane przez czujnik w większej odległości.
  2. Dziękuje bardzo, poradziłem sobie z problemem atmegi. Kiedy była ustawiona na zewnętrzny kwarc nie chciała działać zasilana z USB, ale kiedy podłączyłem zasilacz laboratoryjny udało mi się zaprogramować bez problemu. Kiedy jest włączony wewnętrzny kwarc nie ma problemów z zasilaniem z USB. Zrobiłem w końcu płytkę. Jak skończę lutować i zadziała to się pochwale na forum.
  3. Panowie, pytanie z trochę innej beczki. Mam Atmege8535, zmieniłem ustawienia fusebitów na zewnętrzny kwarc 8-16 MHz. Mam podłączony kwarc 8MHz, i nic nie reaguje, programator nie widzi uC. Próbowałem też na 12MHz. Co mogę zrobić? Edit. Gdzie można dostać tanio tarcze do cięcia do multiszlifierki? Nie chce kupować całego zestawu końcówek żeby mieć parę tarczek
  4. Tak, na przewodach które będą przylutowane do punktów VCC i GND
  5. To akurat nie lf to mam dużo pinów adc wolnych. Jak poprawie znowu płytkę to pokażę na forum. Układ resetu jest dobry? Kurcze tyle błędów narobić w prostej konstrukcji
  6. Jak właśnie ma się sprawa z ADC atmegi? lepiej CNY dać przez komparator czy bezpośrednio do ADC? Czujniki które dałem to nie są TSOP tylko SFH, w bibliotece zmieniłem tylko kolejność nóżek od obudowy. Czujniki te nie będą korzystać z ADC bo po co jak dają tylko stan niski i wysoki (port będzie wykorzystany jako i/o, nie ADC) CNY są w lustrzanym odbiciu, ale dziękuje za przypomnienie. Dobra teraz jak będę miał czas to przerobię jeszcze raz tą płytkę. Dodam rezystory na bazach, do tego zmienię timery od sterowania mostkiem. Z wykonaniem całej płytki w smd jest problem bo musiałbym kupić znowu dużo części, niech jest narazie przejściowo, to pierwszy robot do testów i nauki. Następny będzie bardziej na poważnie ;] Wartości rezystorów na schemacie są błędne, zapomniałem pozmieniać
  7. Zapomnialem pozamieniac wartosci rezystorow od ledow, czy rx i tx moge wykotzustac jako zwykle i/o? Myslalem zeby wszystkie diody ustawic tak zeby sie wzajemnie czujniki nie zaklocaly. (Przepraszam za pisownie pisze z telefonu) Timer to nie bedzie problem zeby zamienic, i dodac rezystory na bazach tranzystorow. Bedzie to jakos funkcjonowac?
  8. Witam znowu, oto nowsza wersja płytki, zmieniony mostek, dodane diody, switche, reset, rezystory przy diodach i parę innych poprawek.
  9. Kolega Lux mnie przekonał, jutro idę na zakupy po nowy mostek, te pójdą do szafy, wykorzysta się w innym projekcie ;].
  10. nanab wybacz zapomniałem napisać, chodzi o HP moje niedopatrzenie;)
  11. Jakie diody użyć do zabezpieczenia l298n? Jakieś BATy? Czy lepiej podłączyć CNY poprzez komparatory czy do portu ADC?
  12. Dobra, czyli mostki do wymiany, NE do wywalenia, stabilizator parametryczny też, dołożyć przyciski, rezystory, parę diod kolorowych do sygnalizacji pracy robota i powinno być git? ;]
  13. ok, dzięki panowie, poeksperymentuje trochę. W tej płytce dałem akurat te mostki bo takie mam na stanie u siebie, wszystkie części użyłem bo poprostu leża pod ręką. No nic widzę że muszę zacząć od początku edit: czytałem tamten artykuł, poczytałem również inne . Widziałem właśnie że dużo osób sobie chwali sharpy, jednak tak na upartego to dokładność tych czujników sfh jak na moje warunki jest "wystarczająca". Wiadomo poprostu czy coś jest koło robota czy nie. Jak sobie odłożę trochę więcej pieniędzy to je zakupie, narazie wykorzystam te;]. Jeszcze pytanie dotyczące tych mostków które posiadam, nie dadzą rady z pololu? w nocie jest napisane że dają ciągle 600mA na kanał czyli teoretycznie mogę z niego pobrać 1,2A. Czy to nie wystarczy? Da się jakoś zabezpieczyć silnik przed za dużym napięciem? Gdyby coś było nie tak PWM poszedłby 100% i poszło pełne napięcie na silnik to moge go uszkodzić.
  14. No i tego właśnie potrzebowałem, widzę że jeszcze kupa roboty czeka. Może lepiej zrobić mostek od podstaw na mosfetach? Silniki to właśnie Pololu 30:1. W jaki sposób ograniczyć napięcie dla silników? pakiet ma 11,1V. O masie pamiętałem, nie rozlałem jej żeby nie zaciemniać schematu. To początki dopiero pierwszy robot a nie chce się uczyć na swoich błędach i próbuje je uniknąć. Czujiki chciałem dać SFH, mam ich dość sporo a z funduszami na sharpy krucho.
  15. Po lewej stronie jest 7805 od logiki, odbiorniki działają bo mam poskładane na pająka, wystarczy sama nośna. Silników nie mogę zasilić bezpośrednio. Pololu nie mogą mieć więcej niż 9V a bateria ma 11,1V. Mostki mają obciążalność 600mA na kanał a tam są po 2 na silnik.
×
×
  • Utwórz nowe...