Skocz do zawartości

karol2607

Użytkownicy
  • Zawartość

    16
  • Rejestracja

  • Ostatnio

Reputacja

0 Neutralna

O karol2607

  • Ranga
    2/10

Informacje

  • Płeć
    Mężczyzna
  1. No nieźle... zapowiada się kolejny wciągający, forbotowy kurs. W prawdzie mam już płytkę STM'a, aczkolwiek jeszcze nie miałem czasu do niej zajrzeć, a teraz nadarzyła się idealna okazja, żeby zgłębić temat i dowiedzieć się kilku (czyt. bardzo wielu) ciekawych informacji. Czekam na kolejne części!
  2. Jestem pod niesamowitym wrażeniem ile udało Ci się przez ten 1 rok zrobić! Czytam Forbot'a w miarę od początku i aż nie dowierzałem jak dynamicznie się rozwijał! Czy ta strona to jedyne czym się zajmujesz, czy tez prowadzisz jakieś inne projekty? Mam na myśli czy coś aktualnie konstruujesz itp.? Czy masz może jakieś "podpowiedzi", albowiem również prowadzę tego typu bloga (mechatrobot.pl), oczywiście o znacznie niższej popularności. Może mógłbyś doradzić coś na szybko Pozdrawiam
  3. karol2607

    Arduino uno - brak kontaktu z platformą...

    No tak zapomniałem dodać (sorry): W Atmedze przez przypadek miałem wgranego blink'a. ...i w Arduino i w osobnym układzie, który na szybko stworzyłem, dioda na pinie 13 mruga - czyli Atmega wykonuje program poprawnie. Arduino jest oryginalne... mam też nieoryginalne i na nim również dioda 13 mruga i również nie mam z nim kontaktu. :/ Wcześniej działało, tak więc musiałem coś zrobić "nie tak" - pytanie co to może być? Jakie warunki muszą być spełnione żeby móc poprawnie komunikować się z Arduino? Klon jest idealną "podróbą" Arduino, jedyne czy się różni to brakiem znaczka Aktualizacja: Doszedłem do tego: Obydwie Atmegi są sprawne i mają wgrany bootloader (poprawnie wykonują blink'a, który był przez przypadek wgrany a podczas resetowania mruga LED13) Klon arduino poprawnie komunikuje się z komputerem (wysyłam "znaczek" w monitorze portu szer. i jest sygnał diody RX) aczkolwiek nadal nie mogę wgrać programu. Pojawia mi się taki błąd: Szkic używa 1 006 bajtów z (3%) pamięci programu. Maksimum to 32 256 bajtów. Globalne zmienne używają 15 bajtów z (0%) dynamicznej pamięci, pozostawiając 2 033 bajtów dla lokalnych zmiennch. Maksimum to 2 048 bajtów. avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xd1 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xd1 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xd1 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xd1 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xd1 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xd1 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xd1 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xd1 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xd1 avrdude: stk500_recv(): programmer is not responding avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xd1 Problem z wgrywaniem na płyte. Sprawdź http://www.arduino.cc/en/Guide/Troubleshooting#upload w poszukiwaniu sugestii. Jak rozumiem programator nie dopowiada - tylko w takim razie c jest nie tak i jak to naprawić? Oczywiście nie ma osobnego programatora tylko korzystam z bootloadera w Atmedze Co do oryginału to po podłączeniu go do PC i włączeniu konsoli zaczyna wysyłać jakiś "dziwny" ciąg bezsensownych znaków (tak, mam nastawione na 9600) Co się dzieje?? [ Dodano: 16-05-2015, 17:46 ] Ok - problem rozwiązany - nie wiem jak to naprawiłem ale ważne, że działa Przepraszam za zamieszanie
  4. Witam, w ostatnich dniach borykam się z pewnym problemem. Mianowicie: Nie jestem w stanie wgrać programu do Arduino :/ Nie mam również kontaktu (poprzez monitor portu szeregowego) z płytką = gdy wysyłam przez program jakiś tekst ani RX ani TX nie "mrugają". W czym może leżeć problem? Gdy program kończy kompilowanie i rozpoczyna wgrywanie programu do Atmegi pojawia się błąd mówiący, że nie można wgrać programu na platformę. Mam zainstalowane najnowsze Arduino IDE, mam zainstalowane sterowniki - system wykrywa Arduino, Arduino IDE również wykrywa platformę, Atmega jest sprawna.... w takim razie w czym może leżeć problem? Błąd z oprogramowaniem w komputerze? Jakieś "problemy" samego Arduino? Proszę o pomoc! Z góry dziękuję za wszystkie odpowiedzi, podpowiedzi i porady Pozdrawiam, Karol
  5. Witajcie! Mam na sprzedaż bon o wartości 200zł do firmy Faldruk na wykonanie obwodów drukowanych. Ogólnie mówiąc wygrałem go na zawodach robotycznych w Poznaniu - Cyberbot, jednak nie jest mi potrzebny. Proponuję około 3/4 (-30%) ceny czyli 140zł. Zapraszam do "składania ofert" oraz kontaktu. Pozdrawiam, Karol PS Jestem otwarty na wszelkie negocjacje!
  6. Wiem, wiem - na filmiku nie pokazałem wykresu z ale nie chciałem już "mieszać". Ogólnie chodzi o to, że z pomocą aplikacji, którą opisałem w ostatnim kom. (IP webcam) zbieram dane z wbudowanych w smartphon'a sensorów (np. Sony Xperia M: czujnik dźwięku(mikrofon), czujnik zbliżeniowy(czujnik IR z przodu telefonu, czujnik przechylenia itd.) - a większość tych danych dotyczy również robota - jeżeli telefon jest przechylony o robot też Potem mogę odczytywać dane w postaci wykresów na komputerze/telefonie. Umieszczam screenshoot'a z takiego wykresu (jak to wygląda): PS oczywiście mogę włączać i wyłączać poszczególne sensory. Pozdrawiam
  7. vox2003, Dzięki! ...Diody? Rzeczywiście Postaram się to jak najszybciej poprawić i dzięki za podpowiedź z diodami przy mostku. max1205max, Tak, tak - IP web cam Demooon, ...Co do transmisji: Przesyłanie przez wi-fi z pomocą programu IP Web cam (tak jak już wspomniał kolega max1205). Jeśli chodzi o parametry wideo to jakość/prędkość jest zależna głównie od prędkości internetu i możliwości komputera i telefonu. U mnie wygląda to tak: *Rozdzielczość video: 640x480 *Jakość przekazu ustawiona na: 80% *fps: 30 (kwestia kamery w telefonie) *Prędkość internetu: ~100 Mb/s Przy czym w takiej konfiguracji obraz się zacina - tak jak to widać na filmiku. Myślę, że przy ~50% jakości pracowałoby w miarę płynnie shaslyk135, W tym wypadku: Arduino i biblioteki
  8. Oto i moja konstrukcja: https://www.forbot.pl/forum/topics7/wielozadaniowy-orion-250-wielozadaniowy-robot-mobilny-vt11157.htm#95581 Robot dla Nasa to to nie jest ale jak na 15-latka to nie jest chyba źle Orion 250 to wielozadaniowy robot (pojazd) mobilny, który może być sterowany z dowolnego urządzenia z bluetooth'em. Jest on wyposażony w: wyświetlacz LCD, wysięgnik magnetyczny, mostek H L298N, moduł bluetooth HC-05 oraz podstawowy element jakim jest tu Arduino uno. Napisałem również do niego dedykowaną aplikację na smartphony i tablety z systemem Android. Ważna zaleta: cena wykonania = 150/200zł
  9. Witam serdecznie forumowiczów! Nazywam się Karol i mam 15 lat. Interesuję się robotyką i elektroniką od września zeszłego roku, wcześniej zajmowałem się mocno amatorsko informatyką (strony WWW, programy, cmd itp.). Właśnie skończyłem prace nad moim pierwszym poważniejszym projektem jakim jest Orion 250 - prosty robot mobilny z wieloma funkcjami i zastosowaniami + aplikacja mobilna dedykowana właśnie dla niego. Konstrukcja i zasilanie(#1); elektronika(#2): #1 Robot wykonany jest głównie z wyciętej plexy i pianki modelarskiej. Każde koło ma swój osobny 5V silnik DC z przekładnią (jak się nie mylę 1:120). Robot jest również wyposażony w prosty wysięgnik magnetyczny na serwie 9g. Aktualnie zasilam go z najprostszych "paluszków" [=6x AA], co daje w granicach 9-12V. W najbliższym czasie, zamierzam kupić zwykły pakiet w miarę wydajnych li-pol'i (3S). #2 Chciałem zastosować jakiś uC z "własnej kolekcji" ale stwierdziłem, że nie będę się "rzucał na głęboką wodę" i wybrałem po prostu... Arduino uno. Za sterowanie silnikami odpowiada moduł mostka H: L298N, który bez problemu sobie ze wszystkim radzi. Robot wyposażony jest również w ultradźwiękowy czujnik odległości hc-sr04 jednak na razie go nie podłączyłem. Komunikacja z telefonem odbywa się za pośrednictwem bluetooth'a, z racji, że robot miał być raczej tani, zamiast wyrafinowanych BTM-222 itd. zakupiłem na allegro moduł HC-05 za 20zł który przesyła dane do Atmegi za pośrednictwem UART'a. Dodatkowo przygotowałem płytkę z wyświetlaczem LCD (z Noki) 3110 z własnym zasilaniem (li-pol 1S). Podłączenie modułu do Arduino jest ułatwione dzięki wyjściu kanda, które na nim umieściłem. #3 Inne: po dołączeniu do pojazdu swojego smartphon'a, powstaje możliwość odbioru aktualnego obrazu z kamer, a także wykresów z sensorów (czujnik ruchu, czujnik przechylenia, czujnik dźwięku itd.) z dowolnego miejsca na Ziemi - tym razem z pomocą wi-fi. Aplikacja: Postanowiłem, również, napisać dedykowaną aplikację dla robota na tablety i smartphony z Androidem. Wydaje mi się, że program jest w miarę prosty/wygodny, aczkolwiek to jest moja opinia. Dla zainteresowanych umieszczam załącznik (folder), w którym znajdziecie schemat prototypu, zdjęcia konstrukcji a także aplikacja, którą możecie przetestować (dodaję również "notę", w której wyjaśnione jest starowanie a także dokładana specyfikacja komunikacji i komendy, które są wysyłane). Co wchodzi w skład projektu? Co musiałem zrobić?: -opracować i zaprogramować aplikację - Robot Controler bt, dla urządzeń z Androidem; -zaprogramować płytę główną, w tym wypadku, Arduino; -przygotować konstrukcję mechaniczną robota a także zaprojektowanie i wykonanie strony elektronicznej; Zalety konstrukcji: √ tani (jak na robotykę) koszt wykonania = w granicach 200zł [ja oczywiście wydałem o wiele więcej] √ dedykowana aplikacja - to znacznie ułatwia sterowanie √ możliwość sterowania z dowolnego urządzenia z bluetooth (komputer-za pośrednictwem monitora portu szeregowego, tablet, smartphone) √ odbiór aktualnego obrazu, a także wykresów z sensorów (czujnik ruchu, czujnik przechylenia, czujnik dźwięku itd.) z dowolnego miejsca na Ziemi Osiągnięcia: II miejsce na Ogólnopolskim Festiwalu Robotyki Cyberbot (w Poznaniu) Schemat (prototypu) robota: Oto krótki film z działania robota: Podziękowania dla: Wszystkich osób, które wspomogły mój projekt na Polak Potrafi. W szczególności: firmie Hybrid Lizard a także Pani Małgorzacie Wyszyńskiej. Serdecznie dziękuję również firmie, która mnie wspiera: Roboty i Spółka Dla zaintersowanych: w załączniku umieszczam; kilka zdjęć, schemat, aplikację oraz kod QR a także notę informacyjną. Zapraszam do komentarzy. Prosiłbym aby komentując: mieć na uwadze, że jest to moja pierwsza konstrukcja i mam 15 lat. Co zrobiłem źle/bez sensu? Co Wy (o wiele bardziej doświadczeni) byście poprawili w Orioni'e? Pozdrawiam, Karol www.mechatrobot.pl - mój workblog ## Orion 250 - Załącznik
  10. karol2607

    Cyberbot 2015 - Poznań, 18.04.2015

    Ok, dzięki za informację Spróbuje się pojawić. Mam jeszcze takie pytanie: będzie jakaś prezentacja robota, w auli przed publicznością (chodzi o kategorię Freestyle)? Pozdrawiam
  11. karol2607

    Cyberbot 2015 - Poznań, 18.04.2015

    A moglibyście podać jakieś przybliżone godziny rozpoczęcia - zakończenia ... bo o 18:00 jest chrzest mojego brata, a chętnie bym się pojawił i wystartował
  12. Super artykuł! Myślałem że w miarę "ogarniam" elektronikę ale większość zagadnień, które były dla mnie niejasne/nieznane wyjaśniasz w artykule. Czekam na kolejne części
  13. Proponuję umieścić poniżej ankiety aktualne wyniki. Bo jak już zagłosowałem i wyszedłem ze strony to teraz musiałbym 2. raz zagłosować żeby zobaczyć aktualne wyniki. Pozdrawiam
  14. Ok, dzięki Treker! Właśnie o to mi chodziło.
  15. Dzięki za informacje. A widziałeś może zawody w kategorii freestyle - ciekawi mnie w jaki sposób były prezentowane roboty (np. w centrum wykładowym przed widownią)? Pozdrawiam
×