Skocz do zawartości

Tom277

Użytkownicy
  • Zawartość

    27
  • Rejestracja

  • Ostatnio

Reputacja

11 Dobra

O Tom277

  • Ranga
    3/10

Informacje

  • Płeć
    Mężczyzna

Ostatnio na profilu byli

Blok z ostatnio odwiedzającymi jest wyłączony i nie jest wyświetlany innym użytkownikom.

  1. Tom277

    Driver LED, jakieś propozycje?

    Jakiś czas temu kupiłem takie źródła po pierwszym zachwycie, ale ostatecznie po przetestowaniu emocje opadły. Może w jakimś specyficznym zastosowaniu ma to sens, ale w moim akurat się słabo sprawdziło. Zrobiłem płytkę jak na powyższym schemacie, czyli dziesięć kolumn po 4 czerwone LED-y. Każda kolumna posiadał swoje źródło prądowe 30mA, wygląda jak mała dioda SMD SS14L. Niestety wszystko to razem tak się grzało, że miałem poważne obawy o trwałość diod. Diody swoje tez dodały do tego piecyka. Tak jak napisałem wcześniej, może w jakimś pojedynczym zastosowaniu ok, ale w tym przypadku akurat
  2. Tom277

    Driver LED, jakieś propozycje?

    Ok. Na razie jeszcze nie mam nic prócz koncepcji. Odezwę się. Dzięki
  3. Tom277

    Driver LED, jakieś propozycje?

    a no tak, całkiem zapomniałem, że to jest tak zrobione, choć nie do końca o to mi chodziło. Nie wiem, czy dobrze się zrozumieliśmy, ja maiłem na myśli zbudowanie źródła prądowego o np. wydajności 300mA i zasilanie z tego 10 gałęzi/kolumn (po 4szt w szeregu) diod led, gdzie każda kolumna teoretycznie powinna pobierać 30mA. Rezystor chciałem wpiąć w szereg Teraz tak na serio, to z powyższym układem się nie spotkałem, żeby bardzo mały rezystor kompensował różnice prądu w takim połączeniu diod. Jeśli już gdzieś w nocie aplikacyjnej połączone są tak lub podobnie diody to bez
  4. Tom277

    Driver LED, jakieś propozycje?

    A jeszcze jedno pytanie bo w sumie to nikt się do tego nie odniósł. Co sądzić o takim podłączeniu diod? Spotykam w notach aplikacyjnych taki sposób, ale też często trafiam na informację, że nie powinno się tak łączyć diod (równolegle) ze względu na rozbieżność charakterystyk/parametrów. Nigdzie natomiast nie spotkałem się z przykładem włączania niewielkich rezystorów w każda gałąź, tak jak to się robi np przy łączeniu równoległym tranzystorów. W powyższym przykładzie mam na myśli diody "normalne" z prądem ok 20 - 50mA, które połączone w taki panel pobrałby łącznie ok 500 - 800mA
  5. Tom277

    Driver LED, jakieś propozycje?

    szczygiel256 dziękuję układ zaproponowany z TME jest całkiem ciekawy i co najważniejsze jest dostępny (masakra, co się dzieję z dostępnością). Właśnie chyba największy mój problem z tym, że możliwości jest sporo i jest bardzo duży wybór z którego nie potrafiłem odfiltrować sobie tego co byłoby dla mnie najlepsze. Dziękuję koledzy za rzeczową pomoc. Pozdrawiam edit przeglądam notę układu jaki zaproponowałeś i powiem więcej, on jest bardzo ciekawy , cena super, możliwość podpięcia zewnętrznego tranzystora oj...
  6. Tom277

    Driver LED, jakieś propozycje?

    _LM_ dziękuję, ciekawe artykuły, nie wiem czy rozwiążą mój problem, ale na pewno bardzo pomocna podpowiedź. Wczoraj to właśnie przeglądałem fakt, że dużo z tych układów to liniowe regulatory. Gieneq w sumie to gdzieś wcześniej przeszła mi taka myśl żeby diody zasilać pwm-em sterowanym z uP i kontrolować prąd ADC, ale jakoś tak umknęło to mojej uwadze w trakcie rozważań. Dzięki za przypomnienie.
  7. Przyszło mi zbudować dla siebie oświetlenie sygnalizacyjne z kilkunastu/kilkudziesięciu czerwonych LED-ów. Zasilanie będzie to 12V z akumulatora i alternatora na platformie maszyny, diody SMD po 20mA na diodę. Nie chcę robić drivera liniowego ponieważ "szkoda" mi energii gdy lamka pracuje na akumulatorze, nie chcę też mieć grzałki gdy napięcie zasilania wzrośnie do ponad 14V przy pracy alternatora. Z definicji nie lubię chińskich modułów, bo one są świetne, ale tylko w opisie z Aliexpress a w rzeczywistości jest różnie. Chciałbym też żeby płytka była dopasowana do obudowy lampki więc goto
  8. Nie do końca. Zrobię tak, że zastosuje MOSFET-a szeregowo z przekaźnikiem, czyli najpierw włączę przekaźnik a następnie MOSFET-a. Tak wiem, przekombinowane, ale nie wymyśliłem na szybko lepszego rozwiązania. Niestety nie, mimo stosowania przekaźników dobrej jakości, dobranych nadmiarowo, sklejanie styków w niektórych zastosowaniach jest moją zmorą. Spróbuj sterować silnikami większej mocy z przekaźnika, lub tak jak w temacie włączać baterię kondensatorów. Myślę, że w takich przypadkach poleganie na przekaźnikach nie jest dobrym pomysłem gdy przekaźnik ma pracować niezawodnie prz
  9. Chodzi o to, że muszę odciąć zasilanie mostków fizycznie przekaźnikiem. Nie mogę zrobić np odcięcia mosfet-em ze względu na ryzyko uszkodzenia(przebicia, zwarcia) mosfet-a. Jednak odcięcie zasilania przez przekaźnik daje największą gwarancję bezpieczeństwa. Twoja podpowiedź z dwoma przekaźnikami jest już trochę nie w czasie bo nie ma za bardzo miejsca na płytce. Trochę to dziwne rozwiązanie, ale w sumie czemu nie, tylko jak wspomniałem już nie zmieszczę kolejnego przekaźnika. W międzyczasie zastanawiałem się nad dodaniem mosfeta, ale szeregowo, będzie się włączał po przekaźniku jeszc
  10. Mam taki mały problem, kolejny raz borykam się z udarem prądowym, jaki występuje w momencie włączenia urządzenia pod zasilanie. W układzie mam kilka kondensatorów elektrolitycznych po 2szt 470uF na każdy kanał drivera silnika w sumie 3 kanały, co daje łączną pojemność ok 3000uF (jeszcze kilka małych po 22uF w obwodzie procesora). Układ mam tak rozwiązany, że obwód mocy włączany jest przekaźnikiem. Mój kłopot to iskrzenie styków przekaźnika w momencie zadziałania przekaźnika. Normalne jest, że kondensatory muszą się naładować przy pojemności 3000uF iskrzenie jest dość znaczące i prędzej cz
  11. Tom277

    Zasialnie Atmegi 3V3

    Kurcze nic wczoraj nie dotknąłem, awaria samochodu, która musiałem się zająć. Tak jestem pewien, ponieważ mam wpięty wyświetlacz, LED-a który sobie mrugał, na wyświetlaczu zrobiłem też liczbę która po prostu zwiększała swoja wartość tak, żeby zobaczyć czy wyświetlacz się odświeża. Po włączeniu zasilania wyświetlacz się inicjalizował, ładował się obraz tła i tyle. Potem już nic więcej ani zmienna się nie inkrementowała, led nie mrugał. Dopiero reset powodował ruszenie programu. Przepraszam, że nic nie mam do dodania nowego. Ty się angażujesz a ja nic nie sprawdziłem, jak wyżej napisałe
  12. Tom277

    Zasialnie Atmegi 3V3

    nie, nie dałem. Konwerter USB-UART dołączany jest poza układem, jak wspomniałem jest mi potrzebny tylko do podglądania (debugowania) w czasie uruchamiania. Procesor to AVR więc bez problemu obsługuje 5V. Uważasz, że dzielnik jest potrzebny? A dodam jeszcze, że wykorzystuję tylko linie Tx z procesora czyli tylko wysyłam do PC-ta. Pytam bo jesteś doświadczonym konstruktorem, więc może źle robiłem dotychczas. Co innego gdybym "prowadził" pełną komunikację a procesor miał tylko na 3V3, więc rozumiem, że mogę uszkodzić Rx w procesorze bo konwerter poda za wysokie napięcie, ale w moim przypad
  13. Tom277

    Zasialnie Atmegi 3V3

    Hmmm.... a to jest dobre pytanie Muszę sprawdzić, niestety wczoraj, jak już nic więcej nie zrobiłem z braku czasu, wrócę do domu sprawdzę co ja tam mam w tej swojej przejściówce, jakaś tak stara, kiedyś sam ja zrobiłem myślę, że jakiś FT232. Myślisz, że tu może być przyczyna? Co miałby zmienić reset procesora a włączenie procesora? Wczoraj jedynie ustaliłem, że jak używam komunikacji UART to program nie startuje sam po włączeniu zasilania, dopiero reset z mkAVRCalculator uruchamia program. No, ale zaraz, chip w przejściówce zasilany jest z USB z komputera więc to jednak chyba nie t
  14. Tom277

    Zasialnie Atmegi 3V3

    Tak oczywiście, że mam kondensatory. Dla każdego pinu Vcc po jednym 100nF + 10uF. Mam włączony Brown-out detection level at Vcc=2.7V BOODLEVEL=101. Przy okazji, nie korzystałem z tego wcześniej, więc dopytam, czy to nie jest za wysokie napięcie ie powinno być minimalne 1.8V przy tym zasilaniu? Ale powyższe nic nie zmienia, nadal jest problem. Zacząłem więc sprawdzać program, najpierw wyremowałem zostawiając jedynie obsługę LCD, było ok. Po kolei odkomentowywałem kolejne sekcje programu, aż dotarłem do samego końca i okazało się, że obsługa UART-a koliduje z programem. Bez wysył
  15. Tom277

    Zasialnie Atmegi 3V3

    Na tym etapie zasilam wszystko z zasilacza przez stabilizator (popularna płytka zasilająca do stykówki), wszystko jest na stykówce jeszcze, więc spadek napięcia z niewydolnej baterii odpada. Mierzyłem faktyczne napięcie na nóżkach procesora, jest ok 3.2V z diodą o której wspominałem i 3.29V bez diody (zwarta). Wyświetlacz LCD to JLX12864G z kontrolerem UC1701x, według dokumentacji VDD range (Typ.): 1.8V ~ 3.3V i VDD2/3 range(Typ.): 2.5V ~ 3.3V. Reszta też na zakres 1.95V to 3.6V (sprawdzone w dokumentacji). No kurcze nie wiem. Najpierw myślałem, że to problem stykówki, ale problem jest z
×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.