Skocz do zawartości

dawid75_75

Użytkownicy
  • Zawartość

    21
  • Rejestracja

  • Ostatnio

Reputacja

0 Neutralna

O dawid75_75

  • Ranga
    2/10

Informacje

  • Płeć
    Mężczyzna
  • Moje zainteresowania:
    elektronika, elektrotechnika, robotyka
  1. Szanowni Forumowicze, Zagłębiając się w temat znalazłem funkcję liczącą CRC w bibliotece na arduino do tego czujnika. Dowiedziałem się też, że jest biblioteka o nazwie crc16.h w katalogu util. Pierwotnie chciałem z niej korzystać, ale wymaga argumentów 8-bitowych, a z tego, co zrozumiałem z datasheet'a czujnika i patrząc na funkcję z biblioteki arduino muszę zlepić ze sobą dane pomiarowe z czujnika, czyli otrzymam 16-bitową liczbę. Postać funckji z crc16.h: static __inline__ uint8_t _crc_ibutton_update (uint8_t __crc, uint8_t __data) Funkcja z biblioteki arduino: #define SHIFTED_DIVISO
  2. Problem szpilek od silników rozwiązałem. W bardzo prosty sposób - odseparowałem silnik od reszty układu przetwornicą izolowaną DC/DC 5/5V B0505S-1W (200mA wydajności prądowej; docelowo połączę je sobie równolegle żeby udźwignąć dwa silniki, każdy ma ca. 200mA, nie więcej). Do wyjścia przetwornicy podłączę jeszcze stabilizator 3.3V żeby mieć szynę na wejścia logiczne mostka. A sygnały do mostka z procesora podłączę przez transoptory. Na razie sprawdziłem oscyloskopem jak wyglądają szyny zasilania po separacji silnika. Efekt - szyna 3V3 praktycznie nie ruszona, piękny, gładki przebieg napięcia.
  3. Tak się zacząłem zastanawiać czy pomogłoby rozdzielenie mas na cyfrową i analogową. Nie wiem czy to coś da bo i tak masy schodzą się na PCM. Jak to z tym jest? Oprócz tego zastanawiam się jeszcze nad tym czy warto jest połączyć rozdzielenie mas wraz z optoizolacją masy cyfrowej. Jak tu się sprawy mają?
  4. Wstawiłem tamten, bo nie miałem nic kolorowego, nie ściemniam. Teraz już mam. Wstawiam jeszcze raz poprzedni schemat, ale z uzupełnieniem o procesor. Wstawiam, bo chcę żeby były widoczne wszystkie kondensatory. Poniżej wstawiam schemat bez kondensatorów i wzmacniacza pomiarowego, zaznaczone zasilania i masy. Szyny na kolorowo, strzałki z prądem na kontrastowo do szyn. Odnośnie długości przewodów - mam przy każdym odcinku wstawić długość w cm? Od razu mogę powiedzieć, że: - połączenia między płytkami są wykonane przy użyciu przewodów stykowych żeński-żeński 10cm, - sygnały na mostek
  5. Wstawiam schemat układu wraz z połączeniami. Pominąłem jedynie atmegę na płytce stykowej, z atmegi wchodzą sygnały PWM na piny wtyku IDC, a do wtyku IDC wpięta jest taśma. Na razie ręcznie żeby łatwo nanosić poprawki w razie czego. Pominąłem też połączenia między logiką mostka a wtykiem IDC, gdyż zamazałbym rysunek dokumentnie. Połączenia logiki wychodzą na wtyk IDC, a do wtyku IDC wchodzi taśma 10 żyłowa z wtyczką na końcu. Stany niskie/wysokie logiki mostka biorę z szyn GND/3V3, podaje je przez kabelki do wtyczki z taśmą 10cio żyłową. Jedna sprawa, której zapomniałem z kolei dorysowa
  6. Sprawa wygląda tak, że to co dłubię teraz docelowo ma wylądować w mojej inżynierce i chcę to zrobić porządnie, a czasu mam do końca tego roku kalendarzowego (o ile w lato w sesji wszystko pójdzie zgodnie z planem). Rysunki oczywiście zrobię i wstawię, ale to najwcześniej w weekend. Odnośnie ICLa - faktem jest, że gorzej, że tego nie wiedziałem, nawet się nie bronię. Jednakże tutaj chyba tylko praktyka mogła mnie tego nauczyć Tak też się zastanawiam - czy ICL7660 działałby poprawnie jakbym mu dorzucił dławiki szeregowo do kondensatorów żeby mi tak prądu w szpilkach nie ciągnęło? Skąd t
  7. Pozrzucałem przebiegi bez kondensatorów w mostku - mogę nie zdążyć ich dziś dolutować bo mam kolokwium jutro. Schematy też dorzucę. PWM biorę z Atmegi8A; procesor zasilam z szyny 3V3. Przebiegi: 1) Szyna 3V3, pracują dwa silniki, pwm = 90% 1kHz; mierzone względem masy przed rezystorem pomiarowym: 2) Szyna 3V3, pracują dwa silniki, pwm = 90% 1kHz; mierzone względem masy za rezystorem pomiarowym (czyli tej masy, do której mam podłączone wszystkie odbiorniki): 3) Szyna 5V, pracują dwa silniki; pwm = 90% 1kHz; mierzone względem masy przed rezystorem pomiarowym: 4) Szyna 5V, pracują
  8. A właśnie, pojemności przy mostku, o tym zapomniałem. Powinienem dać szybkiego ceramika 47-100nF przy części cyfrowej i duży elektrolit przy części analogowej (zasilaniu silnika)?
  9. Wrócę do domu i zrobię zdjęcia pod wieczór A i zapomnialem powiedzieć i jeszcze jednej rzeczy - jak odlączyłem silniki od mostka, ale sam mostek zostawiłem i dałem na niego normalne sygnały sterujące wraz z PWMem to na szynach pojawily się regularne szpileczki, ale dość znaczne, wszystkie o jednakowej amplitudzie. Odłączając PWM od mostka problem znikał. Czy to zaklocenia wynikające z przełączeń tranzystorów?
  10. Rozumiem, czyli w moim przypadku nie ma chyba sensu. Powracając do tych szpilek - niepokoją mnie one o tyle, bo pojawiają się tylko jak włączę silnik dlatego myślałem, że to nie są akurat zakłócenia z otoczenia. Jeśli to szpilki z otoczenia to jak wyjaśnić to, że pojawiają się tylko jak włączę silnik? Jak silnik stoi to na szynach mam gładko.
  11. Aaa, teraz jasne. No i fakt, że nie bardzo chcę poczuć 10kV, 230V już mi wystarczy, dziękuję bardzo Tak się jeszcze zastanawiam czy ma sens optoizolacja między silnikiem a resztą układu?
  12. Ok, rozumiem Zrobiłem to o czym pisałeś z opornikiem 1k i oscyloskopem. Jednakże jak przyłożyłem palca do sondy to... nic się nie wydarzyło. Czysta masa na ekranie. Coś robię źle?
  13. Punkty 1.-3. i 5. rozumiem. Odnośnie 4. - chodzi o to (?): Jeśli tak - czy jest to też coś w rodzaju filtru RC? Jeszcze mam wątpliwości odnośnie tych pojemności i dławików - piszesz: czyli rozumiem, że chodzi o to: Jednakże na początku napisałeś: więc patrząc na to, zamieniłbym miejscami dławiki i kondensator. Ale jakbym miał wybierać to zostałbym przy tym, co narysowałem. Czy o to właśnie chodzi? Jeśli o pomiary chodzi - to fakt, jak przyłożę sondę do masy to dalej trochę "szumi" i czasami odnoszę wrażenie, że wielkość szpilek jest różna, w zależności od dnia... W ogóle Ri
  14. O ile wiem to zasilacz jest źródłem napięciowym, a nie prądowym, więc będzie starał utrzymać w Twoim układzie stałe napięcie, a nie stały prąd. Prąd, który popłynie zależy od oporu całkowitego układu, który zasilasz więc - tj. napisał kol. Treker - pobierze sobie tyle prądu ile chce, ale nie ma gwarancji co się wydarzy powyżej 3A
  15. Więc ok, dodam jeszcze dławiki do kondensatorów. Gwoli formalności - kolejność jest taka (?): kondensator -> dławik -> silnik ? Mam też inny problem - jak oglądam sobie przebieg wyjściowy z enkodera to i tak ma on potężne szpilki od silnika. Jak przepuszczę ten sygnał przez filtr RC to zbocza prostokąta łagodnieją - co jest oczywiste - ale szpilki przechodzą nietknięte. Jest jakaś możliwość żeby to odfiltrować przed podaniem na procesor? Tak się też zastanawiam czy jest sens stosować izolację optoelektryczną przy zasilaniu silników?
×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.