Skocz do zawartości
Komentator

Kurs Raspberry Pi - #7 - dostęp zdalny VNC, SCP, klucze RSA

Pomocna odpowiedź

fire45, niestety, na ten moment nie jestem w stanie powiedzieć skąd u Ciebie takie zachowanie. Sprawdziliśmy to u siebie na dwóch konfiguracjach + nikt inny nie zgłaszał takiego problemu. Musisz mieć u siebie gdzieś coś ustawione... pytanie tylko co 😉 Nie zmieniałeś niczego w ustawieniach klienta VNC?

Udostępnij ten post


Link to post
Share on other sites

@hatamarii Problem z ssh wynika prawdopodobnie z uprawnień - do katalogu .ssh, jak również do pliku authorized_keys powinien mieć dostęp wyłącznie użytkownik, na którego się logujesz (brak uprawnień rwx dla grupy i pozostałych użytkowników). Najłatwiej wyklikać przez winscp. Miałem identyczny problem i ustąpił po odpowiednim ustawieniu uprawnień.

Pozdr

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

@jajokajo, witam na forum 😉 Widzę, że to Twoje pierwsze kroki na Forbocie, oto najważniejsze informacje na start:

  • Chcesz przywitać się z innymi członkami naszej społeczności? Skorzystaj z tematu powitania użytkowników.
  • Opis najciekawszych funkcji, które ułatwiają korzystanie z forum znajdziesz w temacie instrukcja korzystania z forum - co warto wiedzieć?
  • Poszczególne posty możesz oceniać (pozytywnie i negatywnie) za pomocą reakcji - ikona serca w prawym dolnym rogu każdej wiadomości.

Dnia 2.12.2018 o 20:55, jajokajo napisał:

Problem z ssh wynika prawdopodobnie z uprawnień - do katalogu .ssh, jak również do pliku authorized_keys powinien mieć dostęp wyłącznie użytkownik, na którego się logujesz (brak uprawnień rwx dla grupy i pozostałych użytkowników). Najłatwiej wyklikać przez winscp.

Dziękuję za podzielenie się rozwiązaniem tego problemu - Twoja rada na pewno komuś się jeszcze przyda. Sprawdzę niedługo jeszcze raz ten fragment kursu, ale w momencie jego publikacji na 100% nie trzeba było zmieniać ręcznie takich uprawień. Jeśli ćwiczenia były wykonywane zgodnie z opisaną instrukcję to wszystko powinno od razu zadziałać bez dodatkowych, ręcznych ustawień. Albo coś się zmieniło, albo w Waszym przypadku problemy były spowodowane tym, że działaliście w jakiś inny sposób od tego opisanego w kursie.

Udostępnij ten post


Link to post
Share on other sites

Cześć!

Tytułem wstępu napiszę, że też jestem nowy na forum i dopiero co zaczynam bawić się Malinką. Linuxa znam średnio - moją ulubioną dystrybucją jest Ubuntu, choć zarządzałem też RedHatem, (Open)SUSE, Gentoo i FreeBSD.

Mam ten sam problem co kolega - mimo wgrania w odpowiednie miejsce klucza publicznego to nadal muszę podawać hasło. Sprawdziłem uprawnienia do pliku i katalogu .ssh i są właściwe (rwx --- ---). Sprawdziłem konfigurację ssh (/etc/ssh/sshd_config) ale tam też wszystko wygląda poprawnie. Co ciekawe, jeśli w putty'm wskażę nie odpowiedni klucz prywatny to otrzymuje zgodny z oczekiwaniem komunikat "Server refused our key". Jeśli klucz jest właściwy to komunikatu brak

Udostępnij ten post


Link to post
Share on other sites

@LukiD, witam na forum 😉 Widzę, że to Twoje pierwsze kroki na Forbocie, oto najważniejsze informacje na start:

  • Chcesz przywitać się z innymi członkami naszej społeczności? Skorzystaj z tematu powitania użytkowników.
  • Opis najciekawszych funkcji, które ułatwiają korzystanie z forum znajdziesz w temacie instrukcja korzystania z forum - co warto wiedzieć?
  • Poszczególne posty możesz oceniać (pozytywnie i negatywnie) za pomocą reakcji - ikona serca w prawym dolnym rogu każdej wiadomości.
31 minut temu, LukiD napisał:

Mam ten sam problem co kolega - mimo wgrania w odpowiednie miejsce klucza publicznego to nadal muszę podawać hasło. Sprawdziłem uprawnienia do pliku i katalogu .ssh i są właściwe (rwx --- ---). Sprawdziłem konfigurację ssh (/etc/ssh/sshd_config) ale tam też wszystko wygląda poprawnie. Co ciekawe, jeśli w putty'm wskażę nie odpowiedni klucz prywatny to otrzymuje zgodny z oczekiwaniem komunikat "Server refused our key". Jeśli klucz jest właściwy to komunikatu brak

Niestety nie mam teraz pod ręką RPi, aby to sprawdzić. Zweryfikuję poprawność instrukcji w poniedziałek. Na ten moment mogę tylko podpowiedzieć, że "statystycznie" problem jednak raczej występuje tylko u Ciebie (np. przez błędne wykonanego jakiegoś kroku instrukcji, może nawet z wcześniejszych części kursu). Ten artykuł był czytany przez XX tysięcy osób i do tej pory opis takiego problemu pojawił się chyba tylko 2 razy. Gdyby gdzieś w kursie był błąd to na pewno takich pytań było znacznie więcej. Oczywiście nie wykluczam, że coś zostało zaktualizowane i teraz ta instrukcja nie działa, ale intuicja podpowiada, że jednak wszystko jest poprawnie - sprawdzimy w poniedziałek. Daję znać, bo może zmotywuje Cie to do reinstalacji systemu i sprawdzenia wszystkiego raz jeszcze i wtedy sam rozwiążesz swój problem zanim zdążę usiąść do moich testów 😉

Udostępnij ten post


Link to post
Share on other sites

Cześć! Znalazłem błąd - kiedy wykonywałem działania z 7 części kursu, rozdział "Instalacja kluczy RSA" to z lenistwa skopiowałem z linijki poniżej wspomnianego nagłówka ścieżkę jako argument dla mkdir i nie zauważyłem literówki w nazwie pliku: autorized_keys . Dalej nazwa tego pliku jest już pisana poprawnie authorized_keys, ale po kolejnym przejrzeniu całej konfiguracji i poszczególnych kroków zauważyłem brak literki "H" w nazwie pliku. Po poprawie nazwy pliku uwierzytelnienie za pomocą klucza działa poprawnie

Ciekawi mnie tylko, dlaczego system nie zgłaszał komunikatu, że serwer odrzuca klucz.

Zrobiłem jeszcze jeden eksperyment - zmieniłem nazwę folderu .ssh na jakąś inną, żeby zasymulować brak pliku authorized_keys i spróbowałem się zalogować - wynik: malinka prosi o hasło, ale nie wyświetla komunikatu, a po zmianie klucza w putty'm malinka prosi o hasło I WYŚWIETLA komunikat... ot zagwozdka...

 

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

Gratuluję spostrzegawczości, czyli jednak drobny błąd w instrukcji - widocznie większość osób brała nazwę pliku z późniejszego fragmentu, w którym ten plik faktycznie powstawał. Dobrze, że na zrzutach ekranu i we wszystkich innych miejscach nazwa była poprawna. Dziękuję za zwrócenie uwagi, już poprawione!

Udostępnij ten post


Link to post
Share on other sites

Witajcie,

Dzięki Wam rozpocząłem moją przygodę z malinką i właśnie przerabiam doskonały kurs 🙂

W związku z faktem,iż do tej pory byłem związany w okienkami Windowsa to komendy Linuxa i ilość parametrów trochę mnie przeraża.

Aktualnie - zgodnie z opisem wszystko "idzie" jak trzeba. Problem pojawił się podczas testowania wiedzy, aby nie tylko odtwarzać przykłady z kursu. Postanowiłem założyć nowego użytkownika - komenda sudo adduser nowy_użytkownik, później ustawienie haseł i wszystko jest ok w konsoli. Następnie przez raspi-config nadałem uprawnienia do vnc. ( a jeszcze wcześniej przez sudo-visudo nowemu użytnikowi dałem uprawnienia root'a - pod rootem dopisałem linijkę nowy_użytkownik ALL=(ALL) NOPASSWD: ALL) i oczywiście restart. Teraz nie mam problemów z zalogowaniem się do raspberry pi przez ssh oraz przez WinSCP (nowy użytkownik spokojnie loguje się do malinki). Problem pojawia się, kiedy próbuje się zalogować do vnc. Adres maliny pozostaje bez zmian, wpisuję użytkownika i hasło i za każdym razem mam komunikat Access denied.

Czy możecie mi powiedzieć co robię źle?

Udostępnij ten post


Link to post
Share on other sites

Witam,

Chyba udało mi się rozwiązać problem - nie wiem czy to profesjonalne, ale przynajmniej działa. 🙂 Zapewne są dużo lepsze rozwiązania

Problem był w programie VNC viewer - tam, znajduje się opcja "user&permission" - dodałem tam "nowy_użytkownik" i prawa administracyjne.

Logowanie odbyło się z sukcesem 🙂

PS. Może komuś przyda się ta informacja .

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites
13 godzin temu, maciekk05 napisał:

nowy_użytkownik ALL=(ALL) NOPASSWD: ALL

Dlaczego NOPASSWD? Jeśli nie musisz nigdy tak nie rób - czasem konieczność wpisania hasła może uratować system w przypadku polecenia, które działa inaczej wydane ze zwykłego użytkownika, a inaczej z roota.

  • Lubię! 2

Udostępnij ten post


Link to post
Share on other sites

@ethanak  znalazłem gdzieś taką składnie (oczywiście z informacją, że bez NOPASSWD będzie wymagał podawania hasła) ale masz rację - podawanie hasła likwiduje zagrożenie o którym piszesz. Zaraz zmienię w ustawieniach. Dzięki za sugestię.

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Cześć, mam ten sam problem: server refused our key przy próbie logowania się za pomocą pary kluczy RSA w Puttym. W internecie widać, że zdarza się on dość często, jednak żadne z omawianych rozwiązań u mnie nie działa. Czy ktoś może rozwiązał ten problem?

Sprawdzałam uprawnienia do pliku z kluczem i do katalogu, upewniłam się, że klucz jest w jednej linii i kompletny, odkomentowałam ścieżkę do AuthorizedKeysFile w pliku /etc/ssh/sshd_config

Coś jeszcze mogę sprawdzić?

Udostępnij ten post


Link to post
Share on other sites

@Ma-G, witam na forum 😉 Widzę, że to Twoje pierwsze kroki na Forbocie, oto najważniejsze informacje na start:

  • Chcesz przywitać się z innymi członkami naszej społeczności? Skorzystaj z tematu powitania użytkowników.
  • Opis najciekawszych funkcji, które ułatwiają korzystanie z forum znajdziesz w temacie instrukcja korzystania z forum - co warto wiedzieć?
  • Poszczególne posty możesz oceniać (pozytywnie i negatywnie) za pomocą reakcji - ikona serca w prawym dolnym rogu każdej wiadomości.

Dnia 25.02.2019 o 21:46, Ma-G napisał:

Coś jeszcze mogę sprawdzić?

Upewnij się, że nie masz literówki w tworzonych plikach. Błędy, które zdarzały się tutaj niektórym osobom wynikały z błędnego nazywanie plików np. autorized_keys zamiast authorized_keys. Może u Ciebie pojawiła się jakaś analogiczna literówka?

Udostępnij ten post


Link to post
Share on other sites

Hej

@Ma-G: U mnie także występował problem odrzucania połączenia poprzez serwer. Okazało się, że na końcu klucza miałem ukrytą spację. Po jej usunięciu wszystko zaczęło działać. Usunąłem ostatni znak z klucz i kilka razy nacisnąłem Delete dla pewności. Następnie od nowa wpisałem usunięty znak.

Jak by ktoś potrzebował zmieniać uprawnienia do katalogu .ssh i pliku authorized_keys to polecam zestaw komend wydawanych z katalogu użytkownika:

chmod 700 .ssh
chmod 600 .ssh/authorized_keys
chown pi:pi .ssh -R

Czy to potrzebne to nie wiem. Najpierw grzebałem z uprawnieniami. Dopiero gdzieś udało mi się znaleźć, że ktoś miał spację na końcu klucza.

Pozdrawiam

Grzegorz

Udostępnij ten post


Link to post
Share on other sites

Bądź aktywny - zaloguj się lub utwórz konto!

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony

Utwórz konto w ~20 sekund!

Zarejestruj nowe konto, to proste!

Zarejestruj się »

Zaloguj się

Posiadasz własne konto? Użyj go!

Zaloguj się »

×