Skocz do zawartości
Zaloguj się, aby obserwować  
juras

[C] STM32 F103 - problem z wykorzystaniem ADC i DMA - CUBE

Pomocna odpowiedź

Witam forumowiczów.

Na podstawie kursu STM32 F4 na stronie Forbota staram się napisać program do wykorzystania ADC i DMA do pomiaru napięć. Pomiar napięć bez wykorzystania DMA potrafię wykonać bez problemu, jednak gdy chcę uruchomić DMA, obserwując w STM studio nie otrzymuję żadnych wartości z pomiaru - wartość zmiennej ciągle są równe 0.

Dodam też, że okno konfiguracyjne ADC w programie CUBE posiada mniej opcji niż w przypadku konfiguracji procesora F4 wykorzystanego w kursie. Zasadniczą (moim zdaniem) różnicą jest brak opcji "DMA continuous request". Tak wygląda okno konfiguracji ADC w CUBE dla mikrokontrolera F103:

Inne różnice to takie, że w opcjach DMA dla swoich potrzeb wybrałem długość danych jako pojedynczy bajt i to, że wykorzystuję 3 zewnętrzne kanały do pomiaru napięcia.

Czy ktoś z Was spotkał się już z podobnym problemem, lub wykorzystał prawidłowo DMA w F103?

Z góry dziękuję za odpowiedź.

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

Zaloguj się, aby obserwować  

×
×
  • Utwórz nowe...