Skocz do zawartości
Komentator

Kurs Raspberry Pi, projekty – #3 – Domoticz, kamera, GPIO

Pomocna odpowiedź

Kurs Raspberry Pi, projekty – #3 – Domoticz, kamera, GPIO

Za nami podstawowa instalacja Domoticza oraz podłączenie pierwszego czujnika. Teraz czas na porty GPIO oraz wykorzystanie kamery. Sprawdzimy również działanie harmonogramów i scen, czyli obowiązkowych elementów każdego systemu inteligentnego budynku.

UWAGA, to tylko wstęp! Dalsza część artykułu dostępna jest na blogu.

Przeczytaj całość »

Poniżej znajdują się komentarze powiązane z tym wpisem.

Udostępnij ten post


Link to post
Share on other sites

Fajny kurs, ale tak naprawdę to pokazuje tylko jak zainstalować domoticza i złapać "zajawkę" za co dziękuję :). Podłączać się czujnikami bezpośrednio pod rashberry wydaje się bardzo uciążliwe. Powinniście pokazać jak zkomunikować esp8266 lub arduino z raspberry. Dodatkowo jak skonfigurować apkę imperihome. Zapewne oddzielny kurs dotyczący tych aspektów budził by wielkie zainteresowanie.

Udostępnij ten post


Link to post
Share on other sites

@cino111, dziękuję za Twoją opinię 🙂 Masz rację to tylko wstęp, a możliwości Domoticza są znacznie, znacznie większe. To jest i miał być krótki wstęp do Domoticza, aby każdy mógł się zorientować czy to jest temat dla niego. Zresztą dokładnie to napisałem w podsumowaniu tego artykułu. Ten kurs ma być przeglądem różnych ciekawych projektów, które można wykonać z RPi, bo nie każdy musi być zainteresowany Domoticzem. Celowo teraz nie "mieszam" dorzucając do tego informacje o Arduino i ESP, bo i tak najpierw trzeba poznać podstawy, o których tutaj pisałem. Jeśli będzie odpowiednie zainteresowanie to na pewno w przyszłości temat ten zostanie na Forbocie opisany dokładnej. W każdym kursie trzeba gdzieś postawić granicę, aby nie opisywać za dużo informacji na raz. Ta seria dodatkowo jest specyficzna, bo z założenia miała opisywać jak najwięcej zupełnie różnych projektów. Więc mam wrażenie, że główny cel jest jednak spełniony - szczególnie biorąc pod uwagę, że z tego kursu (i poprzedniego) korzystają osoby, które jeszcze nie dawno często nie miały żadnego pojęcia o malince.

Udostępnij ten post


Link to post
Share on other sites
(edytowany)

Witam, mam problem z modułem przekaźnikowym działającym na zasadzie odwrotnych stanów logicznych. 

 

Edytowano przez oczek2k

Udostępnij ten post


Link to post
Share on other sites

@oczek2k, witam na forum 😉
Widzę, że to Twoje pierwsze kroki na Forbocie, jeśli chcesz przywitać się z innymi członkami naszej społeczności skorzystaj z tego tematu: Powitania użytkowników.

Co dokładnie się dzieje? Czy sprawdzałeś najpierw działanie opisywanego w kursie modułu buzzera? Jeśli pod danym pinem zadziała poprawnie buzzer to moduł przekaźnika również powinien działać. Jeśli nie sprawdzałeś działania układu tak jak jest to opisane w kursie to załóż proszę osobny temat i opisz tam swój problem. W komentarzach do kursów staramy się rozmawiać tylko o tematach związanych bezpośrednio z naszymi przykładami (tak, aby nie wprowadzać innych czytelników w błąd). Z góry dziękuję za zrozumienie i pomoc w utrzymaniu porządku na forum 🙂

Udostępnij ten post


Link to post
Share on other sites

Jako, że to mój pierwszy post na forum to zacznę od: witam wszystkich 🙂

Mam taki problem, że nagle w edytorze nano nie mogę otworzyć pliku domoticz.sh, tego skopiowanego do /etc/init.d. Otwiera się pusty i pojawia się błąd, widoczne to będzie na załączonym zrzucie ekranu.
Na początku wszystko było dobrze, dioda działała (buzzera jeszcze nie wpiąłem, jak chciałem dodać to właśnie pojawił się problem). Normalnie mi się otwierał i dopisywałem linijki do GPIO, nagle się zbiesił. Ten plik w katalogu domoticz otwiera się normalnie (ten screen też załączam). Natomiast przy otwieraniu tego z "init.d" pojawia się błąd odczytu. Próbowałem już otworzyć ten plik w VNC przez edytor tekstowy. Tak dopisałem te końcowe linijki, ale wtedy w domoticzu nie działało to. Przy próbie dodania diody nie było widać tych pinów GPIO (malinkę zrestartowałem). Próbowałem tez usunąć domoticza (cały ten katalog domoticz plus ten plik domoticz.sh z init.d) i wszystko powtórzyłem od nowa. Dalej przez edytor nano nie otwiera się ten plik po skopiowaniu go do init.d 😕

Czy ma ktoś pomysł dlaczego tak się stało, miał ktoś kiedyś taki problem? Może jedynym rozwiązaniem jest dopisywanie linijek w tym pliku w katalogu "domoticz" i potem ciągłe kopiowanie go do init.d po zmianach? Jednak na pewno nie jest to wygodne i zastanawia mnie czemu w nano nagle przestał się otwierać 😕

1.png 2.png

Udostępnij ten post


Link to post
Share on other sites

@Bhoy67, witam na forum 😉 Widzę, że to Twoje pierwsze kroki na Forbocie, oto najważniejsze informacje na start:

  • Chcesz przywitać się z innymi członkami naszej społeczności? Skorzystaj z tematu powitania użytkowników.
  • Opis najciekawszych funkcji, które ułatwiają korzystanie z forum znajdziesz w temacie instrukcja korzystania z forum - co warto wiedzieć?
  • Poszczególne posty możesz oceniać (pozytywnie i negatywnie) za pomocą reakcji - ikona serca w prawym dolnym rogu każdej wiadomości.

Dnia 22.09.2018 o 12:04, Bhoy67 napisał:

Mam taki problem, że nagle w edytorze nano nie mogę otworzyć pliku domoticz.sh, tego skopiowanego do /etc/init.d. Otwiera się pusty i pojawia się błąd, widoczne to będzie na załączonym zrzucie ekranu.

Przepraszam za późną odpowiedź, ale jakoś umknęło mi Twoje pytanie. Zacznę standardowo: czy po restarcie problem nadal występowało? Możliwe, że coś się "namieszało", gdy w tym samym czasie edytowałeś plik w nano oraz przez WinSCP.

Dnia 22.09.2018 o 12:04, Bhoy67 napisał:

Może jedynym rozwiązaniem jest dopisywanie linijek w tym pliku w katalogu "domoticz" i potem ciągłe kopiowanie go do init.d po zmianach?

Nie, nie spokojnie - można edytować plik w miejscu docelowym. Kwestia uprawnień 🙂

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Dzięki @Treker za odpowiedź 🙂 W udzielaniu się na forum pierwsze kroki, chociaż z Waszych kursów to już trochę korzystam (wcześniej nie miałem rejestrowanych zestawów, często samodzielnie kompletowane). Również za Wasze kursy dziękuję, bo bardzo pomocne 😉

Co do Twojej odpowiedzi- sprawdzę jutro to jeszcze raz na malinie (dziś nie mam przy sobie) lecz z pamięci coś na to odpowiem. Jestem przekonany, że uprawnienia edytowane przez 'chmod' były takie jak należy, w nich nic nie pomieszałem.

Dnia ‎30‎.‎09‎.‎2018 o 23:00, Treker napisał:

Zacznę standardowo: czy po restarcie problem nadal występowało? Możliwe, że coś się "namieszało", gdy w tym samym czasie edytowałeś plik w nano oraz przez WinSCP.

1. Po restarcie nadal był problem. Pamiętałem o restarcie i nic to nie dało.

2. Ja najpierw cały czas próbowałem otworzyć to w nano i efekt taki jak już przedstawiłem, czyli ten plik skopiowany do init.d otwiera się pusty. Ponowna instalacja domoticza na nic się zdała. Dopiero potem próbowałem otworzyć go przez VNC w edytorze tekstu (tam trzeba było trochę pomieszać uprawnienia, żebym mógł zapisać w nim zmiany, ale potem wróciłem do takich jak były).

Jeśli chodzi o kurs to cały odcinek wykonałem w taki sposób, że edytowałem ten plik z katalogu "domoticz" i gotowy kopiowałem do init.d, potem restart. No i wszystko działało, tylko ten problem wygody pozostaje 🙂 I ciekawość czemu nagle tak się stało, bo nie mam pojęcia. Spróbuję jeszcze jutro pokombinować. Pewnie jednak coś namieszałem, a nie że przestało działać przez magię. Na początku po pierwszej instalacji domoticza to działało normalnie w nano...

Udostępnij ten post


Link to post
Share on other sites
Dnia 3.10.2018 o 21:12, Bhoy67 napisał:

I ciekawość czemu nagle tak się stało, bo nie mam pojęcia. Spróbuję jeszcze jutro pokombinować. Pewnie jednak coś namieszałem, a nie że przestało działać przez magię. Na początku po pierwszej instalacji domoticza to działało normalnie w nano...

To niestety nie mam pomysłu co się mogło stać. Jak sam widzisz nikt inny nie zgłasza podobnego problemu. A nie zmieniałeś może czegoś w uprawnieniach pliku lub w uprawnieniach Twojego użytkownika?

Udostępnij ten post


Link to post
Share on other sites

No właśnie nikt inny problemu nie zgłasza i ja też nie mam pojęcia co tu się mogło stać. Jak stało się to po raz pierwszy (i od tamtej pory do dziś nie działa) to jestem przekonany na 100% że nic przy uprawnieniach nie kombinowałem. Jakiekolwiek kombinacje to ja zacząłem później stosować, gdy tak jak pisałem próbowałem odpalić to w VNC. Wtedy musiałem trochę to pozmieniać- dodać możliwość zapisu.

No ale koniec końców z całym artykułem sobie poradziłem, bo edytowałem ten w katalogu 'domoticz" i kopiowałem do init.d, więc zostawmy to i mniejsza z tym 😉

Udostępnij ten post


Link to post
Share on other sites

Jeśli to tylko Twoja platforma testowa to w wolnej chwili proponowałbym najbardziej brutalne rozwiązanie tj. instalację czystego systemu i później ponowy test instalacji Domoticza. Wtedy powinno obejść się bez problemów, a jeśli jakieś będą to zanim zaczniesz "kombinować" z uprawnieniami daj nam znać i wtedy wymyślimy coś wspólnie 😉

Udostępnij ten post


Link to post
Share on other sites

Cześć :) Na wstępie chciałbym powiedzieć, że super wyszedł wam ten poradnik, zarówno wersja dla początkujących jak i zaawansowanych.

Próbuję dodać LEDy do Domoticza przez GPIO, ale niestety za każdym razem jak dodaję pojawia się błąd GPIO.INIT.ERROR. Wszystko zrobiłem zgodnie z instrukcją. W załącznikach przesyłam screen z Domoticza i domoticz.sh. 

Z góry dzięki za pomoc :)

Zrzut ekranu 2018-11-16 o 17.03.35.png

Zrzut ekranu 2018-11-16 o 17.04.30.png

Udostępnij ten post


Link to post
Share on other sites

@grossier, witam na forum 😉 Widzę, że to Twoje pierwsze kroki na Forbocie, oto najważniejsze informacje na start:

  • Chcesz przywitać się z innymi członkami naszej społeczności? Skorzystaj z tematu powitania użytkowników.
  • Opis najciekawszych funkcji, które ułatwiają korzystanie z forum znajdziesz w temacie instrukcja korzystania z forum - co warto wiedzieć?
  • Poszczególne posty możesz oceniać (pozytywnie i negatywnie) za pomocą reakcji - ikona serca w prawym dolnym rogu każdej wiadomości.

20 godzin temu, grossier napisał:

Cześć 🙂 Na wstępie chciałbym powiedzieć, że super wyszedł wam ten poradnik, zarówno wersja dla początkujących jak i zaawansowanych.

Miło słyszeć, że się podoba - dzięki!

20 godzin temu, grossier napisał:

Próbuję dodać LEDy do Domoticza przez GPIO, ale niestety za każdym razem jak dodaję pojawia się błąd GPIO.INIT.ERROR. Wszystko zrobiłem zgodnie z instrukcją. W załącznikach przesyłam screen z Domoticza i domoticz.sh. 

Czy masz zainstalowane wiringpi? Informacja o tym jak to sprawdzić znajduje się w artykule 😉 Czy to czysta instalacja systemu, czy coś wcześniej na niej już robiłeś?

Udostępnij ten post


Link to post
Share on other sites
8 minut temu, Treker napisał:

Czy masz zainstalowane wiringpi? Informacja o tym jak to sprawdzić znajduje się w artykule 😉

Tak, mam.

9 minut temu, Treker napisał:

Czy to czysta instalacja systemu, czy coś wcześniej na niej już robiłeś?

Nie jest czysta per se, robiłem na niej poprzednie zadania z kursu. Oprócz Raspbiana i Domoticza nic nie ma.

Udostępnij ten post


Link to post
Share on other sites

Możesz sprawdzić dla pewności czy samo GPIO z wiringpi działa poprawnie korzystając z instrukcji opisanych tu: Kurs Raspberry Pi – #12 – podstawy GPIO, skrypty? Będziemy wiedzieli czy to problem "gdzieś w malince", czy może jednak chodzi o samą konfigurację Domoticza.

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Napisz odpowiedź...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...