Skocz do zawartości

Raspberry Pi Composite czarno-biały obraz


Pomocna odpowiedź

Cześć,

próbuję podłączyć raspberry do telewizora przez RCA. Kupiłem przewód na aliexpress, ale oczywiście żyły były zamienione i musiałem go przeciąć i samemu dopasować kolejnosć przewodów. W jakikolwiek sposób nie ustawię przewodów to ekran zawsze jest czarno-biały. Próbowałem w config.txt zmieniać sdtv_mode, overscan, sdtv_enable_colorburst=0 i nic mi nie pomogło. Wiem, że telewizor działa poprawnie z wejściem analogowym, ponieważ podpinałem pod niego PS2.

Próbowałem się posłużyć konfiguracją z poradnika: https://www.instructables.com/id/DIY-Raspberry-Pi-Zero-Handheld-Game-Console/

ale też bez efektu. W którymś momencie skala szarości zmieniła się na skalę zielony-czarny, ale po chwili wróciło do czarny-biały.

Dźwięk działał akceptowalnie, sprawdzone w retropie. Problem wygląda identycznie na Raspberry Pi 3B oraz Raspberry Pi B+.

Jeśli ktoś z was spotkał się z problemem skali szarości, to proszę o pomoc. Załączam mój plik config.txt.

Pozdrawiam

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=0

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=640
#framebuffer_height=480

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=2
#hdmi_mode=51

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
sdtv_mode=2
#sdtv_aspect=1
sdtv_enable_colorburst=0
#boot_delay=3
avoid_safe_mode=1


#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on
gpu_mem_256=128
gpu_mem_512=256
gpu_mem_1024=256
overscan_scale=1
#dtoverlay=vc4-fkms-v3d
#dtoverlay=vc4-kms-v3d

 

Link to post
Share on other sites

@smarzony, witam na forum 😉 Widzę, że to Twoje pierwsze kroki na Forbocie, oto najważniejsze informacje na start:

  • Chcesz przywitać się z innymi członkami naszej społeczności? Skorzystaj z tematu powitania użytkowników.
  • Opis najciekawszych funkcji, które ułatwiają korzystanie z forum znajdziesz w temacie instrukcja korzystania z forum - co warto wiedzieć?
  • Poszczególne posty możesz oceniać (pozytywnie i negatywnie) za pomocą reakcji - ikona serca w prawym dolnym rogu każdej wiadomości.

17 godzin temu, smarzony napisał:

Próbowałem w config.txt zmieniać sdtv_mode, overscan, sdtv_enable_colorburst=0 i nic mi nie pomogło. Wiem, że telewizor działa poprawnie z wejściem analogowym, ponieważ podpinałem pod niego PS2.

Najczęściej przyczyną czarno-białego obrazu jest złe ustawienie trybu PAL/NTSC. Próbowałeś na początku zmienić tylko to ustawienie czy od razu "mieszałeś" w różnych ustawieniach?

Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.