Skocz do zawartości
locztek

Sprawdzenie schematu - podłączenie TB6612 do Arduino

Pomocna odpowiedź

Witam 

Próbuje zrobić arduino line followera i aktualnie czekam na części. Postanowiłem więc zrobić schemat połączeń aby po przyjściu części od razu zająć się składaniem robota.

Jako że jestem początkującym zwracam się z prośbą do Was o zerknięcie na ten schemat, wiem że nie jest on szczególnie czytelny, ścieżki mogłyby być poprowadzone inaczej ale bardziej zależy mi by dowiedzieć się czy wszystko dobrze podłączyłem i czy taka konstrukcja się nie spali 😉 Jeśli chodzi o część zaznaczoną czarną ramką to jest to mostek h TB6612FNG połączony z kondensatorami w sposób taki jak jest na płytce tutaj (ponieważ taką właśnie zamówiłem)

Tak więc jakby mógł ktoś zobaczyć i powiedzieć co zrobiłem nie tak to byłbym wdzięczny 🙂  

schemat.png

Udostępnij ten post


Link to post
Share on other sites

Faktycznie schemat nie jest zbyt czytelny, ale coś tam widać 😉  Czy dobrze dostrzegłem, że masz połączone napięcie 5V z Arduino z napięciem podawanym na mostek, którym mają być zasilane silniki? To nie jest zbyt dobre rozwiązanie, nie możesz zasilać silników ze stabilizatora wbudowanego w Arduino. Chyba, że chcesz całość zasilić z tej "baterii" widocznej na schemacie, ale nie podałeś informacji na temat jej napięcia i trochę to podejrzanie wygląda. Jak dokładnie chcesz to zasilać i jaki prąd pobierają maksymalnie Twoje silniki?

Udostępnij ten post


Link to post
Share on other sites

Chcę zasilać to lipol'em 2s 7,4v 1100mAh  jeśli chodzi o maksymalny prąd to 300mA a napięcie silników to 6v i wszystko chciałbym zasilić właśnie z tego lipola

 

Udostępnij ten post


Link to post
Share on other sites

Czy w takim razie dobrze widzę, że 7,4V z LiPo chcesz podłączyć do 5V w Arduino?

Udostępnij ten post


Link to post
Share on other sites

Niestety tak .. czyli powinienem wcale  nie łączyć 5v z arduino z lipol'em ale tylko vin z nim połączyć?  A przy dobieraniu połączeń starałem się zrobić to tak jak na zdjęciu . Wziąłem pinout'y Uno i Mini i dobierałem tak żeby piny które zostały użyte w mini były takie same jak te w Uno  .

TB6612FNG_bb_1.jpg

Udostępnij ten post


Link to post
Share on other sites
5 godzin temu, locztek napisał:

Niestety tak .. czyli powinienem wcale  nie łączyć 5v z arduino z lipol'em ale tylko vin z nim połączyć? 

Podłączenie LiPola do 5V w Arduino natychmiast spali układ. Tak, najlepiej LiPol do Vin. Pytanie wtedy tylko jak zasilisz silniki, bo przy 300 mA nie możesz zasilać ich przez stabilizator wbudowany w Arduino. Może zaryzykować zasilanie ich prosto z LiPola i kontrolować prędkość za pomocą PWM (uważając, aby ich nie spalić). Alternatywnie możesz dodać drugi stabilizator (w tym wypadku wystarczyłby nawet 7806) albo przetwornicę tylko pod zasilanie silników.

Udostępnij ten post


Link to post
Share on other sites

Czyli jeśli dobrze zrozumiałem to tam gdzie szarą kropką zaznaczyłem mogę dać przetwornice step down 6 v i to załatwi sprawę?

połączenie.png

Udostępnij ten post


Link to post
Share on other sites

Jeśli zamiast baterii 2xAA będziesz zasilał układ z LiPola 7,4V to tak 🙂

Udostępnij ten post


Link to post
Share on other sites

W takim razie dziękuje bardzo za pomoc 🙂 ! Jak dojdą części i całego go zbuduje to pochwale się na forum .Pozdrawiam!

 

 

Udostępnij ten post


Link to post
Share on other sites

Bądź aktywny - zaloguj się lub utwórz konto!

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony

Utwórz konto w ~20 sekund!

Zarejestruj nowe konto, to proste!

Zarejestruj się »

Zaloguj się

Posiadasz własne konto? Użyj go!

Zaloguj się »

×