Skocz do zawartości
Zaloguj się, aby obserwować  
skowron

[Line Follower] ATmega8 L293D bez ADC

Pomocna odpowiedź

Witam,
Proszę o sprawdzenie tego schematu. Dopiero zaczynam więc możliwe że będzie sporo błędów 😉 Czujniki to nie CNY17 a CNY70 tylko tych drugich nie mogłem znaleźć w eagle.

Pozdrawiam Krzysiek

Udostępnij ten post


Link to post
Share on other sites

1) Diody przy mostku L293D są właściwie niepotrzebne - mostek ma je wbudowane (dotyczy tylko wersji z "D")

2) Jeśli mam się czepiać, to kondensator na wejściu stabilizatora to wg noty katalogowej zdaje się 0,33uF 🙂 Oprócz tego dodał bym na wejściu elektrolit 100uF

3) Brakuje mi złącza ISP, choć to oczywiście nie jest błąd (pytanie, czy chce Ci się za każdym razem wyciągać procka?)

4) Reset bezpieczniej jest chyba zostawić w powietrzu (ew. doprowadzić do złącza ISP 😉 )

5) Dlaczego właściwie stosujesz komparatory? Przecież dużo prościej można wykonać i skalibrować czujniki podłączone do portów ADC przez dzielniki napięcia

6) Rezystor na linii do "-" komparatora jest w złym miejscu. Porównaj sobie chociażby z tym schematem: https://www.forbot.pl/forum/upload_img/obrazki/IMG_4967454e401c38116.png

Tutaj schemat chyba przyjemniejszy https://www.forbot.pl/forum/upload_img/obrazki/IMG_4869db123af687811.gif, na wypadek gdybyś mimo wszystko zdecydował się na komparatory.

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Ok dzięki za rady, możesz zerknąć czy teraz jest w porządku?

Udostępnij ten post


Link to post
Share on other sites

Teraz gitara. Jedynie aref połączył bym z avcc.

Udostępnij ten post


Link to post
Share on other sites

Dlaczego nie podciągać resetu do VCC? Ja tak robię i jeszcze przez kondensator 100nF do masy i przycisk do resetowania i wszystko gra, jak zostawiam "w powietrzu" to mi się procek czasem samoistnie resetuje.

W dodatku podłączyłbym wyjścia enable do timera z PWM (OC1a i OC1b), można by sterować prędkością silników, może się kidyś przydać .

Udostępnij ten post


Link to post
Share on other sites

Prawda, na wyjścia Enable nie spojrzałem. Co do resetu, to jednym działa, innym nie. Mi osobiście procek resetował się właśnie z podciągniętym resetem - choć to kwestia dobrego wyfiltrowania zasilania. Od kiedy zostawiam reset "w powietrzu" problem się nie pojawia, a trochę konstrukcji już zrobiłem.

Pozdrawiam

Udostępnij ten post


Link to post
Share on other sites

No to w porządku, niech sobie skowron sam sprawdzi czy potrzebuje rezystor przy resecie czy nie 🙂

Profilaktycznie dodałbym jeszcze kondy 100nF przy zasilaniu uC i mostka, ale to już wedle uznania, nie są konieczne.

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

Zaloguj się, aby obserwować  

×
×
  • Utwórz nowe...