Skocz do zawartości

Problemy z Pololu A4988


Pomocna odpowiedź

@andrews 

Dnia 19.05.2019 o 16:12, andrews napisał:

jakie jest napięcie pomiędzy 2A i 2B,

Nic tu nie ma (no chyba że coś źle mierzyłem, ale tu raczej wątpię)

Cytat

jakie jest w ogóle napięcie zasilania silnika mierzone bezpośrednio na płytce (pomiędzy VMOT i GND),

12 V, 0,8A (wcześniej było 0,4A), natężenie może być minimalnie niższe (0,78A)

Cytat

jakie napięcie jest na wyjściu stabilizatora napięcia.

36A

Cytat

oraz napięcie zasilające logikę (pomiędzy VDD i GND) bezpośrednio na płytce.

w jaki sposób bezpośrednio na płytce?

 

Link to post
Share on other sites
2 godziny temu, Bartt napisał:
Cytat

jakie jest w ogóle napięcie zasilania silnika mierzone bezpośrednio na płytce (pomiędzy VMOT i GND),

12 V, 0,8A (wcześniej było 0,4A), natężenie może być minimalnie niższe (0,78A)

Co się zmieniło, że teraz jest większy prąd?

Zwróć uwagę, co napisałem w poprzednim poście. Napięcie na wejściu REF układu A4988 (czyli na suwaku potencjometru) powinno być równe 160mV, a przynajmniej nie powinno być większe, żebyś nie przegrzał silnika.

Coś tu zdecydowanie nie pasuje. Może jednak coś źle mierzysz. Jeśli bezpośrednio na płytce sterownika pomiędzy VMOT i GND jest napięcie 12V i płynie prąd 0,8A, to na czym jest spadek napięcia, jeśli nie na cewkach? Gdyby z kolei przez cewki płynął prąd, to powinien być na nich spadek napięcia, więc coś tam powinieneś zmierzyć. Skoro na cewkach nie ma napięcia, to może masz tam jakieś zwarcie, albo coś źle podłączyłeś. Zrób może jakieś zdjęcia, jak to masz podłączone fizycznie (nie rysunek), pokaż jak i gdzie mierzysz napięcia i może przede wszystkim w jaki sposób mierzysz prąd. Poza tym nie odpowiedziałeś na wszystkie pytania, np. czy pomiędzy 1A-1B masz (przy wyłączonym zasilaniu) rezystancję 30 Ohm (taka sama powinna być pomiędzy 2A-2B).

 

2 godziny temu, Bartt napisał:
Cytat

jakie napięcie jest na wyjściu stabilizatora napięcia.

36A

Na wyjściu stabilizatora masz 36A? Chyba miałeś na myśli 36V, ale to też raczej niemożliwe. Może mierzyłeś na wejściu stabilizatora? Nie wiem jaki to stabilizator, ale zwykle takie stabilizatory mają maksymalne napięcie wejściowe rzędu 35V, więc to też trochę na granicy bezpieczeństwa.

Wybacz, ale ja nie widzę co i jak robisz. Niemniej informacje, które podajesz są raczej mało prawdopodobne, więc coś musisz robić nie tak.

2 godziny temu, Bartt napisał:
Cytat

oraz napięcie zasilające logikę (pomiędzy VDD i GND) bezpośrednio na płytce.

w jaki sposób bezpośrednio na płytce?

Nie wiem, jak to ująć inaczej. Bezpośrednio na płytce sterownika, czyli dotykając przewodami pomiarowymi pola lutownicze na płytce sterownika, gdzie przylutowane są przewody zasilające logikę (a nie np. na wyjściu tego napięcia z Raspberry Pi).

Edytowano przez andrews
Link to post
Share on other sites

@andrews

  • Cytat

    Co się zmieniło, że teraz jest większy prąd?

    Wyjąłem jeden rezystor, wcześniej pisałeś że ma być 0,8

  • Cytat

    Na wyjściu stabilizatora masz 36A? 

    Sorry, pomyliłem z natężeniem 😃, jest coś około 12,2V

  • Cytat

    napięcie zasilające logikę

    5V 

 

 

Link to post
Share on other sites
1 godzinę temu, Bartt napisał:

Wyjąłem jeden rezystor, wcześniej pisałeś że ma być 0,8

Może źle to ująłem. Miałem na myśli, że tyle maksymalnie może pobierać silnik, ale nie zawsze tak będzie. Właściwie to nawet przy pracy pełnokrokowej prąd płynie przez obydwie cewki, ale tylko ok. 70% maksymalnego. Sterownik sam sobie to reguluje na podstawie napięcia ustawionego potencjometrem na pinie REF sterownika A4988 w zależności od trybu pracy i kolejnego kroku.

Napisz dokładnie, jak mierzysz prąd. Obawiam się, że przy pomiarze prądu podłączasz przewody pomiarowe tak samo jak podczas pomiaru napięcia, czyli do VMOT i GND.

Jeśli chcesz zmierzyć prąd pobierany przez układ, musisz np. odłączyć od płytki sterownika przewód dodatni (VMOT), podłączyć do niego jeden z przewodów pomiarowych, a drugi przewód pomiarowy podłączyć wtedy do pola lutowniczego VMOT na płytce sterownika, z którego przewód dodatni wylutowałeś. Oczywiście przyrząd musi być przełączony  na pomiar prądu. Inaczej mówiąc musisz podłączyć przyrząd szeregowo.

Edytowano przez andrews
Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.