Skocz do zawartości
damiancio13

Problem z Raspberry Pi 4 - brak sygnału HDMI

Pomocna odpowiedź

@jakubortyl a sprawdzałeś działanie układu bez obudowy (bez bocznych ścianek)? Złącze microHDMI nie jest zbyt wygodne i czasami nie styka dosłownie przez brakujące  0,1 mm. Z tego co przeszukałem różne zgłoszenia to trafiła się już u kogoś taka sytuacja, że właśnie przez obecność obudowy kabel nie stykał poprawnie. W takiej sytuacji najlepiej dosunąć RPi wewnątrz obudowy najbliżej ścianki z otworem na HDMI 🙂 Mogą też być inne przyczyny tego problemu (np. minimalnie krótsze złącze lub grubsza ścianka obudowy z plexi). Nie zdarza się to często, ale warto sprawdzić ten temat i wykluczyć go na samym początku.

Udostępnij ten post


Link to post
Share on other sites

witam

Bez obudowy, na kolejnym przewodzie dał obraz hdmi. Ale dziwna sprawa bo nie ma dżwięku. Ani Jack ani hdmi. A obraz raz na kilka prób się nie pojawia

Pozdrawiam 

Udostępnij ten post


Link to post
Share on other sites

@jakubortyl może w takim razie masz uszkodzone gniazda microHDMI na RPi? Mało prawdopodobne, ale jest taka szansa. Przyznam, że nie mam już pomysłu, bo Twoje problemy są dość "losowe" - tak jakby były właśnie zależne od uszkodzonego gniazda. Chyba najlepiej będzie jak napiszesz do Botlandu na adres reklamacje@botland.com.pl - opisz swój problem i wszystkie próby, może oni skojarzą taki problem z jakąś wcześniejszą reklamacją i będą w stanie Ci pomóc. W między czasie możesz oczywiście korzystać dalej z kursu (wiele zadań wymaga jedynie łączności przez SSH).

Udostępnij ten post


Link to post
Share on other sites

A ja mam problem z "umierającym" prawdopodobnie GPU na PI4. Dzieje się to w momencie podłączenia 2 monitorów HDMI. Zdarzyło mi się wyjąć podczas pracy jeden z przewodów HDMI. Wtedy PI4 na chwilę zgasiła obraz, potem obraz ponownie powrócił na jednym z monitorów, a procesor nagle podniósł temperaturę z ok 50st na 74st. Kolejne uruchomienie skutkowało pracą jednego monitora (tego co go odłączyłem). Podobna sytuacja miała miejsce podczas podłączenia oscyloskopu do shelda. Też "umarł" procesor w identyczny sposób.  Czy ma ktoś podobne doświadczenia?

Pozdrawiam,

Udostępnij ten post


Link to post
Share on other sites

@Smoczy czy później, po "ostygnięciu" układ działa czy to faktycznie bezpowrotne uszkodzenie?

Udostępnij ten post


Link to post
Share on other sites

Bezpowrotne, ponieważ po ostygnięciu i kolejnym podłączeniu układ rozgrzewa się ponownie.

Udostępnij ten post


Link to post
Share on other sites
(edytowany)
Dnia 19.12.2019 o 19:51, damiancio13 napisał:

 

Cześć. Dopiero zaczynam przygodę z raspberry pi4 i od razu problem. Mianowicie mam Samsung smart TV (model UE40ES5500W) i malina nie chce z nim współpracować (nie wykrywa hdmi pomimo różnych konfiguracji w config.txt). Ma ktoś może rozwiązanie? Wiem, że może być zgrane bo przy pierwszym uruchomieniu (po zakupie - używka z rozdupczonym raspbian) widać było ładowanie ale wywaliło Kernel panic i  postanowiłem zainstalować LibreELEC. Po załadowaniu na kartę obraz pozostał czarny z komunikatem o barku obrazu z hdmi. To samo po zarzuceniu nowego raspbiana, dlatego wydaje mi się, że problem leży w konfiguracji.Widget blockquote

Edytowano przez dongregorio
Poprawiony model tv

Udostępnij ten post


Link to post
Share on other sites

@dongregorio witam na forum 🙂 Czy Twoje RPi działa poprawnie z innymi monitorami?

Udostępnij ten post


Link to post
Share on other sites

@Treker @Treker nie miałem możliwości sprawdzenia, ale jak już wspomniałem na "wysypanym" raspbianie się wyświetlało (był na zakupionej karcie używanej w zestawie z maliną). Były maliny na górze ekranu i tekst ładowania leciał do momentu Kernel panic na którym się zatrzymał. Jakbym był mądrzejszy to plik konfiguracji bym skopiował.

Sprawdziłem że przez vnc pulpit się wyświetla, tylko na TV nie chce mi puścić. Jakieś sugestie? Może ktoś ma  Samsung Smart TV z podłączoną maliną Pi4? Jeśli tak to czy jest możliwość przesłania pliku config.txt?

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...