Skocz do zawartości
danielll

Mikrokontroler STM-spalony?

Pomocna odpowiedź

Podłączyłem sobie dzisiaj dwa silniki. Wszystko dzialalo dobrze az do pewnego czasu gdy przez przypadek rozlaczyl mi sie kabel doprowadzajacy zasilanie do sterownika silnika z akumulatora. Uslyszalem lekkie pykniecie i natychmiast wylaczylem obwod z akumulatora. Teraz nawet gdy podlaczam sam mikrokontroler to mimo ze diody sie swiecą to st-link nie wykrywa plytki. Dodatkowo zauwazylem ze plytka sie mocno nagrzewa.

Czy to jest objaw spalenia mikrokontrolera? Prawdopodobnie tak, ale co konkretnie moglo byc przyczyna?

Udostępnij ten post


Link to post
Share on other sites

@danielll nie wiemy co dokładnie i do czego podłączyłeś oraz jak zasilany był układ. Ewentualna pomoc może się jedynie ograniczyć do wróżenia ze szklanej kuli 🔮 Daj znać co to za sterownik silników i jak był podłączony to łatwiej będzie coś doradzić.

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Sterownik to LSM293D

Zasilanie z lipola 7.4V

Prawdopodobnie jak rozlaczyl mi sue przewod od zasilania z akumulatora to dotknal masy mikrokontrolera. Glowne pytanie brzmi czy w takim przypadku mikrokontroler calkiem sie spalil i jest juz do wyrzucenia.

Udostępnij ten post


Link to post
Share on other sites

Oj jak z lipola zasilałeś to wszystko możliwe, kilkanaście amperów to norma jaką możesz z niego wyciągnąć więc nawet krótkie zwarcie może usmażyć elektronikę.

Możliwe że gdzieś jest bezpiecznik, dioda zabezpieczająca. Musiałbyś posprawdzać miernikiem gdzie jakie są napięcia. Ale jak płytka się nagrzewa to chyba koniec 😞 

  • Pomogłeś! 1

Udostępnij ten post


Link to post
Share on other sites

Co do podłączenia akumulatora to jak podłączam bezsposrednio plus do VIN, mase do GND i wysuwam zworke to powinno być ok?

Udostępnij ten post


Link to post
Share on other sites

Napisz jaki masz rodzaj płytki - rozumiem że jest to jakiś rodzaj płytki rozwojowej. Jeżeli masz Nucleo to tu jest dokumentacja i napisane jest że na Vin podajesz 7 do 12 V, czyli jak masz z 2 ogniwa to będzie ok. Zwróć uwagę że na 21 stronie jest coś o zworce, może na Twojej płytce będzie coś podobnego.

Udostępnij ten post


Link to post
Share on other sites

To jest nucleo. Dokladnie stm32f303re.

Wiem ze trzeba przelozyc zworke tylko jeszvze musze sprawdzic ktora. Chcialem sie tylko upewnic czy napiecie powyzej 5V nic nie uszkodzi i czy poprawnie podlaczam bo w sumie nie moglem znalezc nic w necie nic na temat polaczenia a czytanie dokumentacji jeszcze srednio mi idzie. Dzieki wielkie za pomoc 🙂

Udostępnij ten post


Link to post
Share on other sites
(edytowany)

W tym pdfie co podesłałem na końcu jest shcemat, co prawda inna wersja Nucleo ale myslę, że będzie to podobne. Jest tam regulator opisany jako LD50, który odpowiada układowi 1117. Ale tak patrząc na schemat to nie ma możliwości aby uszkodzić coś samym zasilaniem, bo zastanawiałem się czy jednoczesne podłączenie USB i czegoś na Vin mogło spowodować uszkodzenia ale wygląda na to że nie da się.

image.thumb.png.21a5669f9364046c851a119ecdce0c65.png

Edit: może zobacz czy zwora SB2 jest w dobrym stanie.

Edytowano przez Gieneq

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...