Skocz do zawartości

Sterowanie PWM L9110S


Pomocna odpowiedź

Cześć,

mam problem, który obrazuje ten film: 

Chodzi o to, że zgodnie z kodem i tym co gość robi na tej stronie: https://www.brainy-bits.com/l9110s/ oczekuję, że koło będzie kręciło się sekundę w jedną stronę, następnie sekundę w drugą. Niestety, koło zamiast kręcić się w jedną ze stron - piszczy. Specjalnie ustawiam prędkość na 240, ponieważ jest to duża wartość. Tym bardziej, że w przeciwnym kierunku koło się kręci i to dość żwawo. Gdy - co ciekawe - speed ustawię na 255, to silnik nawet nie piszczy. Na filmie widać płytkę stykową - nic z niej nie jest obecnie podłączone do arduino, a silnik podłączony jest do sterownika zasilaniem z 4 nowych baterii AA.

Proszę o pomoc. Przeglądałem noty katalogowe, filmy. Najczęściej sterują silnikami parami: LOW/HIGH (wejście A/B sterownika). I to też mi działa. Nie rozumiem, czemu gościowi z przytoczonego tutoriala działa, mimo, że robi inaczej a mnie nie. Co robię źle? Jak się tego dziada L9110S używa sterując PWMami prędkości w obu kierunkach?

Dziękuję z góry za każdą pomoc, ja tracę cierpliwość:)

Pozdrawiam,
Michał 

Link to post
Share on other sites

Nie wiem czy dobrze pamiętam, ale jak sterujesz mostkiem H za pomocą PWMa, a drugie wejście to DIR(kierunek), to zmieniając kierunek musisz też, zmienić fazę PWMa na przeciw fazę (o 180 stopni ?).

Mówiąc bardziej obrazowo, jeżeli kręcąc umownie w Prawo masz DIR=0, PWM=90% i jest OK, to jak chcesz to samo w lewo, dajesz DIR=1 to PWM=10%. Wiem że to brzmi trochę absurdalnie, ale jak dobrze pamiętam w takim typie sterowania mostkiem H za pomocą PWMa własnie to, tak "opacznie" działa.

Edytowano przez BlackJack
  • Lubię! 1
  • Pomogłeś! 1
Link to post
Share on other sites
31 minut temu, BlackJack napisał:

Nie wiem czy dobrze pamiętam, ale jak sterujesz mostkiem H za pomocą PWMa, a drugie wejście to DIR(kierunek), to zmieniając kierunek musisz też, zmienić fazę PWMa na przeciw fazę (o 180 stopni ?).

Mówiąc bardziej obrazowo, jeżeli kręcąc umownie w Prawo masz DIR=0, PWM=90% i jest OK, to jak chcesz to samo w lewo, dajesz DIR=1 to PWM=10%. Wiem że to brzmi trochę absurdalnie, ale jak dobrze pamiętam w takim typie sterowania mostkiem H za pomocą PWMa własnie to, tak "opacznie" działa.

Hej, i to by tłumaczyło dlaczego przy 255 jest cisza, a przy 240 jest głośny dźwięk. Sprawdziłem i ... rzeczywiście tak jest. Dzięki stokrotne 🙂

Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.