Skocz do zawartości
Pieterlpl

Brak komunikacji z czujnikiem CCS811

Pomocna odpowiedź

Cześć!

Kolejny problem z którym nie potrafię sobie poradzić. Otóż zamówiłem płytkę z czujnikiem taką jak na zdjęciu:

ccs811.thumb.jpg.be396038d613fd54b02a693b5d5c19d8.jpg

Po przylutowaniu goldpinów okazało się że ani Arduino UNO ani ESP32 nie wykrywają tego czujnika - brak adresu I2C. Nadmienię iż wcześniej podłączałem czujniki BME280, BMP280 oraz taki moduł z 3 czujnikami - BMP280 + HDC1080 + CCS811 i nie było żadnego problemu z wykryciem. Tego nie mogę w żaden sposób uruchomić. Napisałem do sprzedawcy, że być może jest on wadliwy. Po przysłaniu drugiego, ponownym przylutowaniu pinów sytuacja jest taka sama więc wierzyć mi się nie chce że 2 płytki uszkodzone. Na aliexpress znalazłem w której aukcji że być może potrzebne są rezystorki 4k7 podciągające zasilanie pod SCL i SDA ale to też nic nie daje.

Mieliście kiedyś styczność z tą płytką?

Pozdrawiam

 

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...