Skocz do zawartości
Okami

Problem z uruchomieniem Raspberry Pi 4 w wersji 2GB RAM

Pomocna odpowiedź

Witam

Stwierdziłem że zacznę swoją przygodę z malinką od zakupu kursu z tej strony.

Złożyłem obudowę, włożyłem karę i chciałem instalować system a tu psikus nie działa. (czerwona dioda zasilania cały czas się pali a zielona się zapala na trochę potem gaśnie i tak parę razy)

Czytałem że malinka w wersji 4 ma problem z działanie z nie którymi zasilaczami może właśnie trafiłem na taki model? (nie mam innego zasilacza niż ten dołączony do zestawu)

Byłbym wdzięczny za sugestie co mogę sprawdzić, jestem całkowicie zielony w tej materii.

Udostępnij ten post


Link to post
Share on other sites

@Okami witam na forum 🙂 Tak, masz rację, RPi nie działa poprawnie z niektórymi zasilaczami, ale w zestawach są sprawdzone modele i tutaj nie powinno być problemu 🙂 Jak próbowałeś instalować system? Podłączyłeś monitor czy próbowałeś komunikować się przez SSH lub UART?

Udostępnij ten post


Link to post
Share on other sites

Podłączałem malinkę do telewizora, przez HDMI. Port HDMI jest raczej dobry bo przez chwile telewizor zachowywał się tak jakby łapał obraz.

Jak będę miał czas to sprawdzę czy działa bez boku obudowy tak jak było sugerowane w innym temacie. We nie stykać bo raz mignęła mi dioda od zasilania.

Udostępnij ten post


Link to post
Share on other sites
(edytowany)

Sprawdziłem i tak udało mi się odpalić ale jest coś z portem zasilania bo żeby odpali to musiałem kablem porusza. Jak już coś pojawiło się na ekranie to trochę dziwnie się zrobiło. Mianowicie nie paliła się zielona dioda i malinka zamiast uruchomić instalator to uruchomiła się do raspbiana i po około 3 minutach zawiesiła się.

edit:

Może być tak że moje problemy mogą być spowodowane prze źle naganę dane na karcie?

edit2:

Jako tako udało mi się rozwiązać problem z nie włączającą się malinką. (z moich obserwacji wnioskuje że telewizor do którego podłączyłem malinkę „krztusi się” podawanym sygnałem wideo) Chciałem zmniejszyć rozdzielczość ale tutaj pojawił się drugi problem, masa artefaktów przy otwieraniu menu (najprawdopodobniej spowodowanych tym „krztuszeniem się”) ale i samo zachowanie systemu. Zachowuje się tak jakby brakowało mu ramu. Czy takie zachowanie może być spowodowane tym że ekran nie wyrabia z wyświetlaniem obrazu?

Sadzę że dało by się to zweryfikować łącząc się zdalnie przez ssh albo sprawdzić to na jakimś lepszym wyświetlaczu.

 

 

 

Edytowano przez Okami
dopisanie treści

Udostępnij ten post


Link to post
Share on other sites

@Okami hmm, to dość dziwne objawy - chyba jeszcze nikt nie opisywał u nas takiego przypadku. Testowałeś już łącznie przez SSH lub np.: VNC?

Udostępnij ten post


Link to post
Share on other sites

Trochę problemów mi się zebrało i zabawa z malinką musiała zejść na dalszy plan.

Chciałem dzisiaj sprawdzić komunikacje przez ssh. A tu kolejny problem zamiast 2 – 3 nowych partycji system widzi tylko jedną. Może coś źle robie a może karta albo dane na niej są zepsute. Moim pierwszym pomysłem było żeby sprawdzić czy pójdzie z inną kartą. Ale i na tą opcję nie znajdę za szybko czasu. Poniżej dwa zdjęcia z tym co mi pokazuje system(Win 7) po włożeniu karty.

1.png

2.png

Udostępnij ten post


Link to post
Share on other sites

@Okami instalowałeś system samodzielnie czy to karta, która powstała po użyciu NOOBSa?

Udostępnij ten post


Link to post
Share on other sites

A co ma pokazać? Przecież biedny Windows nie ma pojęcia o linkusowych systemach plików...

Udostępnij ten post


Link to post
Share on other sites

Z dobrze wgranym obrazem powinien dostać dwie partycje na karcie uSD, jedną FAT, a drugą o nieznanym systemie plików, co nawet w Windows daje dobry podgląd na to, czy można mieć szanse na poprawnie wykonaną operację wgrania obrazu systemu. W nowszych Windowsach (8 i 10) wykrycie obu partycji powinno nastąpić niezwłocznie po wgraniu obrazu karty (dwa nowe woluminy z literami dysku). Brak obsługi partycji typu ext nie powinien być żadną przeszkodą w pierwszej fazie oceny (u mnie ta ocena jest najczęściej ostateczna - bo to żadna skomplikowana operacja). Ze swej strony mogę polecić:

https://sourceforge.net/projects/win32diskimager/

 

Udostępnij ten post


Link to post
Share on other sites

Tak jak pisałem powyżej, używałem tylko karty dołączonej do zestawu .

Po złożeniu obudowy i podłączeniu malinki przez HDMI do telewizora. Malinka nie podawała na wyjście żadnego obrazu, po kilku próbach udało się mi uruchomić malinkę bez obudowy i na drugim porcie HDMI (chyba obudowa była źle złożona i wtyczka zasilania nie wchodziła do końca, a drugi port HDMI bo mój telewizor nie radzi sobie z sygnałem z tego złączą, widzi sygnał ale wyświetla mi komunikat „poza zakresem”)

Kiedy już uruchomiłem malinkę, zamiast włączyć się instalator systemu, system uruchomił się do pulpitu i gdzie pytał się tylko ustawienia klawiatury i aktualizacje. Pulpit wyświetla się normalnie ale jak chce coś zrobić to już źle to wyświetla np. po otwarciu terminala widać tylko kawałek wprowadzanej litery, podobnie jak chce otworzyć jakieś menu, pokazuje się tylko ta część pod kursorem to sama kursor też się blokuje. (sprawdzałem myszki bezprzewodowe jak i kablowe, obie zachowują się tak samo) Sam komputerek po około minucie zawiesza się.

Zgodnie z sugestią chciałem spróbować łączności przez ssh ale po ujrzeniu co jest na karcie zacząłem  mieć wątpliwości czy dane są poprawnie nagrane.

Myślicie że moje problemy mogą być spowodowane źle nagrany obrazem/ uszkodzeniem karty a może to coś poważniejszego i kontaktować się z działem reklamacji botlandu.

Udostępnij ten post


Link to post
Share on other sites

@Okami hmmm brzmi to dziwnie - nie było chyba tu takiego przypadku. Myślę, że najlepiej będzie jak spróbujesz nagrać obraz na kartę samodzielnie i zobacz co stanie się wtedy. Jeśli nadal będziesz miał ogólne problemy z działaniem malinki to zgłoś sprawę do Botlandu - na pewno szybko pomogą i wymienią RPi lub coś doradzą 🙂

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...