Skocz do zawartości

Zasilanie arduino nano i Sg90 z powerbanka


Pomocna odpowiedź

Witam.

Mam problem z zasileniem arduino nano i sewomechanizmów z powerbanka, a mianowicie, zrobiłem przejściówkę z USB na dwa żeńskie wtyki plus i minus do których podlaczone są przewody zasilajace od serwa. Gdy arduino i serwo są podłączone do oddzielnych gniazd USB w laptopie (arduino poprzez gniazdo miniUSB) to wszystko działa jak należy. Problem pojawia się gdy któreś z nich podłączam do powerbanka , wtedy serwo zaczyna wariować tzn. drży i nie może ruszyć się z pozycji 0. Nie wiem w czym problem , rozebrałem powerbank i w środku są dwa ogniwa lipo 18650 3.7V , na wyjsciu USB do którego podłączam np. serwo  jest 5.1V więc wszystko moim zdaniem powinno być ok. Poniżej zamieszczam zdjęcia powerbanka . Czy jeśli zbudował bym swój uklad na tych ogniwach i użyłbym przetwornicy step-up , ładowarki do li-xx , oraz stabilizatora napięcia to bylo by to samo? Docelowo ma to zasilać robota 4-nożnego z 12toma serwami sg90.

Pozdrawiam 😉

20200525_115203_HDR.thumb.jpg.c3dcaec6ce36342fd2d9e2bc733220a3.jpg

Edytowano przez Brafalo97
Link to post
Share on other sites

@Brafalo97 Cześć, na wstępie zasilanie serw z portu USB laptopa to nie najlepszy pomysł (port USB nie ma takiej wydajności prądowej (i nie jest stworzony do zasilania serw) i może się skończyć nawet jego uszkodzeniem) .

Należy pamiętać też o wspólnej masie. Nie jest zalecane że mikrokontroler (elektronikę) zasilasz z jednego źródła energii (laptop) a serwomechanizmy z innego np. powerbank (gdy masy nie są połączone ze sobą). 

Zobacz np. jak to jest realizowane w kursie Arduino: 

https://forbot.pl/blog/kurs-arduino-kontynuacja-uart-serwomechanizmy-id7520

Próbowałeś podłączyć Arduino i serwomechanizmy pod powerbank poprzez swoją przejściówkę z wtykami żeńskimi? Jak wtedy zachowywał się układ? 

Układ powerbank może nie być przystosowany do takiego obciążenia dlatego serwa są "niestabilne". 

Jeżeli zbudujesz swój układ oparty na takich ogniwach i zastosujesz odpowiednią przetwornicę i stabilizator to taki problem nie powinien występować. 

Musisz sprawdzić ile pobiera pojedyncze serwo podczas pracy i wtedy się dowiesz jakiego natężenia wyjściowego potrzebujesz. 

 

 

  • Lubię! 1
  • Pomogłeś! 1
Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.