Skocz do zawartości

Silniki do gimbali jako napędy w robocie


Pomocna odpowiedź

Cześć,

Jestem nowy na forum więc może najpierw przywitam się. Mam na imię Wojtek i zaczynam swoją przygodę z robotyką. Sam głównie chcę skupić się aspekcie mechanicznym ale jak wiadomo nie da się uciec odrobiny elektroniki i elektryki w projektowaniu robotów czy tak na prawdę czegokolwiek 😉

Ostatnio zainteresowałem się tematem silników w łaziku. Konstrukcja do której szukam odpowiedniego napędu to łazik o masie ok. 50kg, 4 kołowy o czterech osiach skrętnych. Mam dobrać do takiego układu silniki napędzające koła łazika. Maksymalna prędkość jaką powinien osiągać to mniej więcej 1m/s więc raczej niewiele ( średnica koła to mniej więcej 300mm ) Zasilanie łazika stanowi akumulator Li-Po 22.2V.

Przeszukując aliexpress w poszukiwaniu silnika natknąłem się na silniki do gimbali. Co sądzicie o takim napędzie do łazika? Oczywiście do silnika musiałbym zaprojektować przekładnię ale z tym nie będzie problemu, chodzi mi głównie o to czy pomysł zastosowania takiego silnika ma sens. Zainteresowałem się tymi silnikami bo mają stosunkowo małą prędkość obrotową przy stosunkowo dużym momencie obrotowym ( dla przykładu taki silnik: https://shop.iflight-rc.com/index.php?route=product/product&path=34_44&product_id=279 ).

Pozdrawiam,

Wojtek

Link to post
Share on other sites

Witam!

Zainteresował mnie ten problem ale w mniej ambitnym zakresie. Swojego czasu nabyłem silnik podobny GBM6208H-150T. Ma on zabudowany enkoder i złącze obrotowe. Chcę nim obracać. Dysponuję też płytką STM32F3DISCOVERY. Nabyłem sterownik ESC EMAX BLHeli-12A. Czy jak to poskładam będzie działało tj. silnik będzie się kręcił? Mam trochę więcej czasu więc połączyłem to w całość i jak na razie próbuję to ożywić ale bez skutku. ESC zasiliłem z zasilacza 9 V bo z instrukcji wynika, że tak jest ustawiony standardowo. 3 przewody wyjścia ESC podłączyłem do silnika. Z DISCOVERY zasiliłem wyprowadziłem GND do brązowego, 5 V do czerwonego i PWM do pomarańczowego. Generuję sygnał PWM o częstotliwości 400 Hz i wypełnieniu od 1 ms do 2 ms. A silnik nawet nie drgnie. Czy ktoś już coś takiego przerabiał?

Andrzej

Edytowano przez andzrej
Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.