Skocz do zawartości
Daniel1172

Sterownik serw PCA 9865 i mg996r - jedno nie działa

Pomocna odpowiedź

Witam wszystkich.

Mam problem ze sterownikiem serw PCA9865 ponieważ mam podłączone kilka serw mg 996r i jedno się spaliło. Kupiłem nowe aby wymienić i za nic nie chce działać, juz przetestowałem trzy serwa mg 996r od innego sprzedawcy i nadal nic. Czy może być tak że serwa które działają są cyfrowe a które nie działają są analogowe? Jest możliwa taka różnica w działaniu ?

Z góry dziękuję za odpowiedź

Udostępnij ten post


Link to post
Share on other sites

A co to takiego PCA9865? Słyszałem o PCA9685, ale o tym nie.

Jak zasilasz te serwa?

Próbowałeś je sterować bez sterownika, po prostu sygnałem PWM z mikrokontrolera?

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Tak, PCA9685, przestawiły się cyferki. Z zasilaniem nie ma problemu bo to jest akumulator 11,1V i dołączona przetwornica na 6V. Pojemności nie pamiętam ale wystarczająca. Tak, sterowalem je z Arduino Mega.

Udostępnij ten post


Link to post
Share on other sites
4 minuty temu, Daniel1172 napisał:

Tak, sterowalem je z Arduino Mega.

Nie o to pytałem. Jak podłączysz sygnał serwa zamiast do PCA9685 do nóżki tej twojej megi, i użyjesz biblioteki Servo do ruszania serwem, to działa?

Udostępnij ten post


Link to post
Share on other sites

To teraz pytanie jaką częstotliwość sygnału PWM generujesz tym PCA9685. Jeśli jest to cokolwiek innego niż standardowe 50Hz, to różne serwa mogą na to różnie reagować.

Udostępnij ten post


Link to post
Share on other sites

Mam 60 i na tym inne serwa chodzą. Na 50 jest to samo. Teraz mam inny problem, mianowicie podczas pracy innych serw wyciągnąłem wtyczkę nowego serwa i wsadziłem spowrotem i zaczęło działać, lecz jak zabrałem napięcie i włączyłem spowrotem to serwo znowu stoi i rusza jak wyciągnę i wsadzę wtyczkę. Wiem że to głupie ale tak jest i nie wiem dlaczego.

Udostępnij ten post


Link to post
Share on other sites

Być może warto wziąć multimetr albo nawet analizator logiczny czy oscyloskop i zacząć patrzeć na to jak te sygnały i zasilania rzeczywiście wyglądają.

Udostępnij ten post


Link to post
Share on other sites

To musi problem leżeć w samym serwie bo podłączając inne stare serwo tego samego modelu pracuje poprawnie.

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...