Skocz do zawartości
Cixo

Problem z uzyskaniem pożądanego Ic na 2n5551

Pomocna odpowiedź

udało się mamy 0.51A

czyli hfe brać z tego wykresu?

a np dla 2n5401

mi się udało 0.52A na 18R rezystor 

czy to dobrze i wg noty katalogowej?

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Cieszę się, że się udało. Mogą wypowiedzieć się jeszcze Koledzy, ale tak, hFe jest bardzo specyficznym parametrem, zazwyczaj podawana jest wartość średnia - zależy od temperatury, napięć, prądów, potrafi też się "rozrzucać" nawet porównując dwa identyczne tranzystory.

Odnośnie jeszcze 2n5551, hFe (czy beta, jak kto woli) = Ic/Ib = około 5, jest to raczej słaba wartość, ale jak widziałeś w nocie, dla mniejszych przedziałów prądu Ic jest zdecydowanie lepiej

Odnośnie 2n5401, nota jest tutaj: https://www.onsemi.com/pub/Collateral/2N5401-D.PDF , zastrzegam, że nie wiem, czy można wymuszać takie duże prądy bazy Ib, tam będzie około ćwierć ampera, ale dla mnie jest to dziwne - z charakterystyki wynika bowiem, że dla Ic = 100mA, Vce = -5V (bo to PNP) beta w temperaturze pokojowej jest równo 100, niemożliwe, by potem nagle wynosiła 2... Zastanawiające... Rozumiem, że modyfikowałeś odpowiednio schemat połączeń i sam układ, ponieważ na początku mierzyłeś tranzystor NPN (2n5551), a teraz PNP (2n5401)? Bo to bardzo ważne!

Udostępnij ten post


Link to post
Share on other sites

tak, zmieniłem bieguny, jak i bieguny miernika, a rezystor do GND. Rano dam zdjęcie płytki

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Jeśli to 2n5401, to wygląda na OK... Nie wiem, co może być przyczyną ograniczenia prądu, ale przychodzi mi jeszcze jedna myśl - spróbuj zlutować ten układ "na pająka". Płytki stykowe nie lubią zbyt dużych prądów, a >100mA już do takowych należy (ale zgaduję) 🙂

Udostępnij ten post


Link to post
Share on other sites

@wn2001Polutowałem, zasilacz to 5V 1A USB sytuacja dalej taka sama, przepraszam że długo nie odpisywałem, ale miałem baardzo dużo na głowie.

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

@wn2001Polutowałem, zasilacz to 5V 1A USB sytuacja dalej taka sama, przepraszam że długo nie odpisywałem, ale miałem baardzo dużo na głowie.

Dałem rezystor 22R, zasilacz 5V 2.1A USB, Ic = 400mA

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

@Cixo Jasne, to niestety nie umiem Ci więcej doradzić, może Kolegom przychodzi jeszcze coś na myśl? Bo moim zdaniem wygląda to tak, jakby albo amperomierz miał dużą rezystancję wewnętrzną i tranzystor się nasycał lub przy pewnych prądach beta spadała do jakiś bardzo małych wartości 😕

Udostępnij ten post


Link to post
Share on other sites

Dobrze, dzięki, muj amperomierz to taki typowy chińczyk za 15zl więc to w sumie możliwe, pojawia się też spadek napięcia na zasilaczu

Udostępnij ten post


Link to post
Share on other sites

A jak duży jest to spadek? Masz drugi multimetr aby zmierzyć rzeczywiste napięcie zasilające?

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...