Skocz do zawartości

Mosfet sterowanie STM32 ON-OFF


Pomocna odpowiedź

Cześć.

Uruchomiłem układu i działa, jeszcze nie wlutowałem procka ale zastanawia mnie jedna rzecz otóż jeżeli nie mam procka do rezystor r11 podciąga do 3.3v i mosfet nie powinien przewodzić? U mnie przewodzi w takiej sytuacji, może zmniejszyć rezystancję r11?

 

Link to post
Share on other sites

Nczego nie zmniejszaj tylko pomierz napięcia. Aby podjąć jakąkolwiek sensowną decyzję musisz wiedzieć co się dzieje a nie na czuja coś dłubać. Sprawdź czy rzeczywiście npn jest włączony - jakie napięcie jest na jego bazie a jakie na kolektorze i czy na bramce MOSFETa jest to samo. Przecież układ jest prosty jak cep, dwa-trzy pomiary woltomierzem, ew. jakieś sprawdzenie połączeń (po wyłączeniu wszystkich zasilań) i już wiesz. A jeśli wyczaisz coś dziwnego, drążysz temat. Wymyślaj sobie wtedy w głowie co musi się dziać (lub co musiało się stać) by sytuacja wyglądała tak jak ją widzisz to zwykłe poszukiwanie błędów. Poszukiwanie, a nie zmyślanie.

Link to post
Share on other sites

Pracuje w szpitalu i złapałem niestety covid i jestem w inbulatorium jedyne co mam to płytkę i wlutowane elementy (zapomniałem multimetru) jako wskaźnik że mosfet przewodzi mam wlutowaną diode Led na wyjściu mosfet do plusa która świeci jeżeli nie mam podpiętej masy na bramki tranzystora. Jak wyjdę to postaram się wszystko pomierzyć. 

Pozdrawiam 

  • Lubię! 2
Link to post
Share on other sites

No to popatrzmy. Na bazę npn zapodajesz prąd z 3.3V poprzez rezystancję sumaryczną R9+R11, tj. 23k. W takich warunkach na bazie powinieneś dostać ok. 0.6V bez żadnej łaski. To w końcu prawie 120uA więc całkiem zacny prąd. Jeżeli widzisz 0.28V to albo masz popsuty miernik, albo jego rezystancja wewnętrzna jest tak mała, że nie nadaje się do pracy z tego typu układami, albo źle podłączyłeś tranzystor, albo jest spalony albo nie jest npn. Dalej w zasadzie nie ma co analizować. Prąd bazy jest na tyle duży, że BC817 z opornikiem 1k w kolektorze powinien wejść w głębokie nasycenie (bo do tego wystarczy w tym wypadku tylko Ic>5mA) i na kolektorze a więc i na bramce powinieneś widzieć ok. 0.1V. Mam nadzieję, że tak proste rzeczy to sam rozkminiasz, dawno już znalazłeś błąd i wszystko działa.

  • Lubię! 1
Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.