Skocz do zawartości

Moje arduino bez przerwy wywala błąd


Pomocna odpowiedź

Spokojnie sobie testowałem termometr cyfrowy na arduino i nagle wywala mi błąd:

avrdude: ser_open(): can't set com-state for "\\.\COM9"
Upload error: Failed uploading: uploading error: exit status 1

teraz czasem wywala mi też taki błąd:

"avrdude: ser_open(): can't open device "\\.\COM9": Nie mo�na odnale�� okre�lonego pliku."

albo taki:

"Upload error: Failed uploading: no upload port provided"

 

Od tego czasu wywala mi ten błąd non stop przy każdym programie, nawet blinku. Zmieniałem kabel, wyłączałem i włączałem ide, odłączałem podłączałem ardu do komputera, zmieniałem porty, włączałem wyłączałem monitor portu szeregowego bo coś mi się kojarzyło że podobny błąd wyskakiwał jak zapominałem go wcześniej zamknąć. 

Dodatkowo:

1 Co chwilę słyszę wkurzający odgłos odłączania urządzenia. Tak jakby ciągle ktoś wyciągał i wsadzał wtyczkę którą podłączoną jest ardu. Odgłos jest najczęściej wtedy kiedy otwarty jest monitor portu szeregowego ale w ide wyświetla się że traci połączenie z płytką bez przerwy 

2 Wyskakuje komunikat następujący: "Error: Request upload failed with message: Upload error: Failed uploading: no upload port provided" oraz czasem "Could not reconnect to serial port. Error: Timeout after 10000 ms."

3 Arduino to klon.

4 Moje ide to wersja 2.00 we wczesnym dostępie.


Oprócz pomysłów na rozwiązanie problemu proszę również o jakiś sprawdzony sposób na odstresowanie bo mam już 4 inne ardu które w podobny sposób przestały działać i leżą w szufladzie a ja mam wrażenie że więcej czasu spędzam próbując je naprawić niż je programując.😤

  • Lubię! 1
Link to post
Share on other sites
51 minut temu, morteusz napisał:

Klon arduino uno

I juz kilka takich sztuk ma ten sam problem?? A masz czym wypalic bootloadera? Drugie Ardu pod reka?

Link to post
Share on other sites
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.
Zarejestruj się lub zaloguj, aby ukryć tę reklamę.

jlcpcb.jpg

jlcpcb.jpg

Produkcja i montaż PCB - wybierz sprawdzone PCBWay!
   • Darmowe płytki dla studentów i projektów non-profit
   • Tylko 5$ za 10 prototypów PCB w 24 godziny
   • Usługa projektowania PCB na zlecenie
   • Montaż PCB od 30$ + bezpłatna dostawa i szablony
   • Darmowe narzędzie do podglądu plików Gerber
Zobacz również » Film z fabryki PCBWay

2 godziny temu, farmaceuta napisał:

I juz kilka takich sztuk ma ten sam problem?? A masz czym wypalic bootloadera? Drugie Ardu pod reka?

Właściwie to nie ten sam problem. wcześniejsze arduina zawsze najpierw ładują się ekstremalnie długo a potem wywalają masę linijek błędu w stylu avrdude ....coś tam coś tam.  a tutaj wywala różne błędy, drogą dedukcj i dochodzę do konkluzji że błędy wyskakują różne ale przyczyna jest taka sama - rozłącza ciągle arduino. Kod błędu zmienia się w zależności od tego czy zacząłem wgrywać kod kiedy było rozłączone (wtedy wyskakuje to samo jakbym w ogóle nie podpiął płytki) czy rozłączyło w trakcie wgrywania kodu na płytkę (wtedy wyskakuję to: "avrdude: ser_open(): can't set com-state for "\\.\COM9"
Upload error: Failed uploading: uploading error: exit status 1" ).

Link to post
Share on other sites
1 godzinę temu, FlyingDutch napisał:

to może być uszkodzenie portu USB w kompie

wydaje się wysoce prawdopodobne w tym przypadku bo przy 3 wcześniejszych płytkach korzystałem jeszcze z innego komputera niż teraz i testowałem na lapku brata.

Link to post
Share on other sites
2 godziny temu, farmaceuta napisał:

Drugie Ardu pod reka?

Niestey nie. To było moje ostatnie. Mogę załatwić nowe ale jeżeli to coś np. z kablem to wolałbym to wyłapać i nie psuć kolejnej płytki.

Link to post
Share on other sites
1 godzinę temu, Belferek napisał:

I to samo się dzieje gdy odłączysz od Arduino WSZYSTKIE możliwe układy, czujniki itd.? Na samym Arduino?

Nobla dla tego pana! poznacie go po białym "B" na zielonym tle.

Link to post
Share on other sites
(edytowany)

No to teraz jak już "wszystko" działa, na spokojnie poszukaj błędu w swoim układzie i powiedz co było źle.

Edytowano przez Belferek
  • Lubię! 1
Link to post
Share on other sites
(edytowany)

Np. zapomnienie o tym, że z portu USB można łyknąć max pół ampera, i że Arduino może mieć problemy przy zasilaniu typu 4V 🙂

Ew. genialne podłączenia czujników do pinów 0/1 (pozdrowienia dla autorów kursów wszelakich)

Edytowano przez ethanak
  • Lubię! 1
Link to post
Share on other sites
(edytowany)


*Mam nadzieję że to czujnik temperatury bo niczym się nie różni od tranzystorów i czujników analogowych a w moich pudełkach z elektroniką to tak jakby ktoś wziął bombę i odpalił w środku.

Edytowano przez morteusz
Link to post
Share on other sites
  • Gieneq zmienił tytuł na: Moje arduino bez przerwy wywala błąd

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Anonim
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.

×
×
  • Utwórz nowe...

Ważne informacje

Ta strona używa ciasteczek (cookies), dzięki którym może działać lepiej. Więcej na ten temat znajdziesz w Polityce Prywatności.