Skocz do zawartości
danioto

Problem z LCD (wc1602a0)

Pomocna odpowiedź

Witam,
mam bardzo niezwykły dla mnie problem, z którym nie do końca wiem co mam zrobić. Mianowicie kupiłem wyświetlacz 2x16, oznaczenie jak w temacie (wc1602a0). Sprawdziłem notę katalogową, podłączenie standardowe, niby zgodne z hd44780 i kierując się wskazówkami na stronie Radzia chciałem podłączyć na początku tylko 3 piny, VSS, VDD, V0 (VSS i V0 do masy oraz VDD 3V3), oczekiwałem zapełnionych dwóch rzędów, lecz nie zobaczyłem nic... Pobawiłem się z potencjometrem, by ustawić ewentualny kontrast i dalej nic, lecz przypadkowo podłączyłem tylko VDD oraz V0 i okazało się, że na wyświetlaczu pojawiła się jedna linia kwadracików (przy kolejnych odłączeniach i podłączeniach zmieniała swoją pozycję). Co to znaczy? Czy mogę mieć po prostu uszkodzony wyświetlacz?

Udostępnij ten post


Link to post
Share on other sites

Po podłączeniu wyświetlacza ( 2*16 ) do zasilania i ustawieniu kontrastu ( bez mikrokontrolera ) zaświeca się pierwsza linijka znaczy piersze 16 górnych znaków ( prostokontów ) -wyświetlacz sprawny

Udostępnij ten post


Link to post
Share on other sites

Podłącz go do jakiegoś AVR i spróbuj coś wyświetlić to zobaczysz czy wszystko działa 😉

Udostępnij ten post


Link to post
Share on other sites

Chyba mnie źle zrozumieliście.

Po podłączeniu zasilania, masy i kontrastu przez potencjometr nie dzieje się nic. Jeżeli zaś podłączę VDD do zasilania, a kontrast do masy to wyświetla mi się jedna losowa linijka małych dot'ów,a nie całych kwadratów. Co to może być?

Udostępnij ten post


Link to post
Share on other sites

Pierwsza możliwość - twój wyświetlacz nie jest przystosowany do zasilania 3V3 i potrzebuje 5V.

Druga możliwość - trafiła ci się sztuka która wymaga ujemnego napięcia zasilania dla kontrastu. Choć to mało prawdopodobne.

Z drugiej strony jak podłączysz VDD z V0 to tak jakbyś miał potencjometr w skrajnym położeniu do plusa. Spróbuj sobie wziąźć inny potencjometr.

Udostępnij ten post


Link to post
Share on other sites

Co do pierwszej możliwości to w nocie katalogowej jest napisane, że wyświetlacz jest przystosowany do napięć od 2.7 do 5.5, więc pierwszą możliwość odrzucam. Co do drugiej, to tak jak powiedziałeś raczej mało prawdopodobne, ale spróbuję. Jednak propozycji, bym zmienić potencjometr nie rozumiem...

Udostępnij ten post


Link to post
Share on other sites

Tzn. chyba jednak bez tego ujemnego zasilania kontrastu przy 3V ci się nie obędzie.

Trochę jeszcze poszperałem i przy 3V3 możesz mieć problem z tym kontrastem. Ogólnie przejrzyj sobie ten temat:

http://elm-chan.org/docs/lcd/lcd3v.html

Tutaj też sobie zerknij, chyba nawet walczą z tym samym modelem LCD:

http://www.elektroda.pl/rtvforum/topic1885179.html#9023595

Udostępnij ten post


Link to post
Share on other sites

A nie prościej zasilić wyświetlacz z 5v. Konwersji napięć robić nie musisz.

Udostępnij ten post


Link to post
Share on other sites

Ok, dzisiaj podłączyłem do 5V wraz z V0 regulowanym od 0 do 5 i nadal nic się nie pojawiło. Jakieś sugestie?

P.S. Jak już mówiłem, podłączyłem VSS,VDD oraz V0.

Udostępnij ten post


Link to post
Share on other sites

Odświeżam.

Naprawdę nikt nie spotkał się z takim problemem? Czy możliwym jest, że wyprowadzenia są ułożone inaczej niż w nocie katalogowej? Czy to tylko oznacza wyświetlacz do kosza? Wiedziałem, że z tym wyświetlaczem będzie opornie, ale nie aż tak 😋

EDIT:

Ha! Jeszcze lepiej. Jak podłączę zasilanie 5V do VDD, a masę do rzekomego kontrastu to wtedy mam tak jak u Radzia, czyli wszystkie pola z wszystkimi dot'ami zapalone... Co to znaczy? 😃

Udostępnij ten post


Link to post
Share on other sites

wyświetlacz masz na pewno sprawny, podeślij notę katalogową lub nazwę wyświetlacza, może źle podłączasz.

Na 100% żeby sprawdzić czy działa to podłączyć pod uC.

pozdrawiam

Udostępnij ten post


Link to post
Share on other sites

Nota katalogowa

Ciężko podłączyć mi to pod uC, bo to mój pierwszy wyświetlacz, nie mam żadnego programu do obsługi jakiegokolwiek wyświetlacza, tym bardziej żadnej biblioteki. Wszystko muszę stworzyć sam, ale ciężko cokolwiek tworzyć nie mogąc go podłączyć za pomocą 3 kabli...

Udostępnij ten post


Link to post
Share on other sites

Ja mam troche inny problem :/

Kupiłem LCD JHD 162A, podłączyłem do uC i:

za 1 razem nic > pokręciłem trochę potencjometrem i było OK

lcd działał jak należy..

włączam drugi raz też jest OK

ale za którymś razem litery były jakieś bledsze, musiałem na chwile odwrócić się do kompa, a jak wróciłem do lcd to nie pokazywał nic :/ kręce potencjometrem i dalej nic podłączam VEE do 5V i nic, przy podłączeniu do masy nic się nie zmieniło... wyświetlacz nie pokazuje dosłownie NIC nawet kwadracików w pierwszej lini po podłączeniu go tylko do zasilania...

Co robić? kupić nowy, czy da się coś zrobić?

Udostępnij ten post


Link to post
Share on other sites

Z czego zasilasz układ. Im niższe napięcie tym wyświetlacz działa coraz gorzej.

Udostępnij ten post


Link to post
Share on other sites

miałem podobnie nawet kupiłem nowy lcd a tu dalej to samo okazało sie że mam akumulatorki słabe

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij, aby zacząć pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...