Skocz do zawartości
olinpus

Pierwszy robocik-potrzebny prosty i zrozumiały schemat.

Pomocna odpowiedź

Witam.

Jestem nowy na forum więc wszystkim dzień dobry 😃.

Zbudowałem do szkoły wykrywacz metali i teraz potrzebuje robota który jeździłby po wyznaczonej linii. Niestety nie jestem obyty z tematem i potrzebuje prosty schemat. Serwa już mam, laminat również. Co jeszcze będzie mi potrzebne aby stworzyć robocika? Jest jakiś prosty schemat na budowę tego? Jeśli ktoś byłby mi wstanie to jasno wyłumaczyć to proszę o kontakt GG: 10157876 albo odpowiedzi w temacie.

Pozdrawiam Maciej. 😉

__________

Komentarz dodany przez: Treker

Udostępnij ten post


Link to post
Share on other sites

Już koledze pomogłem na GG (mam przynajmniej taką nadzieję).

  • Lubię! 1

Udostępnij ten post


Link to post
Share on other sites

Witam.

Robot już prawie skończony, zostało mi przylutować CNY70. Niestety nie wiem w którą stronę.

Na pewno "wcięcia" w obudowie mają być na górze i na dole. A napis na obudowie ma być z prawej czy z lewej?

Pozdrawiam Maciej. 😉

Udostępnij ten post


Link to post
Share on other sites

Dlaczego tak porozrzucałeś elementy po tej płytce? Daj je bliżej siebie to będziesz miał mniejszy gabaryt. Zwróć uwagę na odległość pomiędzy czujnikami. Nie wydaje Ci się, że są zbyt daleko od siebie? Aby robot wykrył linię będzie musiał się obrócić o zdecydowanie zbyt duży kąt.

Przeprojektuj płytkę dając czujniki i elementy bliżej siebie.

Udostępnij ten post


Link to post
Share on other sites

Hey

Puściłeś masę do L293 b.cieniutką ścieżeczką między pinami jumpera a przez nią będą płynęły główne prądy do silników. Być może w tym przypadku ta ścieżka okaże się wystarczająca ale na przyszłość radzę projektować tak: w pierwszej kolejności grube ( w miarę ) i możliwie krótkie ścieżki do (+) i (-) Uz a następnie sygnałowe.

Przydałby się też C filtrujące Uz.

Udostępnij ten post


Link to post
Share on other sites

Na wszelakie modyfikacje płytki już niestety za późno 😥 Płytka już jest gotowa, wszystko polutowane i tylko Cny70 został, czy ktoś mi podpowiem w którą stronę go przylutować?

Udostępnij ten post


Link to post
Share on other sites

Przecież masz tam napisane "marking area" na schemacie, czyli strona, gdzie masz napisy.

Udostępnij ten post


Link to post
Share on other sites

Wielkie dzięki za odpowiedź. O to mi chodziło. 😉 Wieczorem dam znać czy działa tak jak należy.

[ Dodano: 23-10-2011, 15:08 ]

Niestety coś jest nie tak. Nie pojawia mi się napięcie na ścieżkach do silników. Ktoś coś może pomóc?

Udostępnij ten post


Link to post
Share on other sites

A jest na pinach masa / +Uz 293 ? Podejrzewam przerwę w ścieżce o której poprzednio wspomniałem.

Udostępnij ten post


Link to post
Share on other sites

Na jakich pinach? 🙄 Może powiedz mi w którym miejscu mam zmierzyć to będzie mi o wiele łatwiej. :->

Udostępnij ten post


Link to post
Share on other sites

Nie wiedziałem że jesteś aż tak początkujący. Nóżki układu scalonego popularnie nazywa się pinami, wszystko masz przed oczami kawa na ławę, mam nadzieję że jakiś miernik też. Jak nie, to może masz jakiegoś LED-a i jakiegoś oporka z przedziału np. 220Ω do 4,7kΩ. Daj LED-owi w szereg jakiś z tego przedziału, podłącz do baterii i sprawdź czy świeci. Możesz nim sprawdzić na pinach 293 czy dochodzi do niego Uz ( Uzasilania ). Mam nadzieję że nie będziesz pytał "których pinów" tylko do tego dojdziesz sam.

Udostępnij ten post


Link to post
Share on other sites

Niestety w temacie elektroniki jestem blady. Sprawdziłem i na tych ścieżkach pojawia się napięcie wiec błąd musi leżeć gdzieś indziej.

Udostępnij ten post


Link to post
Share on other sites

Układ jest z serii "tak prosty że nie ma prawa nie działać". Nie zrobiłeś go w SMD ( montażu powierzchniowym ) więc nie powinieneś mieć problemów ze sprawdzeniem samego 293 + silniczki. Zacznij od sprawdzenia czy masz prawidłowe luty - czy nie ma gdzieś zwarć. Przygotuj sobie kilku centrymetrowe druciki, rzuć okiem na DS ( datasheet tj. dokumentację tego układu ), spisz na który pin co trzeba podać ( tj. podłączyć do masy lub do +Uz ) i sprawdź najpierw jedną a później drugą połówkę układu. Na wszelki wypadek od CNY odlutuj oporniki, wystarczy po jednej nóżce.

Udostępnij ten post


Link to post
Share on other sites

Przyczyna chyba po części znaleziona. Jeden z rezystorów 100R bardzo się grzeje. Co może być przyczyna?

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...