Skocz do zawartości

Pomocna odpowiedź

Podoba Ci się ten projekt? Zostaw pozytywny komentarz i daj znać autorowi, że zbudował coś fajnego!

Masz uwagi? Napisz kulturalnie co warto zmienić. Doceń pracę autora nad konstrukcją oraz opisem.

Gratuluje konstrukcji bardzo przypomina mojego robota którego właśnie co buduję.Ciekawie wygląda.

Udostępnij ten post


Link to post
Share on other sites

Estetyka robota na wysokim poziomie. Widzę, że macie już opony odlewane z silikonu, więc z przyczepnością chyba sobie poradziliście. Czemu zielony? Kolor bardzo ładny, ale dla robota minisumo raczej niezbyt korzystny.

Udostępnij ten post


Link to post
Share on other sites

Nowy, bardzo ciekawy pomysł konstrukcji, bardzo ciekawie się prezentuje, tylko jedno ale czemu zielony? i czemu w projekcie zastosowałeś tylko jeden mostek L298? : ) Tak czy inaczej bardzo fajna konstrukcja i czekam z miłą chęcią na kolejne : )

Udostępnij ten post


Link to post
Share on other sites

Z powodu braku dostępu do ciężkich narzędzi (frezarka, tokarka, szlifierka, a nawet dobra wiertarka) od samego początku zdawaliśmy sobie sprawę , że nie uda nam się zrobić czegoś "niewidocznego" . Dlatego wybraliśmy najbardziej jaskrawy spray metalic jaki udało na się dostać. Poza tym ,jak to juz ktoś kiedys pisał o swoim robocie, ma "lansiarski wygląd" A co do jednego mostka... Konstrukcja w pierwotnym zamyśle miała bazować na dwóch kołach i jakoś tak wyszło 🙂

Udostępnij ten post


Link to post
Share on other sites

Powrzechnie wiadomo ,ze to co działa w domu nie zadziała w pełni na zawodach (przybajmniej tyczy to konstrukcji amatorskich). Dzień przed zawodami czujnik odmowił posłuszeństwa, wymiana go pół godziny przed startem wprowadziła chaos i z programu zaczęły znikac kolejne linie kodu ponieważ nie mogliśmy zlokalizować przyczyny nieprawidłowego działania. W ostateczności wystartowaliśmy jedynie na bocznych czujnikach (10cm)...

Po drugie testując robota na tekturowym ringu nie zdawaliśmy sobie sprawy ,że problemem może być nadmierna prędkość , więc wogóle nie wzięliśmy pod uwagę stosowania PWMa.

Kolejny problem to częstotliwość taktowania... także nie potraktowaliśmy tego poważnie wykorzystując wewnętrzny 1MHz,co zaskutkowało tym, że robot czasem nie widział szybkich obiektów ( oczywiście to także wina nie zastosowania przerwań) . No i główny problem- stosowanie funkcji delay, która oślepia robota.

Udostępnij ten post


Link to post
Share on other sites

sarnecki, to, że robot nie widział szybkich obiektów raczej nie było spowodowane taktowaniem, ale powolnym czujnikiem - analogowe sharpy mają czas reakcji rzędu 40ms, to dużo za dużo 😉 340K już troszkę lepiej, bo 8ms, nie wiem jak te maluszki 10cm.

Udostępnij ten post


Link to post
Share on other sites

Wiem , że na jednym ze zdjęć widać analogowego sharpa lecz w ostateczności nie został on zastosowany i wszystkimi czujnikami były szybkie cyfrówki. Nie sądzę więc ,że 8ms czasu propagacji było głównym problemem...

Udostępnij ten post


Link to post
Share on other sites

A jednak. Skoro 8ms nie było głównym problemem, to 1MHz tym bardziej nie, chyba, że rzeczywiście kod obfituje w delaye w najmniej odpowiednich miejscach.

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Napisz odpowiedź...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...