Skocz do zawartości
karkarkar1

Skręcanie platformy jezdnej

Pomocna odpowiedź

Nie, nie trzeba, wystarczy poszukać. Na samym dole po prawej stronie masz "Postage table"

Udostępnij ten post


Link to post
Share on other sites

No to ktoś je ma dla Ciebie założyć, czy jak?

Udostępnij ten post


Link to post
Share on other sites

Nie, po prostu nie chcę zakładać konta nie wiedząc czy będę na 100% kupował.

Dzięki grabki, już sprawdziłem 😉

Jeszcze powtórzę pytanie z poprzedniego postu: czy na tych http://botland.com.pl/kulki-podporowe-metalowe/137-ball-caster-pololu-1-2-metalowy.html nie pojedzie? Wychodzą mimo wszystko zdecydowanie taniej, a budżet mam dość okrojony 😐

Udostępnij ten post


Link to post
Share on other sites

A wg mnie to zamiast dopytywać się w ciemno o kółka zamieściłbyś jakieś zdjęcie tej platformy, cokolwiek napisał o sterowaniu silnikami.

To co napisał Harnaś do mnie nie przemawia, bo obracanie "ręcznie" i robota jego samoczynne obrócenie się wcale nie muszą iść w parze, przykład: https://www.forbot.pl/forum/topics7/wielozadaniowy-skoczek-vt8424.htm Podobna konstrukcja, brak skrętnych kół, brak gąsienic a jednak się obraca.

Następny przykład: http://www.pololu.com/catalog/product/1560

Tak więc ja uważam że problem leży gdzie indziej i omni koła nic nie pomogą.

Udostępnij ten post


Link to post
Share on other sites

Nie mam jak zrobić zdjęć, jednak narysowałem w Paincie schematyczny rysunek.

Najpierw próbowałem tak (wersja z czterema silnikami):

Skręcałem w taki sposób jak czołg, czyli np. koła po lewej stronie kręcą się do tyłu, a prawe do przodu. Niestety, robot praktycznie stoi w miejscu.

Później próbowałem tak (wersja z kołem skrętnym):

Sterowanie praktycznie to samo: jedno koło do tyłu, drugie do przodu. I tak jak wcześniej pisałem, jak koło skrętne jest ustawione w kierunku skręcania, to platforma skręca, ale jak koło jest ustawione w innym kierunku, to platforma nie daje rady go "przełamać", trzeba jej pomóc (pchnąć ją delikatnie w kierunku skręcania) i wówczas zaczyna skręcać.

To mnie jednak nie satysfakcjonuje, platforma musi jeździć samoczynnie, bez pomocy z zewnątrz...

Tak więc szkoda by było gdyby przez ten problem całe prace się zakończyły...

Udostępnij ten post


Link to post
Share on other sites

karkarkar1, aż się nie chce wierzyć w to co piszesz, ale biorąc pod uwagę zachowanie całości to jedyne co przychodzi mi do głowy to sterowanie silnikami ze zbyt małym napięciem bądź zbyt małą wydajnością prądową źródła zasilania bądź mostków. Jeśli nie napiszesz coś więcej o tym czym zasilasz silniki i przez jaki mostek to chyba pozostaje tylko wróżenie z fusów.

Udostępnij ten post


Link to post
Share on other sites

karkarkar1, no to już masz odpowiedź dlaczego twoja platforma nie ma siły się obrócić. Ten mostek daje 2A na silnik, natomiast silniki z wkrętarek pobierają pewnie powyżej 10A (zgaduję, choć pewnie jeszcze więcej).

Udostępnij ten post


Link to post
Share on other sites

Ja zwrócę uwagę na jeszcze jedno: jeśli robot ma rzeczywiście takie proporcje to przy skręcaniu będą potężne opory, tak czy siak warto się zastanowić czy nie dałoby się tego jakoś lepiej zrobić, nawet gąsienice są lepsze.

Udostępnij ten post


Link to post
Share on other sites

OK, dzięki.

Najpierw podłączę silniki bezpośrednio do zasilania (pomijając mostek H) i zobaczę czy skręca 😉 Jak tak to będę miał pewność że trzeba mocniejsze mostki H i będę robił prawdopodobnie te z linku podanego przez Granata 🙂

Edit: Dokładne wymiary ramy to 37cm x 50cm.

Udostępnij ten post


Link to post
Share on other sites

A czym zasilasz? Na pewno potrzeba mostki które mają większy prąd maksymalny, też ostatnio myślałem nad takim mostkiem bo się przymierzam również do tych silników. Pamiętaj że im bliżej rozmieścisz przedni napęd i tylni napęd od siebie tym robot będzie bardziej skrętny niż jak będzie długi i wąski.

Udostępnij ten post


Link to post
Share on other sites

Zasilam albo zasilaczem na którym mam możliwość regulacji napięcia albo akumulatorem AGM 12v 7Ah.

Sprawdziłem napięciem ok. 3V, skręca idealnie, a nawet nieco za szybko 🤯

Więc wina mostka H, dzięki Sabre, pomogłeś, i to dużo :->

Udostępnij ten post


Link to post
Share on other sites

Jeżeli przy 3V skręca dobrze to zmierz chwilowy pobór prądu jeżeli będzie mniejszy niż 2A to może masz po prostu uwaloną sztukę.

Udostępnij ten post


Link to post
Share on other sites

Dołącz do dyskusji, napisz odpowiedź!

Jeśli masz już konto to zaloguj się teraz, aby opublikować wiadomość jako Ty. Możesz też napisać teraz i zarejestrować się później.
Uwaga: wgrywanie zdjęć i załączników dostępne jest po zalogowaniu!

Gość
Dołącz do dyskusji! Kliknij i zacznij pisać...

×   Wklejony jako tekst z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Twój link będzie automatycznie osadzony.   Wyświetlać jako link

×   Twoja poprzednia zawartość została przywrócona.   Wyczyść edytor

×   Nie możesz wkleić zdjęć bezpośrednio. Prześlij lub wstaw obrazy z adresu URL.


×
×
  • Utwórz nowe...